APN Editor is disabled when cellular data is off

Bug #1388046 reported by Alfonso Sanchez-Beato on 2014-10-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
High
Jonas G. Drange
ubuntu-system-settings (Ubuntu RTM)
Undecided
Unassigned

Bug Description

APN editor is not available when cellular data is disabled for the SIM. APN editor should be enabled even if we have not activated data yet. We should let the user enter/check the APN data before enabling data if he wishes so.

Steps to Reproduce:

Go to System Settings -> Cellular -> Disable Cellular data ( or try to access APN Editor for SIM that's not selected for cellular data )

Now try to access the APN Editor.

Expected results:
The APN Editor can be used.

Actual results:
"APN" stays grey and I cannot enter APN data. See attached screenshot

It may save time to fix this bug at the same time as bug #1388044.

Related branches

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
status: New → Confirmed
description: updated
Matthew Paul Thomas (mpt) wrote :

Originally, I had specified that "On the carrier screen, the 'APN' item should be insensitive whenever the SIM is not associated with a carrier."

But then I was told that which APN you use is independent of which carrier you use. So I removed that restriction as part of the design for bug 1388044.

This bug report seems to be expecting a third behavior: that you should be able to change the APN "when switching to Manually" -- and presumably, not when the carrier is Automatic.

So, which is correct? You should be able to specify an APN manually:
(A) at any time, even when there is no carrier (e.g. you're in a tunnel)
(B) whenever you're connected to any carrier
(C) whenever you're connected to a manually-chosen carrier.

@mpt, right, I was confused when I reported the bug, and thought that the "Manually"/"Automatically" switches referred to the APN. So I'll try to clarify this.

The APN is a set of configuration data needed to open a cellular data connection. This data is operator specific, but not network specific. That is, the data depends on who you pay at the end of the month, not on the network you are registered in at a given moment. Specifically, the APN does not change when you are roaming and you are not connected to your home network. Operators connect to each other so when you open a cellular data connection the APN data travels through the visited network to your operator so it validates it.

As the APN data is static you should be able to edit it whenever the phone is powered and has a SIM card (even if you are not registered in any network at that moment), as with the data on the SIM you can know who is your operator.

I just updated the bug summary. I agree with Alfonso, if the phone is powered and the SIM is accessible, then the APN Editor should be available.

summary: - Cannot edit APN when switching to Manually for slot 2
+ APN Editor is sometimes disabled when it should be available
Tony Espy (awe) on 2015-03-18
description: updated
description: updated
Tony Espy (awe) on 2015-03-18
description: updated
tags: added: apn connectivity
Tony Espy (awe) wrote :

@Alfonso

Thanks for the update in comment #4, however the "Steps to reproduce" in the description are still not clear.

Also, after some further consideration, changing the Internet when currently not registered to a carrier will not work at this time, as we rely on NetworkManager to connect to an APN when it's selected, and NM to remember this based upon it's last-connect time.

I'm not sure we can make this work until we resolved bug #1361864 ( add a "Tag" or "Preferred" attribute to GPRS contexts ).

Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Incomplete
assignee: nobody → Alfonso Sanchez-Beato (alfonsosanchezbeato)
description: updated

I have edited the description and just left the case of APN editor disabled when cellular data is off.

The other two cases were wrong, I was not able to reproduce them having data enabled at the same time, so they were red herrings. Also, I was confused initially and thought that manually/automatically was referring to APNs instead of network.

In any case I think the bug is still valid: APN editor should be enabled even if we have not activated data yet. We should let the user enter/check the APN data before enabling data if he wishes so.

summary: - APN Editor is sometimes disabled when it should be available
+ APN Editor is disabled when cellular data is off
description: updated
Bill Filler (bfiller) on 2015-03-27
Changed in ubuntu-system-settings (Ubuntu):
status: Incomplete → In Progress
assignee: Alfonso Sanchez-Beato (alfonsosanchezbeato) → Jonas G. Drange (jonas-drange)
Changed in canonical-devices-system-image:
milestone: none → ww13-2015
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20150330~rtm-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20150330~rtm-0ubuntu1) 14.09; urgency=medium

  [ jonas-drange ]
  * [cellular/apn] make apn entry enabled always (LP: #1388046)
  * [cellular/apn] no creation of custom contexts on editor exit (LP:
    #1433278)
  * [cellular] apn page does not overwrite empty, provisioned contexts
    (LP: #1415495)
 -- CI Train Bot <email address hidden> Mon, 30 Mar 2015 13:26:48 +0000

Changed in ubuntu-system-settings (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20150401-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20150401-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ jonas-drange ]
  * [cellular/apn] make apn entry enabled always (LP: #1388046)
  * [cellular/apn] no creation of custom contexts on editor exit (LP:
    #1433278)
 -- CI Train Bot <email address hidden> Wed, 01 Apr 2015 14:09:52 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments