[cellular] Setting carrier selection to 'Manual' does not persist

Bug #1388044 reported by Alfonso Sanchez-Beato on 2014-10-31
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Canonical Devices Products
Ubuntu UX
Critical
Matthew Paul Thomas
ubuntu-system-settings (Ubuntu)
High
Jonas G. Drange
ubuntu-system-settings (Ubuntu RTM)
High
Unassigned

Bug Description

To reproduce this:

1. Go to to Cellular -> Carriers -> SIM 1, check, that the current option is "Automatically", set the option in "Choose carrier:" to "Manually"
2. Go back to Cellular
3. Go again to Carriers -> SIM 1. The option is set still to "Automatically"

This happens even after re-starting system-settings.

$ system-image-cli -i
current build number: 139
device name: krillin
channel: ubuntu-touch/ubuntu-rtm/14.09-proposed
last update: 2014-10-31 08:58:51
version version: 139
version ubuntu: 20141031
version device: 20141028-3ca60be
version custom: 1414598646

Related branches

summary: - APN editor does not keep its settings
+ [cellular] Setting carrier selection to 'Manual' does not persist
description: updated
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Jonas G. Drange (jonas-drange)
importance: Undecided → Critical
tags: added: ota-1 rtm14
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
importance: Undecided → Critical
Matthew Paul Thomas (mpt) wrote :

Updating the wireframes will take a while, but the solution in brief:

* "APN"/"APNs" should be promoted to the top-level "Cellular" screen, immediately below "Carrier"/"Carrier".

* With APNs out of the way, the way of triggering a search for carriers should be by entering the "Carrier" screen (single SIM) or the "SIM x" screen (multi-SIM). The search should stop if you exit the screen.

* The list of carriers should always start with "Automatic", followed by whichever carriers have been detected so far. Whenever "Automatic" is currently selected, it should have as its value the name of the automatically chosen carrier, or "None" if none has been chosen yet.

Since the carrier scan (a) may take minutes, but (b) may be interrupted at any time, probably there should be a spinner somewhere. To decide where to put it, I need to know: Does a carrier scan ever "finish"? Or does it just continue indefinitely until you exit?

Changed in ubuntu-ux:
status: New → In Progress
Jonas G. Drange (jonas-drange) wrote :

> Does a carrier scan ever "finish"? Or does it just continue indefinitely until you exit?

Yes, sometimes after seconds, sometimes after (literally) minutes.

Jonas G. Drange (jonas-drange) wrote :

> * "APN"/"APNs" should be promoted to the top-level "Cellular" screen,
> immediately below "Carrier"/"Carrier".
How will this be laid out in single and multi SIM scenarios?

Matthew Paul Thomas (mpt) wrote :

Sorry for the typo. By "immediately below 'Carrier'/'Carrier'", I meant "immediately below 'Carrier'/'Carriers'". That is, immediately below the 'Carrier' item in the single-SIM layout, and immediately below the 'Carriers' item in the multi-SIM layout".

Matthew Paul Thomas (mpt) wrote :

Oh, I see what you mean ... Where is the access point for the screen showing the APN for a given SIM in the dual-SIM case. I guess (A) "APNs" could be a screen that looks almost identical to the "Carriers" screen, containing only one item for each SIM, drilling down to the APN screen for that SIM. That would be clear, but a bit laborious.

Alternatively we could merge them into a single screen titled "Carrier & APN" (single SIM) or "Carriers & APNs" (dual SIM). That screen could either:
(B) contain a "Carriers" section with one item for each SIM, followed by an "APNs" section with an item for each SIM; or
(C) contain a section for each SIM, each with one "Carrier" item followed by one "APN" item.

At least you can implement the carrier scan part while I figure that out...

Jonas G. Drange (jonas-drange) wrote :

> The search should stop if you exit the screen.
We cannot stop a scan once in progress.

As Jonas points out, once the scan starts it cannot be stopped. But I do not see this as an issue: that is done in the background, and results could be collected later. In fact, there is a DBus call in ofono named GetOperators() that will show the result of the last scan.

Due to this behaviour, I think it makes sense to have a button to manually start a scan of the spectrum.

There is also a peculiarity in ofono interface that can condition GUI. You can either select to register to the "default" network (that is, automatically) or to a given network (which is the equivalent to manually). What I mean is that showing options Automatically/Manually maybe does not make much sense: it could be more a selection like:

* Automatic
* Network 1
* Network 2
...
* Network N
- Button for refreshing networks

I think this is similar to what @mpt wants, anyway.

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Triaged
Matthew Paul Thomas (mpt) wrote :

Specification updated. <https://wiki.ubuntu.com/Networking?action=diff&rev2=248&rev1=247> The resulting design is actually simpler, and more consistent between single and dual SIM. However, it does introduce three new strings: "Carrier & APN", "Carriers & APNs", and "Choose carrier:". If we're past string freeze, you might need to temporarily use "Carrier", "Carrier", and, "Carrier" respectively.

Changed in ubuntu-ux:
status: In Progress → Fix Committed
description: updated
Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → In Progress
Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Bill Filler (bfiller) on 2014-12-08
Changed in ubuntu-system-settings (Ubuntu):
importance: Critical → High
Changed in ubuntu-system-settings (Ubuntu RTM):
importance: Undecided → High
tags: added: settings-ww51

LP bug #1355705 is related to this one.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20141211-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20141211-0ubuntu1) vivid; urgency=low

  [ jonas-drange ]
  * [cellular/carriers] new Carrier & APN entry, as well as a major
    refactor of carrier selection code warranted by the design change.
    (LP: #1388044)
 -- Ubuntu daily release <email address hidden> Thu, 11 Dec 2014 21:15:06 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Bill Filler (bfiller) on 2015-01-14
Changed in canonical-devices-system-image:
milestone: ww51-2014 → ww05-2015
Matthew Paul Thomas (mpt) wrote :

Verified in devel-proposed 15.04 r78. I reported bug 1412504 on the inaccurate strings.

Changed in ubuntu-ux:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in ubuntu-system-settings (Ubuntu RTM):
status: New → In Progress
Dave Morley (davmor2) wrote :
Víctor R. Ruiz (vrruiz) wrote :
Dave Morley (davmor2) wrote :

STEPS:
Pre-requisite:
Sim from another country (in my case USA T-mobile payg)
Spare sim slot

1. Insert the sim into the spare sim slot
2. Turn the phone on
3. Goto Settings→Cellular→Carriers
4. Select the sim
5. Wait for the list to fill
6. Select a carrier (In my case T-Mobile-uk)
7. Wait till it connects
8. Close settings
9. Open Settings→cellular→carriers
10. It is now on Vodafone-uk
11. After the spinner stops it is then on O2-uk
12. If I close the settings app and return once more
13. O2 is now missing from the list and automatic is hi-lighted instead.

Dave Morley (davmor2) wrote :

EXPECTED:
I expected it to remain on T-mobile

ACTUAL:
It swapped about all over the place before settling on an operator I didn't select

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20150122~rtm-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20150122~rtm-0ubuntu1) 14.09; urgency=low

  [ Ken VanDine ]
  * [cellular/carriers] new Carrier & APN entry, as well as a major
    refactor of carrier selection code warranted by the design change.
    (LP: #1388044)
  * [bluetooth] Show bluetooth address instead of name while it's not
    detected; to be updated once available. (LP: #1382767)

  [ jonas-drange ]
  * Make currently active connection forgettable.
 -- Ubuntu daily release <email address hidden> Thu, 22 Jan 2015 01:39:48 +0000

Changed in ubuntu-system-settings (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers