Bluetooth device with no name leads to details page with no header, no way to go back

Bug #1382767 reported by Oliver Grawert on 2014-10-18
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
ubuntu-system-settings (Ubuntu)
Medium
Mathieu Trudel-Lapierre
ubuntu-system-settings (Ubuntu RTM)
High
Unassigned

Bug Description

When tapping on a freshly detected device in the Bluetooth settings the following details page has no header so there is no way to go back to the settings anymore.

Related branches

Sebastien Bacher (seb128) wrote :

Thanks, can't confirm that but Oliver said the device has no name which might be a case not handled correctly

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Low
summary: - Bluetooth device details page has no header, no way to go back
+ Bluetooth device with no name leads to details page with no header, no
+ way to go back
tags: added: bluetooth
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in ubuntu-system-settings (Ubuntu):
status: New → In Progress
Changed in ubuntu-system-settings (Ubuntu):
importance: Low → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20141031.2-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20141031.2-0ubuntu1) vivid; urgency=low

  [ Sebastien Bacher ]
  * Tweaks to try to make the section headers and titles closer to the
    design. Use a custom component, with tweaked margins and disabled
    tap effects, for that.

  [ Iain Lane ]
  * Move formatSize into a new Utilities class in the qml context and
    call this from the updates panel to consistently display sizes (LP:
    #1385286)
  * Update to work with UPower >= 0.99 as well as current versions (LP:
    #1330037)

  [ Albert Astals ]
  * i18n++ (LP: #1386730)

  [ William Hua ]
  * Re-translate the UI when reboot is cancelled after language change.
    (LP: #1377984)

  [ jonas-drange ]
  * [cellular] split "Cellular Data" and "Connection type" into two
    separate pieces in the UI for both single and multi SIM (LP:
    #1361226)
  * [wifi] use actiongroup to hide "connect to other networks" (LP:
    #1377076)

  [ Michael Terry ]
  * When the power button is held down, show the shutdown dialog like we
    do in the unity8 shell. (LP: #1381731)
  * Add a Continue button when choosing a passphrase. And fix a few
    other design nits with choosing a password.

  [ Michael Zanetti ]
  * Drop reboot notification label on launcher reset. (LP: #1376707)

  [ Mathieu Trudel-Lapierre ]
  * [bluetooth] Show bluetooth address instead of name while it's not
    detected; to be updated once available. (LP: #1382767)
 -- Ubuntu daily release <email address hidden> Fri, 31 Oct 2014 14:53:52 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Pat McGowan (pat-mcgowan) wrote :

adding rtm task and tags, dupe was targeted

tags: added: ota-1 rtm14
Changed in ubuntu-system-settings (Ubuntu RTM):
importance: Undecided → High
Selene ToyKeeper (toykeeper) wrote :

FWIW, I still see this failing in krillin rtm 176.

Yes, because it was still not landed in RTM -- this is tagged as OTA-1. Will check if it needs to be re-tagged.

Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww05-2015
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu RTM):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20150122~rtm-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20150122~rtm-0ubuntu1) 14.09; urgency=low

  [ Ken VanDine ]
  * [cellular/carriers] new Carrier & APN entry, as well as a major
    refactor of carrier selection code warranted by the design change.
    (LP: #1388044)
  * [bluetooth] Show bluetooth address instead of name while it's not
    detected; to be updated once available. (LP: #1382767)

  [ jonas-drange ]
  * Make currently active connection forgettable.
 -- Ubuntu daily release <email address hidden> Thu, 22 Jan 2015 01:39:48 +0000

Changed in ubuntu-system-settings (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers