[oobe] Shutdown dialog does not appear in welcome wizard

Bug #1381731 reported by Michael Terry on 2014-10-15
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Canonical Devices Products
Ubuntu UX
High
Olga Kemmet
ubuntu-system-settings (Ubuntu)
High
Michael Terry
ubuntu-system-settings (Ubuntu RTM)
High
Michael Terry
unity8 (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu RTM)
Undecided
Unassigned

Bug Description

If you hold down the power button in the wizard, you have to wait until the phone hard-shuts off. But a shutdown dialog should appear like it does in the unity8 shell.

Related branches

Michael Terry (mterry) wrote :

I'm going to add a unity8 task since its dialog code isn't marked for translation when used from an outside application like the wizard.

Michael Terry (mterry) on 2014-10-15
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
tags: added: rtm14
Olli Ries (ories) on 2014-10-22
tags: added: touch-2014-10-30
Olga Kemmet (olga-kemmet) wrote :
Changed in ubuntu-ux:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Olga Kemmet (olga-kemmet)
summary: - Shutdown dialog does not appear in welcome wizard
+ [oobe] Shutdown dialog does not appear in welcome wizard
Michał Sawicz (saviq) on 2014-10-30
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
Changed in unity8 (Ubuntu RTM):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01+15.04.20141030~rtm-0ubuntu1

---------------
unity8 (8.01+15.04.20141030~rtm-0ubuntu1) 14.09; urgency=medium

  [ Michael Terry ]
  * Provide 'passphrase' as a field of Components.Lockscreen
  * Fix a race between Qml loading and DBus registration that caused
    problems when jenkins tried to unlock the phone.
  * Set domain explicitly for the Dialogs component because the welcome
    wizard wants to import it. (LP: #1381731)
  * When greeter or lockscreen has focus, show active call panel. (LP:
    #1378872)

  [ Ted Gould ]
  * Set the default OOM score for the dash (LP: #1379786)

  [ Michał Sawicz ]
  * Revert lp:~unity-team/unity8/flickables-speed-workaround to avoid
    risk in RTM.
  * Updated behaviour for zoomable image, workaround for sourcesize (LP:
    #1333187)

  [ Michael Frey ]
  * Added a check for Proximity to determine if we show the lock screen.
    (LP: #1378012)

  [ Ying-Chun Liu ]
  * Add non-interactive code into GenericScopeView. (LP: #1384441)

  [ Mirco Müller ]
  * Also use modal nature of snap-decision notifications when
    greeter/lockscreen is shown. This fixes LP: #1378827. (LP: #1378827)

  [ Michael Zanetti ]
  * Make the launcher update on dconf changes (LP: #1376707)
  * exit spread on background tap (LP: #1368261)
  * Use an index instead of a scope id in DashCommunicator (LP:
    #1376044)

  [ Andrea Cimitan ]
  * Updated behaviour for zoomable image, workaround for sourcesize (LP:
    #1333187)

  [ Daniel d'Andrada ]
  * Make TouchGate synthesize QMouseEvents for mouse-based target items
  * Don't specify a distanceThreshold as it conflicts with
    hintDisplacment
 -- Ubuntu daily release <email address hidden> Thu, 30 Oct 2014 21:43:42 +0000

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.01+15.04.20141030-0ubuntu1

---------------
unity8 (8.01+15.04.20141030-0ubuntu1) vivid; urgency=medium

  [ Michael Terry ]
  * Provide 'passphrase' as a field of Components.Lockscreen
  * Fix a race between Qml loading and DBus registration that caused
    problems when jenkins tried to unlock the phone.
  * Set domain explicitly for the Dialogs component because the welcome
    wizard wants to import it. (LP: #1381731)
  * When greeter or lockscreen has focus, show active call panel. (LP:
    #1378872)

  [ Ted Gould ]
  * Set the default OOM score for the dash (LP: #1379786)

  [ Michał Sawicz ]
  * Revert lp:~unity-team/unity8/flickables-speed-workaround to avoid
    risk in RTM.
  * Updated behaviour for zoomable image, workaround for sourcesize (LP:
    #1333187)

  [ Michael Frey ]
  * Added a check for Proximity to determine if we show the lock screen.
    (LP: #1378012)

  [ Ying-Chun Liu ]
  * Add non-interactive code into GenericScopeView. (LP: #1384441)

  [ Mirco Müller ]
  * Also use modal nature of snap-decision notifications when
    greeter/lockscreen is shown. This fixes LP: #1378827. (LP: #1378827)

  [ Michael Zanetti ]
  * Make the launcher update on dconf changes (LP: #1376707)
  * exit spread on background tap (LP: #1368261)
  * Use an index instead of a scope id in DashCommunicator (LP:
    #1376044)

  [ Andrea Cimitan ]
  * Updated behaviour for zoomable image, workaround for sourcesize (LP:
    #1333187)

  [ Daniel d'Andrada ]
  * Make TouchGate synthesize QMouseEvents for mouse-based target items
  * Don't specify a distanceThreshold as it conflicts with
    hintDisplacment
 -- Ubuntu daily release <email address hidden> Thu, 30 Oct 2014 21:43:42 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
tags: added: ota-1
removed: touch-2014-10-30
Changed in ubuntu-system-settings (Ubuntu RTM):
assignee: nobody → Michael Terry (mterry)
importance: Undecided → Critical
status: New → In Progress
importance: Critical → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20141031.2-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20141031.2-0ubuntu1) vivid; urgency=low

  [ Sebastien Bacher ]
  * Tweaks to try to make the section headers and titles closer to the
    design. Use a custom component, with tweaked margins and disabled
    tap effects, for that.

  [ Iain Lane ]
  * Move formatSize into a new Utilities class in the qml context and
    call this from the updates panel to consistently display sizes (LP:
    #1385286)
  * Update to work with UPower >= 0.99 as well as current versions (LP:
    #1330037)

  [ Albert Astals ]
  * i18n++ (LP: #1386730)

  [ William Hua ]
  * Re-translate the UI when reboot is cancelled after language change.
    (LP: #1377984)

  [ jonas-drange ]
  * [cellular] split "Cellular Data" and "Connection type" into two
    separate pieces in the UI for both single and multi SIM (LP:
    #1361226)
  * [wifi] use actiongroup to hide "connect to other networks" (LP:
    #1377076)

  [ Michael Terry ]
  * When the power button is held down, show the shutdown dialog like we
    do in the unity8 shell. (LP: #1381731)
  * Add a Continue button when choosing a passphrase. And fix a few
    other design nits with choosing a password.

  [ Michael Zanetti ]
  * Drop reboot notification label on launcher reset. (LP: #1376707)

  [ Mathieu Trudel-Lapierre ]
  * [bluetooth] Show bluetooth address instead of name while it's not
    detected; to be updated once available. (LP: #1382767)
 -- Ubuntu daily release <email address hidden> Fri, 31 Oct 2014 14:53:52 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Changed in canonical-devices-system-image:
importance: High → Critical
Michał Sawicz (saviq) on 2014-12-03
Changed in ubuntu-system-settings (Ubuntu RTM):
milestone: none → 14.09-ota-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20141202~rtm-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20141202~rtm-0ubuntu1) 14.09; urgency=low

  [ Ken VanDine ]
  * Refreshed ubuntu-system-settings.pot

  [ Michael Terry ]
  * When the power button is held down, show the shutdown dialog like we
    do in the unity8 shell. (LP: #1381731)
 -- Ubuntu daily release <email address hidden> Tue, 02 Dec 2014 19:41:37 +0000

Changed in ubuntu-system-settings (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Bill Filler (bfiller) on 2014-12-08
tags: added: settings-ww51
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers