cancelling language change incorrectly labels current language using cancelled language

Bug #1377984 reported by James Hunt on 2014-10-06
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
Low
Unassigned

Bug Description

1) Select "Language & Text" in system settings. Note that
    a) current language is "English (United Kingdom)".
    b) the top row shows, "Display language... English (United Kingdom)".
2) Touch "Display language..." and select say "Français (France)".
3) Press "Confirmer" (confirm).
4) A pop-up appears stating that the phone must be rebooted and offers 2 choices "restart now" or "cancel" (both correctly localised).
5) Touch "annuler" to cancel the operation.
6) Note that although the current language should still be "English (United Kingdom)":
    a) the top row now shows "Afficher a langue... English (United Kingdom)". This is incorrect - we cancelled the language change.
    b) the remaining rows are also (incorrectly) all displayed in French.

7) Close system-settings.
8) Restart system-settings
9) Observe that the language used on the menus is now (correctly) English once again.

So, the problem appears to be that system-image itself always applies the new language, even if the user cancels the operation.

Related branches

Sebastien Bacher (seb128) wrote :

Thanks but that's not a settings bug. As the popup informs you, the session locale needs a restart to be updated, since you denied that restart the locale is still english in your locale. We can update the language of the settings itself though, and we do as a preview/so you are able to understand the confirmation dialog, that doesn't persist if you close the application and restart it from the session though...

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Matthew Paul Thomas (mpt) wrote :

I think James is correct here. If changing language requires restart, someone choosing "Cancel" would reasonably expect that to cancel the language change.

Changed in ubuntu-system-settings (Ubuntu):
status: Invalid → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20141031.2-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20141031.2-0ubuntu1) vivid; urgency=low

  [ Sebastien Bacher ]
  * Tweaks to try to make the section headers and titles closer to the
    design. Use a custom component, with tweaked margins and disabled
    tap effects, for that.

  [ Iain Lane ]
  * Move formatSize into a new Utilities class in the qml context and
    call this from the updates panel to consistently display sizes (LP:
    #1385286)
  * Update to work with UPower >= 0.99 as well as current versions (LP:
    #1330037)

  [ Albert Astals ]
  * i18n++ (LP: #1386730)

  [ William Hua ]
  * Re-translate the UI when reboot is cancelled after language change.
    (LP: #1377984)

  [ jonas-drange ]
  * [cellular] split "Cellular Data" and "Connection type" into two
    separate pieces in the UI for both single and multi SIM (LP:
    #1361226)
  * [wifi] use actiongroup to hide "connect to other networks" (LP:
    #1377076)

  [ Michael Terry ]
  * When the power button is held down, show the shutdown dialog like we
    do in the unity8 shell. (LP: #1381731)
  * Add a Continue button when choosing a passphrase. And fix a few
    other design nits with choosing a password.

  [ Michael Zanetti ]
  * Drop reboot notification label on launcher reset. (LP: #1376707)

  [ Mathieu Trudel-Lapierre ]
  * [bluetooth] Show bluetooth address instead of name while it's not
    detected; to be updated once available. (LP: #1382767)
 -- Ubuntu daily release <email address hidden> Fri, 31 Oct 2014 14:53:52 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Fix Released
no longer affects: ubuntu-system-settings (Ubuntu RTM)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers