[background] Preview/Background is black for some images

Bug #1373462 reported by Jean-Baptiste Lallement on 2014-09-24
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Telegram app
Critical
Penk Chen
messaging-app
Fix Released
High
Tiago Salem Herrmann
messaging-app (Ubuntu)
High
Tiago Salem Herrmann
messaging-app (Ubuntu RTM)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Critical
Ken VanDine
unity8 (Ubuntu)
Critical
Michael Terry

Bug Description

With some images the preview and the background is black but the image is fine in the gallery app.

For example picture attached looks correct, but preview and background are black.

TEST CASE:
1. Upload the attached picture to the phone with mtp
2. Go to system-settings / background
3. Tap 'Add an image'
4. Select this image
  -> Verify that the preview is correct
5. Validate your choice,
6. Press the power button twice to show the greeter
  -> Verify that the background is correct

ACTUAL RESULT
Background and preview are black.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubuntu-system-settings 0.3+14.10.20140913-0ubuntu1 [origin: Ubuntu RTM]
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.14.7-0ubuntu1
Architecture: armhf
Date: Wed Sep 24 16:34:18 2014
InstallationDate: Installed on 2014-09-16 (8 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20140916-030205)
SourcePackage: ubuntu-system-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
summary: - [background] Preview/Background is black for some images is black
+ [background] Preview/Background is black for some images
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Critical
Sebastien Bacher (seb128) wrote :

The issue impacts settings and unity and those use standard qt/uitk so if there is an issue it's likely in those components

affects: ubuntu-system-settings (Ubuntu) → ubuntu-ui-toolkit (Ubuntu)
Sebastien Bacher (seb128) wrote :

seems rather content-hub having issues copying those over

affects: ubuntu-ui-toolkit (Ubuntu) → content-hub (Ubuntu)
Sebastien Bacher (seb128) wrote :

not, it's a qt issue, simple testcase

"Item {
    height: 600
    width: 350
    Image {
        anchors.centerIn: parent
        source: "/tmp/bug.jpeg"
        height: parent.height
    }
}"

That fails with the test image on the phone, works on desktop though (so it could be an issue with mir/our backends)

affects: content-hub (Ubuntu) → qtdeclarative-opensource-src (Ubuntu)
Sebastien Bacher (seb128) wrote :

you need a /tmp/bug.jpeg image and can run the it using e.g "QT_SELECT=qt5 qmlscene /tmp/scroll.qml --desktop_file_hint=/usr/share/applications/<somedesk>"

tags: added: touch-2014-10-09
Changed in qtdeclarative-opensource-src (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Ken VanDine (ken-vandine) wrote :

I've reproduced this on both mako and krillin with @seb128's test case using an image created from the krillin camera.

Ken VanDine (ken-vandine) wrote :

Reducing the sourceSize seems to work:

        sourceSize.width: width
        sourceSize.height: height

So maybe the image size is using more memory than it can handle?

Ken VanDine (ken-vandine) wrote :

Here are the exact sizes of the 2 images tested:

Image that is known to not render is 2448x4352
Image that does render is 1836x3264

affects: qtdeclarative-opensource-src (Ubuntu) → ubuntu-system-settings (Ubuntu)
Changed in ubuntu-system-settings (Ubuntu):
status: New → In Progress
Changed in unity8 (Ubuntu):
status: New → Triaged
assignee: nobody → Michael Terry (mterry)
importance: Undecided → Critical
Michael Terry (mterry) on 2014-09-25
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+14.10.20140926-0ubuntu1

---------------
ubuntu-system-settings (0.3+14.10.20140926-0ubuntu1) utopic; urgency=low

  [ Sebastien Bacher ]
  * [storage] use libclick rather than calling the command line (LP:
    #1368967)
  * [storage] tweaks to the disk informations, limit the free space to
    the user available one (excluding the system partitions), don't list
    the external mounts, that's described in the design and is going to
    require work on the categories computation to give correct values
    (LP: #1284247)
  * [about] display the free space value next to the storage label (LP:
    #1335144)

  [ Albert Astals ]
  * Add i18n.tr

  [ jonas-drange ]
  * [wifi] connect to hidden network is now a dialog (LP: #1366005)

  [ Ken VanDine ]
  * Provide more keywords to make search useful (LP: #1370219) (LP:
    #1370219)
  * [background] set sourceSize in the image preview to work around an
    issue loading large images (LP: #1373462)

  [ CI bot ]
  * Resync trunk

  [ Mathieu Trudel-Lapierre ]
  * [bluetooth] Properly handle device types for connection and
    disconnection. (LP: #1369964)
 -- Ubuntu daily release <email address hidden> Fri, 26 Sep 2014 15:32:57 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: Fix Committed → Fix Released
Michael Terry (mterry) wrote :

unity8 (8.00+14.10.20140930.2-0ubuntu1) utopic; urgency=low

  [ Alexandros Frantzis ]
  * Remove stale trusted socket before starting unity8 from upstart (LP:
    #1371597) (LP: #1371597)

  [ CI bot ]
  * Resync trunk

  [ Andrea Cimitan ]
  * Move activity indicator on top of keyboard (LP: #1354519)

  [ Gerry Boland ]
  * Cleanup: Remove unused member and fix small syntax error in
    OrientationLock

  [ josharenson ]
  * Fix lp:1367894 by correcting how the minute value is calculated in
    the panel. (LP: #1367894)

  [ Nick Dedekind ]
  * Fixed DefaultIndicatorPage test. Fixed warnings from test.

  [ Ying-Chun Liu ]
  * Remove maxLineCount in preview. (LP: 1328513) (LP: #1328513)

  [ Michael Terry ]
  * Fix some code that accidentally landed in trunk before it got
    cleaned up. The current code just has some duplication to it that
    should be unified.
  * Implement latest visual designs for passphrase lockscreen.
  * Make it easier to use the Lockscreen component from the welcome
    wizard.
  * Limit how much memory we reserve for the greeter background image,
    allowing giant images to appear correctly.

  [ Daniel d'Andrada ]
  * Add gdbTestComponentName build targets
 -- Ubuntu daily release <email address hidden> Tue, 30 Sep 2014 16:57:28 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released

Also needs to be fixed in messaging-app - previews in MMS messages show a black square as well

Bill Filler (bfiller) wrote :

if you try to share an image taken with the camera via Messaging, the image thumbnail that is inserted in the message is black now. We probably need to apply the same fix as done above setting the source size

Changed in messaging-app (Ubuntu):
importance: Undecided → High
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in messaging-app:
importance: Undecided → High
assignee: nobody → Tiago Salem Herrmann (tiagosh)
Changed in messaging-app (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the scope displayed user pictures also have that issue, does anyone know what project is that?

Victor Tuson Palau (vtuson) wrote :

this impacts telegram image preview, the fix was done for thumbnails in chats, but seems local images (ones sent by you) on the preview

Changed in libqtelegram:
importance: Undecided → Critical
Michał Karnicki (karni) on 2014-10-03
Changed in libqtelegram:
assignee: nobody → Michał Karnicki (karni)
status: New → Fix Committed
assignee: Michał Karnicki (karni) → nobody
assignee: nobody → Penk Chen (penk)
milestone: none → m5

This is starting to get a little tedious - can't the fix be done at a lower
level so that each application doesn't have to make sure it's 'doing it
right'?

On Fri, Oct 3, 2014 at 1:11 PM, Victor Tuson Palau <
<email address hidden>> wrote:

> this impacts telegram image preview, the fix was done for thumbnails in
> chats, but seems local images (ones sent by you) on the preview
>
> ** Also affects: libqtelegram
> Importance: Undecided
> Status: New
>
> ** Changed in: libqtelegram
> Importance: Undecided => Critical
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1373855).
> https://bugs.launchpad.net/bugs/1373462
>
> Title:
> [background] Preview/Background is black for some images
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/libqtelegram/+bug/1373462/+subscriptions
>

Pat McGowan (pat-mcgowan) wrote :

As the size of the image is not known in advance it seems its up to the app per http://qt-project.org/doc/qt-5/qml-qtquick-image.html

Note: Images are often the greatest user of memory in QML user interfaces. It is recommended that images which do not form part of the user interface have their size bounded via the sourceSize property. This is especially important for content that is loaded from external sources or provided by the user.

Penk Chen (penk) on 2014-10-06
Changed in libqtelegram:
importance: Critical → High
importance: High → Critical
Victor Tuson Palau (vtuson) wrote :

This impacts also the photo scope, does the unity8 fix applies to scopes?

Michał Sawicz (saviq) wrote :

The branch I just attached (lp:~unity-team/unity8/croppedImageMinimumSourceSize) fixes this for scope results. If you still find this problem somewhere, please file a separate bug against unity8.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package messaging-app - 0.1+14.10.20141007.1-0ubuntu1

---------------
messaging-app (0.1+14.10.20141007.1-0ubuntu1) 14.09; urgency=low

  [ Bill Filler ]
  * use header in splash screen (LP: #1378379)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Gustavo Pichorim Boiko ]
  * Ship the messaging-app icon together with the package (LP: #1365408)

  [ Tiago Salem Herrmann ]
  * Add initial support for the new information messageType. Notify
    users when the active sim card was switched. (LP: #1356950)
  * Don't show the attachment popup on onClicked(). Update bottom edge
    behavior (LP: #1368718)
  * Add support for sim lock. (LP: #1371661)
  * Fix black image in the mms preview. (LP: #1373462)
  * Make conversations view header fixed.
 -- Ubuntu daily release <email address hidden> Tue, 07 Oct 2014 16:58:07 +0000

Changed in messaging-app (Ubuntu RTM):
status: New → Fix Released
Changed in messaging-app (Ubuntu):
status: Confirmed → Fix Released
Bill Filler (bfiller) on 2014-10-09
Changed in messaging-app:
status: New → Fix Released
Michał Karnicki (karni) on 2014-10-13
Changed in libqtelegram:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers