[system-settings] When brightness is set to automatic, the slider doesn't show current value

Bug #1370791 reported by Leo Arias on 2014-09-18
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Thomas Strehl
Ubuntu UX
High
Matthew Paul Thomas
indicator-power (Ubuntu)
Medium
Charles Kerr
Vivid
Undecided
Unassigned
powerd (Ubuntu)
Vivid
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Medium
Unassigned

Bug Description

On the brightness page, there is a slider to set brightness and a checkbox to set it automatically.

When I select the automatic brightness, I was expecting the slider to show the current brightness level. Instead, it just keeps the old value manually set. I find this a little confusing: I have a slider whose value I can change, but will do nothing while the checkbox is marked, and the value it shows is different from the current brightness of the screen.

<https://wiki.ubuntu.com/BrightnessAndDisplays#Phone>: "Because users have different preferences, the function should also be user-adjustable. This should be achieved by altering the display brightness manually while 'Adjust automatically' is checked."

Related branches

tags: added: qa-daily-testing rtm14 unity8
Changed in ubuntu-ux:
assignee: nobody → Matthew Paul Thomas (mpt)
status: New → Triaged
importance: Undecided → High
summary: - When brightness is set to automatic, the slider doesn't show current
- value
+ [system-settings] When brightness is set to automatic, the slider
+ doesn't show current value
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Matthew Paul Thomas (mpt) wrote :

This has been covered in the spec since April last year, it doesn't require any more design work.

Changed in ubuntu-ux:
status: Triaged → Fix Committed
description: updated
Changed in indicator-power:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Charles Kerr (charlesk)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-power (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
assignee: nobody → Thomas Strehl (strehl-t)
importance: Undecided → Medium
milestone: none → ww22-2015
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

With autobrigthness enabled we need to define the behavior for what happens when the user tries to use the slider:

1 - it works but auto is still on and will reset it
2 - it signals user wants manual settings so disable auto
3 - the slider is disabled but reflects current brightness value

Changed in ubuntu-ux:
status: Fix Committed → Confirmed
Matthew Paul Thomas (mpt) wrote :

That is bug 1314678, which has also been covered in the spec since April 2013: "If it is checked and you adjust the brightness manually, the function that determines the automatic brightness should be adjusted such that, in future, the current ambient light value would result in your just-chosen brightness being chosen automatically." I even drew a bunch of graphs to illustrate how it should work.

If graphs aren't your style, here's an example in text:

If the ambient brightness in your office is X, which results in an automatic brightness of Y, then the brightness slider should show Y (this bug).

If you then move the slider to Z, the brightness should change to Z (bug 1314678).

If you then go out into the street, the brightness should adjust accordingly, because automatic brightness is still on, and the slider should reflect that new brightness (this bug).

If you then go back into your office, the brightness should change to Z, because that's the brightness you last chose for the office's level of ambient light (bug 1314678).

Changed in ubuntu-ux:
status: Confirmed → Fix Committed
Leo Arias (elopio) wrote :

@mpt: awesome solution, that would make me very happy.

Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-power - 12.10.6+15.10.20150522-0ubuntu1

---------------
indicator-power (12.10.6+15.10.20150522-0ubuntu1) wily; urgency=medium

  [ Charles Kerr ]
  * When powerd updates the backlight brightness, update the indicator
    slider to show the new value. (LP: #1370791)

 -- CI Train Bot <email address hidden> Fri, 22 May 2015 17:54:53 +0000

Changed in indicator-power (Ubuntu):
status: Confirmed → Fix Released
Changed in indicator-power (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → Medium
no longer affects: indicator-power
Matthew Paul Thomas (mpt) wrote :

Verified fixed in Ubuntu 15.04 r51. I reported bug 1388094 on the slider not moving smoothly.

Changed in ubuntu-ux:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-power (Ubuntu Vivid):
status: New → Confirmed
Changed in powerd (Ubuntu Vivid):
status: New → Confirmed
dinamic (dinamic6661) wrote :

woa woa woa!!! i thought there is something wrong with my screen! i tried for 2 minutes to adjust the screen brightest only to noticed the "adjust brightness automatically" was ON. this is very ultra confusing! disable the slider when "adjust brightness automatically" is ON

Hi, I think this is not working neither in latest turbo (on rc-proposed) not in latest stable cooler. When automatic brightness is on, moving the slider won't change a thing - regression?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers