Error when trying to update: 'ProcessError: 0 - ErrorInProc...'

Bug #1362282 reported by Kajetan on 2014-08-27
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
Low
Unassigned

Bug Description

I'm having problems with updates lately: When I click on the 'update'-button next to the name of a program in the System Settings the update is downloaded, but is not beeing installed. The error message I get is "ProcessError: 0 - ErrorInProc..." (the message is shortened like this, even in landscape mode). When I click on the 'retry'-button I either get the same error or sometimes 'DBusError: org.freedesktop.DBus.Error.UnknownObject No s...'.

Since I get the same error message for nine updates that could be installed I suspect that there could be a bug in the System Settings. However, a PayUI update installed without an error.

Are there logfiles which could help to pinpoint the problem?

Device: Nexus 4
OS: Ubuntu 14.10 (r203)

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Diego Sarmentero (diegosarmentero)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Yuri (linux-colombi) wrote :

Happens on also on my Nexus 7 (2013) WiFi
Ubuntu 14.04 (r1)
Last updated (when installing): 24/08/2014
Could be related on rights to write on the disk partition (after some googling).

Kajetan (kajetan-krischan) wrote :

After a sudo apt-get upgrade my device stopped booting and I had to re-flash Utopic. However, I was able to create a backup of my home directory (and the log files in it). Right after the flash I was notified about the same updates that couldn't be installed before. However, they could be installed without an error this time.

Nizar Kerkeni (nizarus) wrote :

Have the same bug with my nexus 5 and ubuntu utopic.
Some applications was updated successfully others no with the same error message.

Changed in ubuntu-system-settings (Ubuntu):
assignee: Diego Sarmentero (diegosarmentero) → nobody
importance: Undecided → Low
Jonas G. Drange (jonas-drange) wrote :

Logs are in .cache/upstart/application-legacy-ubuntu-system-settings-.log — are you able to reproduce and attach it to this issue? (I realize this issue is old, sorry about that.)

tags: added: updates
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Incomplete
Kajetan (kajetan-krischan) wrote :

I'm sorry, I don't have the backups of those logs anymore... (And I can't reproduce the issue)

Jonas G. Drange (jonas-drange) wrote :

Okay, sorry about the lag!

Launchpad Janitor (janitor) wrote :

[Expired for ubuntu-system-settings (Ubuntu) because there has been no activity for 60 days.]

Changed in ubuntu-system-settings (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions