[bluetooth] Can't pair PIN-requiring audio devices with Ubuntu Touch

Bug #1355152 reported by Michael Zanetti
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

I tried pairing several devices with my Ubuntu Touch device. All of them fail:

* Nokia-BH 503 (HFP + A2DP + AVRCP)
* Nokia-BH 905i (HFP + A2DP + AVRCP)
* Latest BMW infotainment system (HFP)

All of those devices are found during inquiry. Trying to pair them causes the PIN entry popup to appear on the phone, however, after confirming that it just sits there and waits forever, never completing the pairing process.

Related branches

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Thanks.

This bug belongs to ubuntu-system-settings; I believe this will require some fixes to the agent to properly handle these devices.

Could you please add debug logs from bluez as well as the log for the ubuntu-system-settings app? (/home/phablet/.cache/upstart/application-legacy-ubuntu-system-settings-.log)

affects: bluez (Ubuntu) → ubuntu-system-settings (Ubuntu)
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
importance: Undecided → High
status: New → Triaged
summary: - Can't pair any Bluetooth audio device with Ubuntu Touch
+ [bluetooth] Can't pair PIN-requiring audio devices with Ubuntu Touch
Revision history for this message
Sebastien Bacher (seb128) wrote :

duplicate of bug #1351406?

Revision history for this message
Sebastien Bacher (seb128) wrote :

bug #1347106 seems similar as well

Revision history for this message
Michael Zanetti (mzanetti) wrote :

Hi Mathieu, I can add some logs, but given that this is 100% reproducible you're probably better off just watching the log file while trying to pair something yourself. If you're having troubles with reproducing, let me know and I'll do my best to get meaningful logs.

tags: added: bluetooth
Revision history for this message
Sebastien Bacher (seb128) wrote :
Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+14.10.20140827.1-0ubuntu1

---------------
ubuntu-system-settings (0.3+14.10.20140827.1-0ubuntu1) utopic; urgency=low

  [ Mathieu Trudel-Lapierre ]
  * Fix PIN code or passcode requests by properly matching the tag for
    the original request. (LP: #1355152)
 -- Ubuntu daily release <email address hidden> Wed, 27 Aug 2014 15:27:50 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
pajda (vansionist) wrote :

This bug does affect not only audio devices. Pairing request window never displays, other options not offered. More about my keyboard pairing issue: http://askubuntu.com/questions/625533/how-to-pair-external-bluetooth-keyboard-to-ubuntu-touch-bq-phone

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers