Language list contains blanks and bad characters

Bug #1342326 reported by Renato Araujo Oliveira Filho on 2014-07-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
Medium
William Hua

Bug Description

HOW TO REPRODUCE
===================

1 - Open system settings
2 - Click on Language & Text icon
3 - Click on display language item

Expected
=========

A list of language alphabetically sorted

Current
======

* Language list not sorted alphabetically
* Languages with lowercase letters in the first letter other with uppercase
* Empty items in the beginner of the list.

Related branches

I do not think this is duplicated of bug #1332584, because the problem here is not only the alphabetical sort, there is empty item on the list, some language names is lowercase others uppercase.

The list does not have a standard.

The language name is obscure. For example is difficult to find English since the lanaguage with "E" appear in two different positions. (first in the sections with uppercase letters, then in the lowercase letters section which is after the end of all uppercase letters).

The last entry in the list looks like is a unsupported utf8 value since it shows a list of squares.

Iain Lane (laney) wrote :

I bet the last entry is a font we don't install. Not sure about the blank one(s), and we should maybe do a case-insensitive sort respecting the other rules.

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → William Hua (attente)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
William Hua (attente) on 2014-07-16
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
William Hua (attente) wrote :

The missing font seems to be Korean (ko_KR.utf8), the few un-labeled entries are for ca_ES.utf8@valencia, sr_RS.utf8@latin, and ug_CN.utf8@latin.

summary: - Language list not sorted alphabetically
+ Language list contains blanks and bad characters
Changed in ubuntu-system-settings (Ubuntu):
assignee: William Hua (attente) → Jonas Larsen (jonas)
importance: Undecided → Medium
status: In Progress → Confirmed
assignee: Jonas Larsen (jonas) → Jonas G. Drange (jonas-drange)
tags: added: rtm14
Pat McGowan (pat-mcgowan) wrote :

sorry did not see it was in progress

Changed in ubuntu-system-settings (Ubuntu):
assignee: Jonas G. Drange (jonas-drange) → William Hua (attente)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+14.10.20140718.1-0ubuntu1

---------------
ubuntu-system-settings (0.3+14.10.20140718.1-0ubuntu1) utopic; urgency=low

  [ Ken VanDine ]
  * [phone] Call waiting implementation

  [ Iain Lane ]
  * [sound] Set the index on construction to avoid a disconcerting
    animation when entering the page. (LP: #1342533)
  * Run pylint and pyflakes on the right directory so they actually work
    and fix the errors.
  * revert lenient AppArmor profile since we won't be limiting access to
    ofono in this manner. Furthermore, due to a naive check in media-
    hub-server for the connecting process' profile name, this allows
    system-settings to playback files via media-hub-server again (LP:
    #1342321) (LP: #1342321)

  [ William Hua ]
  * Sort ignoring case, filter out unnamed locales. (LP: #1342326)
  * Set only left and right anchors in language panel. (LP: #1343513)
 -- Ubuntu daily release <email address hidden> Fri, 18 Jul 2014 19:15:36 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers