Sound -> Ringtone does not play the songs

Bug #1342321 reported by Renato Araujo Oliveira Filho on 2014-07-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
High
Iain Lane

Bug Description

Trying to choose a new ringtone does not really play the sound while choosing it.

HOW TO REPRODUCE
===================

1 - Open system settings
2 - Click sound icon
3 - Click on ringtone item
4 - Click in any ringtone in the list

Expected
=========

The ringtone start to play and the button in the top change to "Stop playing"

Current
======

The ringtone does not play and the button in the top change to "Stop playing"

Related branches

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Jonas G. Drange (jonas-drange)
importance: Undecided → High
status: New → Confirmed
tags: added: rtm14
Pat McGowan (pat-mcgowan) wrote :

I am seeing this on the output every time a tone is played:
Creating a new static Service instance
PlaybackStatusChanged signal arrived via the bus.
2014-07-16 15:09:55,176 - WARNING - m_surface is NULL, can't update video texture

Pat McGowan (pat-mcgowan) wrote :

Created a simple app that used an Audio object to play a file and sure enough no sound on the mako, but it does work on desktop.

Pat McGowan (pat-mcgowan) wrote :

This seems suspicious
setting media to: QUrl( "file:///usr/share/sounds/ubuntu/ringtones/Ubuntu.ogg" )

[11:51:15] void AalVideoRendererControl::setupSurface()
m_surface is NULL, can't update video texture

virtual void AalMediaPlayerControl::play()

On Thu, Jul 17, 2014 at 04:02:44PM -0000, Pat McGowan wrote:
> This seems suspicious

FYI, it works on desktop, so I'm very skeptical that this is a bug in
u-s-s.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Iain Lane (laney) wrote :

Looks like it is(!) - a problem in the apparmor profile.

Changed in ubuntu-system-settings (Ubuntu):
assignee: Jonas G. Drange (jonas-drange) → Iain Lane (laney)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+14.10.20140718.1-0ubuntu1

---------------
ubuntu-system-settings (0.3+14.10.20140718.1-0ubuntu1) utopic; urgency=low

  [ Ken VanDine ]
  * [phone] Call waiting implementation

  [ Iain Lane ]
  * [sound] Set the index on construction to avoid a disconcerting
    animation when entering the page. (LP: #1342533)
  * Run pylint and pyflakes on the right directory so they actually work
    and fix the errors.
  * revert lenient AppArmor profile since we won't be limiting access to
    ofono in this manner. Furthermore, due to a naive check in media-
    hub-server for the connecting process' profile name, this allows
    system-settings to playback files via media-hub-server again (LP:
    #1342321) (LP: #1342321)

  [ William Hua ]
  * Sort ignoring case, filter out unnamed locales. (LP: #1342326)
  * Set only left and right anchors in language panel. (LP: #1343513)
 -- Ubuntu daily release <email address hidden> Fri, 18 Jul 2014 19:15:36 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers