"Cancel" button changes language in "Display language" sheet

Bug #1289313 reported by Matthew Paul Thomas on 2014-03-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
Low
Unassigned

Bug Description

Ubuntu Trusty r188

1. Go to System Settings > "Language & Text" > "Display language".
2. Choose a very different language.

What happens: The language of the "Cancel" and "Confirm" buttons both change.

What should happen: The language of the "Confirm" button changes, but the "Cancel" button stays the same.

<https://wiki.ubuntu.com/LanguageAndText#display-language-phone>: "What should change immediately, when you select a different language, is the language of the 'Display language' header and the 'Confirm' button itself, as a preview of what is about to happen."

Sebastien Bacher (seb128) wrote :

Well spotted, I'm unsure we can easily use different locales/languages at the widget level though (it's usually for an application or the currently loaded ui)...

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Low
status: New → Triaged
tags: added: language
Bartosz Kosiorek (gang65) wrote :

I'm unable to reproduce this bug in latest system-settings.

Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → Incomplete
status: Incomplete → Invalid
Sebastien Bacher (seb128) wrote :

that's still an issue on the current bq rc-proposed, how did you test? do you use a language that has translations for those labels?

Changed in ubuntu-system-settings (Ubuntu):
status: Invalid → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers