Bluetooth spinner spins when bluetooth is disabled

Bug #1272317 reported by Dave Morley on 2014-01-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
Low
Mathieu Trudel-Lapierre

Bug Description

Bluetooth setting page has a spinner when the BT is turned off.

Steps to reproduce:
1. Open indicator-bluetooth and turn off bluetooth
2. Open the settings app
3. Select the bluetooth page
4. Note the searching for device spinner is spinning even though the BT is turned off. The found device list are not cleared.

<https://wiki.ubuntu.com/Bluetooth#Devices>: "The list should update every ten seconds, with a spinner showing opposite the label whenever scanning is in progress."

Related branches

Dave Morley (davmor2) on 2014-01-24
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
importance: Undecided → Low
tags: added: maguro mako r146
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report.

Charles, could you have a look to that one?

Changed in ubuntu-system-settings (Ubuntu):
assignee: Sebastien Bacher (seb128) → Charles Kerr (charlesk)
Charles Kerr (charlesk) on 2014-03-16
Changed in ubuntu-system-settings (Ubuntu):
status: New → Triaged
Revision history for this message
Matthew Paul Thomas (mpt) wrote :
description: updated
Revision history for this message
Yuan-Chen Cheng (ycheng-twn) wrote :

Still reproducible in

Device1: Nexus 4
Firmware1: channel utopic rev 106. (20140701-020205)

description: updated
Revision history for this message
Alex Kaluzhny (alex-kaluzhny) wrote :

I would like to suggest raising priority to Medium, because it impacts user experience and was also reported by commercial partner.
Charles, could you please have a look to that one?

tags: added: bluetooth
Changed in ubuntu-system-settings (Ubuntu):
assignee: Charles Kerr (charlesk) → Mathieu Trudel-Lapierre (mathieu-tl)
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+14.10.20140801.2-0ubuntu1

---------------
ubuntu-system-settings (0.3+14.10.20140801.2-0ubuntu1) utopic; urgency=medium

  [ Mathieu Trudel-Lapierre ]
  * Bluetooth UI redesign:
    - Redesign the UI to follow the specification.
    - Create devices only when attempting to connect.
    - Bugfixes for displaying icons for devices.
    - Show new icons for common device types.
    - Support more device types.
    - Show Trusted (known) devices in a separate list from the devices detected
      by Discovery.
    - Allow for a way to forget (unpair) a known device. (LP: #1336197)
    - Follow the state of the Bluetooth adapter for whether Bluetooth
      is enabled. (LP: #1272317)
    - Miscellaneous bug fixes.
  * debian/control: add Build-Depends on libqtdbusmock1-dev and
    libqtdbustest1-dev for Bluetooth testing.

  [ Ken VanDine ]
  * [sound] exposed silentMode and vibrate settings
  * Set anchorToKeyboard in the MainView, to fix issues found on screens
    with multiple input fields. Most noticeable is in the apneditor
    branch that is still being worked on.

  [ CI bot ]
  * Resync trunk

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Michael Terry ]
  * Make the buttons in the password change dialog conform to the color
    scheme preferred by design (green for accept buttons, grey for
    neutral buttons).

  [ jonas-drange ]
  * [cellular] add sim name editor for dual sim scenario
 -- Ubuntu daily release <email address hidden> Fri, 01 Aug 2014 17:10:42 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers