Storage shows same app multiple times (pre-installed and update from click store)

Bug #1265250 reported by Adnane Belmadiaf on 2013-12-31
114
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Bill Filler
ubuntu-system-settings (Ubuntu)
Low
Sebastien Bacher

Bug Description

After a recent upgrade of Shorts/Weather apps using the Update Manager i am seeing two entries of each app on the Storage panel.

root@ubuntu-phablet:/opt/click.ubuntu.com/com.ubuntu.shorts# ll
total 16
drwxr-xr-x 4 clickpkg clickpkg 4096 Dec 18 19:21 ./
drwxr-xr-x 22 clickpkg clickpkg 4096 Dec 31 01:09 ../
drwxr-xr-x 9 clickpkg clickpkg 4096 Dec 11 21:56 0.2.147/
drwxr-xr-x 9 clickpkg clickpkg 4096 Dec 18 19:21 0.2.152/
lrwxrwxrwx 1 clickpkg clickpkg 7 Dec 18 19:21 current -> 0.2.152/

root@ubuntu-phablet:/opt/click.ubuntu.com/com.ubuntu.weather# ll
total 16
drwxr-xr-x 4 clickpkg clickpkg 4096 Dec 18 19:21 ./
drwxr-xr-x 22 clickpkg clickpkg 4096 Dec 31 01:09 ../
drwxr-xr-x 7 clickpkg clickpkg 4096 Dec 11 21:56 1.0.163/
drwxr-xr-x 7 clickpkg clickpkg 4096 Dec 18 19:21 1.0.168/
lrwxrwxrwx 1 clickpkg clickpkg 7 Dec 18 19:21 current -> 1.0.168/

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubuntu-system-settings 0.1+14.04.20131216-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.7-0ubuntu3
Architecture: armhf
Date: Tue Dec 31 23:50:41 2013
InstallationDate: Installed on 2013-12-31 (0 days ago)
InstallationMedia: Ubuntu Trusty Tahr (development branch) - armhf (20131231.1)
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: ubuntu-system-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Adnane Belmadiaf (daker) wrote :
Adnane Belmadiaf (daker) wrote :
summary: - Shorts/Weather displayed twice
+ Shorts/Weather displayed twice in "Storage" screen

what does `click list --manifest' say?

Adnane Belmadiaf (daker) wrote :

Not sure i can provide this, i just reflashed again during the week-end :(

Changed in ubuntu-system-settings (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Adnane Belmadiaf (daker) wrote :

Managed to reproduce it with a newly flashed phone, i opened the update manager, got "Notes" app update, now getting two entries on Storage

Adnane Belmadiaf (daker) wrote :
Adnane Belmadiaf (daker) wrote :

Looking at the source code[0] i see that there is a --all argument, which has two entries of the "Notes" app

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/trusty/ubuntu-system-settings/trusty/view/head:/plugins/about/click.cpp#L50

Iain Lane (laney) wrote :

You can have multiple copies of the same click package installed. Matthew, what should we display in this case?

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
status: Incomplete → Triaged
Matthew Paul Thomas (mpt) wrote :

In what situations would you have multiple copies of the same package installed? Is that something only an engineer or tester would do?

Matthew Paul Thomas (mpt) wrote :

Sorry, I can't do anything more on this without an answer to my question from January.

Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → Confirmed
assignee: Matthew Paul Thomas (mpt) → nobody
Adnane Belmadiaf (daker) wrote :

If i understand this correctly, it happen when you receive an update of any "Preinstalled" app, once you update the app it will have two entries in the system settings since the installation path is different ex :

Preinstalled : /usr/share/click/preinstalled/com.ubuntu.shorts/
Once the first update is applied the path will be : /opt/click.ubuntu.com/com.ubuntu.shorts/

summary: - Shorts/Weather displayed twice in "Storage" screen
+ Storage shows same app multiple times

After few months a usage/updates, here is what u-s-s displays

Adnane Belmadiaf (daker) wrote :
Adnane Belmadiaf (daker) wrote :
Adnane Belmadiaf (daker) wrote :
Sebastien Bacher (seb128) wrote :

Matthew, reassigning to you. The issue is that some clicks are part of the base image, those can be updated but the update is unpacked in some other directory (since the base image is read only) and you end up having 2 versions of the click on disk (one is the system image, one installed from the click store). That's something normal users would hit easily at the moment, since click updates are listed as individual items, even for clicks pre-installed in the base image

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
summary: - Storage shows same app multiple times
+ Storage shows same app multiple times (pre-installed and update from
+ click store)

Each individual apps that is updated generate a new entry on Storage. However, the update via version update (OTA updates) not generate duplicated entries.

Alejandro J. Cura (alecu) wrote :

I think this bug is separate from the one it was marked as a duplicate (bug #1479001). I'm splitting the bugs, and reassigning some of the dupes.

Changed in canonical-devices-system-image:
status: New → Confirmed
assignee: nobody → Alejandro J. Cura (alecu)
Pat McGowan (pat-mcgowan) wrote :

can we land this?

Changed in canonical-devices-system-image:
importance: Undecided → Medium
milestone: none → ww46-2015
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Alejandro J. Cura (alecu) wrote :

The proposed branch fixes the issue mentioned by seb in comment #16.
I'm reassigning the bug to the system settings devels, so they can hopefully land it.

Changed in ubuntu-system-settings (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → Sebastien Bacher (seb128)
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

ok, I guess that makes sense, the click is installed twice but the copy included on the image is going to be counted as part of the base

Changed in canonical-devices-system-image:
assignee: Alejandro J. Cura (alecu) → Bill Filler (bfiller)
Bill Filler (bfiller) on 2015-11-10
Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016

ubuntu-system-settings (0.3+15.04.20151110-0ubuntu1) vivid; urgency=medium
 .
   [ Alejandro J. Cura ]
   * If a system package gets updated by the user, only show the user's
     copy (LP: #1265250)

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+16.04.20151110-0ubuntu1

---------------
ubuntu-system-settings (0.3+16.04.20151110-0ubuntu1) xenial; urgency=medium

  [ Alejandro J. Cura ]
  * If a system package gets updated by the user, only show the user's
    copy (LP: #1265250)

  [ Bartosz Kosiorek ]
  * Allow translating "Unavailable" string (LP: #1511384) (LP: #1511384)

  [ Ken VanDine ]
  * Don't check for updates if not online (LP: #1505663)

  [ Michael Zanetti ]
  * Only animate ActivityIndicators when they are visible (LP: #1513450)

 -- Ken VanDine <email address hidden> Tue, 10 Nov 2015 15:27:33 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers