[bluetooth] After claiming to connect no audio is routed to the headset

Bug #1240979 reported by Pat McGowan
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
Fix Released
Critical
Ricardo Salveti

Bug Description

Once connected using phone or music apps do not result in any audio routed to them.
Also noticed that bluetoothd was at near 100% cpu after the first connection.

<https://wiki.ubuntu.com/Sound#primary-output>: "If you connect or pair headphones, or any audio output device except a secondary display, the primary output should change to that device."

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Revision history for this message
Adrien Béraud (wagaf) wrote :

Yes Bluetooth Audio is broken on 13.10.

See related AskUbuntu question http://askubuntu.com/questions/370254/bluetooth-issues-ubuntu-13-10

One have to run "pulseaudio -k" in a terminal and than manually select the device in audio preferences to have it working.

Revision history for this message
Stuart Langridge (sil) wrote :

I note that this is a problem for me on a Nexus 4. Connecting to Bluetooth speakers from a 13.10 Ubuntu laptop works fine, without having to "kill pulseaudio".

description: updated
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

a2dp devices are working as expected, hsp is still being investigated.

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
tags: added: rtm14
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Reassigning to Ricardo, since he's the one who is actually working on this.

Devices supporting A2DP currently get their audio properly set up for A2DP -- in other words, if it's a stereo device, you should be able to get sound from the Music App.

Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → In Progress
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → Ricardo Salveti (rsalveti)
tags: added: qa-rregression-testing qa-touch
tags: added: qa-daily-testing
removed: qa-rregression-testing
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

This is working for the majority of headsets, exceptions being investigated via other bug reports.

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers