Pointless access request prompt

Bug #1582824 reported by dobey on 2016-05-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
webapps-sprint
High
Alberto Mardegan
ubuntu-system-settings-online-accounts (Ubuntu)
High
Alberto Mardegan

Bug Description

In attempting to test for bug #1582804 on my mako with updated rc-proposed image 441, immediately after logging in to the U1 account after tapping on the '$2.99' button for 'Cut the Rope', I was presented with the screen shown in the attached screenshot (e-mail address removed in screenshot).

There is no reason this dialog should ever appear for the U1 account, and choosing either option is irrelevant to whether the account can be used by the scope. Choosing to not allow simply acts as cancelling the current in-progress action, returning the user to the app preview. However, immediately tapping on the '$2.99' button again will work just fine, and the payment UI will be presented.

Related branches

dobey (dobey) wrote :
Alberto Mardegan (mardy) wrote :

I can add an exception here, that if the calling process is unconfined and does not provide an applicationId, we just let the request through.

Changed in webapps-sprint:
assignee: nobody → Alberto Mardegan (mardy)
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
Changed in webapps-sprint:
importance: Undecided → High
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in webapps-sprint:
status: New → Confirmed
milestone: none → sprint-23
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → David Barth (dbarth)
milestone: none → 12
Alberto Mardegan (mardy) wrote :

Actually, after investigating the situation (though unfortunately, I failed to reproduce this bug), I'm not sure that we should cahnge something in Online Accounts here.
The authorisation prompt does not appear automatically: it only appears when a client invokes the exec() method of the OnlineAccountsClient::Setup object (or the QML equivalent). When online-accounts-service receives such a request, it either initiates the account creation (if there isn't yet an account of such type) or prompts the user to grant access to the existing account.

What I believe is happening here, is that for some reason the client is making the account request twice: the first time, we start the account creation; the second time, the prompt is shown.

I will still keep the bug active, because we might want to be more robust and handle bogus requests more gracefully, but I think we have to first find out why we are getting to requests in the first place.

David Barth (dbarth) on 2016-06-06
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in webapps-sprint:
status: Confirmed → In Progress
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.7+16.10.20160610-0ubuntu1

---------------
ubuntu-system-settings-online-accounts (0.7+16.10.20160610-0ubuntu1) yakkety; urgency=medium

  [ Alberto Mardegan ]
  * Immediately accept degenerate requests from unconfined processes
    (LP: #1582824)
  * Replace incorrect usage of UbuntuColors (LP: #1581047)
  * Update pot file for translations (LP: #1533091)
  * Open popups in an overlaid webview (LP: #1428591)
  * Skip tests on arm64 (LP: #1585942)

  [ Alberto Mardegan, Timo Jyrinki ]
  * Stop depending on transitional packages. (LP: #1583079)

 -- Alberto Mardegan <email address hidden> Fri, 10 Jun 2016 09:46:37 +0000

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: In Progress → Fix Released
David Barth (dbarth) on 2016-06-21
Changed in webapps-sprint:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers