Account details page needs design love

Bug #1544033 reported by Michael Zanetti on 2016-02-10
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Online Accounts setup for Ubuntu Touch
High
Alberto Mardegan
Ubuntu UX
Undecided
Unassigned
webapps-sprint
High
Alberto Mardegan
pay-ui (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings-online-accounts (Ubuntu)
High
Alberto Mardegan

Bug Description

See attached screenshot. There's multiple issues with this page:

* Empty space at the top
* missing icon for PayUI
* PayUI displays appid instead of user friendly name

Related branches

Michael Zanetti (mzanetti) wrote :
affects: ubuntu-system-settings (Ubuntu) → ubuntu-system-settings-online-accounts (Ubuntu)
Alberto Mardegan (mardy) wrote :

The empty space at the top looks like a regression, probably due to some changes in the UI toolkit.

The missing icon and name for PayUi is due to the fact that the ~/.local/share/accounts/applications/com.canonical.payui_payui.application file contains the following entry:

    <desktop-entry>com.canonical.payui_payui_15.01.140</desktop-entry>

but there isn't a file with that name in ~/.local/share/applications/ (plus the ".desktop" suffix). Either the .desktop file needs to be shipped by PayUI, or the <desktop-entry> element should be changed to point at another valid desktop file.

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in ubuntu-system-settings-online-accounts:
status: New → Confirmed
importance: Undecided → High
Alberto Mardegan (mardy) on 2016-02-12
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
Changed in ubuntu-system-settings-online-accounts:
assignee: nobody → Alberto Mardegan (mardy)
status: Confirmed → In Progress
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: Confirmed → In Progress
Changed in webapps-sprint:
assignee: nobody → Alberto Mardegan (mardy)
milestone: none → sprint-19
importance: Undecided → High
status: New → In Progress
dobey (dobey) wrote :

Marking this invalid in pay-ui. Placing the blame on pay-ui for online-accounts having inappropriate requirements for having an installed account plug-in show up on the "Add Accounts" of requiring an "application" to be installed which is registered as using the account, is incorrect and inappropriate. The fact is that pay-ui is not an application, and we will not fix it to install a .desktop file as it if were an application.

It is a very special .click package, and it will hopefully no longer be a click package soon, so it will disappear from this view anyway. However, the problem will still remain that it will be impossible to add a U1, Twitter, or other account type, when there is no "registered application" that claims use of it. The fact is that pay-ui, click-scope, ubuntu-push-client, etc… are not "applications" in the sense of how we use that term for .click packages, nor as is expected by online-accounts. This requirement in online-accounts is simply wrong, as I've argued previously. Unfortunately, I'm having trouble finding the bug where I previously argued this point.

Changed in pay-ui (Ubuntu):
status: New → Invalid
Alberto Mardegan (mardy) wrote :

Then I need to add ubuntu-ux to the bug, to understand what is the expected behaviour:

When tapping on an existing UbuntuOne account, should PayUI be listed as a consumer for this account?

A) If not, how should the page look like? Having no applications listed in the page makes for a rather ugly UI.

B) If yes, what should be its name and icon?

Selene ToyKeeper (toykeeper) wrote :

The empty space seems fixed in silo 77 (ticket 1003) today, but not the icon or name.

Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → High
milestone: none → ww08-2016
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.7+16.04.20160308-0ubuntu1

---------------
ubuntu-system-settings-online-accounts (0.7+16.04.20160308-0ubuntu1) xenial; urgency=medium

  [ Alberto Mardegan ]
  * Bind flickable to page. (LP: #1544033)
  * Don't crash on invalid providers (LP: #1554254)
  * Don't use deprecated onLoadingChanged signal. (LP: #1544063)
  * ProviderRequest: fix single account handling in authorization page
    (LP: #1552762)
  * Update authorisation prompt (LP: #1544919)

  [ CI Train Bot ]
  * Resync trunk.

 -- David Barth <email address hidden> Tue, 08 Mar 2016 08:48:44 +0000

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: In Progress → Fix Released
Matthew Paul Thomas (mpt) wrote :

I agree with Rodney. pay-ui here is akin to a library. Whether an app/scope uses an account directly, or via some helper, should not matter: either way, the user will perceive the app/scope as using the account. Spec updated. <https://wiki.ubuntu.com/OnlineAccounts?action=diff&rev2=29&rev1=28>

dobey (dobey) wrote :

The problem is that the way the U1 account is used, not only in the store scope, but in most everywhere it is used in the system, is that it is designed to work with or without an existing account in place, and we only explicitly require an account when one is absolutely required for some function, and only via some specific user interaction, rather than simply background requests to see if an account exists.

The proposed solution not only requires small changes, but a general complete re-design of how the account is used across the entire system. This is not a simple thing to do, and the changes would be very disruptive to the flows we have in place.

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Alberto Mardegan (mardy) on 2016-04-13
Changed in ubuntu-system-settings-online-accounts:
status: In Progress → Fix Released
Changed in webapps-sprint:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments