Login to some online accounts unavailable from settings

Bug #1234185 reported by Gema Gomez on 2013-10-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
signon-ui (Ubuntu)
High
Alberto Mardegan
ubuntu-system-settings-online-accounts (Ubuntu)
Undecided
Unassigned

Bug Description

Tried to log in to facebook, twitter and google on 20131001.3 image from the settings app and it is not possible. See attached screnshots.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubuntu-system-settings-online-accounts 0.2~+13.10.20130925-0ubuntu1
Uname: Linux 3.4.0-3-mako armv7l
ApportVersion: 2.12.5-0ubuntu1
Architecture: armhf
Date: Wed Oct 2 14:44:00 2013
InstallationDate: Installed on 2013-10-01 (0 days ago)
InstallationMedia: Ubuntu Saucy Salamander (development branch) - armhf (20131001.3)
MarkForUpload: True
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
SourcePackage: ubuntu-system-settings-online-accounts
UpgradeStatus: No upgrade log present (probably fresh install)

Gema Gomez (gema) wrote :
Gema Gomez (gema) wrote :
Gema Gomez (gema) wrote :
Gema Gomez (gema) wrote :
tags: added: avengers qa-touch
tags: added: rls-s-incoming
Changed in signon-ui (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Alberto Mardegan (mardy)
Ken VanDine (ken-vandine) wrote :

There are really several issues here that can get users into this situation:
 * The lack of feedback to the user that we are requesting a login page from the provider. When adding an account all you see is a "Cancel" button. The browser-process that gets spawned by signon-ui doesn't show itself until the page is done loading, maybe we should show the webview right away with a loading ActivityIndicator until loading is completed.
 * If you back out and try to add an account again (or cancel and try again), it continues to wait to show the page that was already requested. I've confirmed this by cancelling several attempts and retrying, then killing the browser-process. I then get a login page for the second attempt. Killing that process gives me the third, and so on. So signon-ui is queuing them as it should, but not cancelling when needed.
 * Since we aren't showing anything to the user until the page completes loading, we also don't show any failures to load the page or provide an error handling for that scenario.

Jean-Baptiste Lallement (jibel) wrote :

fixed and verified in build 97

Changed in signon-ui (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers