Sign-in button is not active

Bug #951461 reported by Marcin Dylewski on 2012-03-10
54
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Trunk
High
Diego Sarmentero
ubuntu-sso-client (Ubuntu)
High
Unassigned

Bug Description

I try to link my computer to Ubuntu-One cloud. I choose "Sign me in with existing account" then I have a window with email and password dialogue but whatever I type there the Sign In button is always inactive.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubuntu-sso-client-qt 2.99.90-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Sat Mar 10 12:18:05 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-sso-client
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-sso-client (Ubuntu):
status: New → Confirmed
Changed in ubuntu-sso-client (Ubuntu):
assignee: nobody → Diego Sarmentero (diegosarmentero)
importance: Undecided → High
Changed in ubuntu-sso-client:
assignee: nobody → Diego Sarmentero (diegosarmentero)
importance: Undecided → High
status: New → In Progress
Changed in ubuntu-sso-client (Ubuntu):
assignee: Diego Sarmentero (diegosarmentero) → nobody
gutigen (gutigen) wrote :

Same problem here... :(

mbro (mariuszbrodko) wrote :

I have the same problem. Sign In button is inactive.

Nicolas (nicolas-homenico) wrote :

Same problem...

Changed in ubuntu-sso-client:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package ubuntu-sso-client - 2.99.91-0ubuntu1

---------------
ubuntu-sso-client (2.99.91-0ubuntu1) precise; urgency=low

  * New upstream release:
    - Do not allow ssl errors to be ignored (LP: #959390).
    - Handle wrong credentials properly in qtnetwork webclient
      (LP: #957317).
    - Use HTTPClientFactory to allow replacing the reactor used to connect
      (LP: #929207).
    - Decode the content of help_text (LP: #951371).
    - Adding missing file for translation (LP: #951376).
    - Adding a general error message when the argument received by
      build_general_error_message is not a dict (LP: #865176).
    - Adding some checks to setup_page (LP: #951461).
    - Adding a padding to the right margin of the reset layout, and align
      one of its layout to the left (LP: #945065).
    - Executing hide_error when the user click the refresh captcha link,
      not inside of the _refresh_captcha method, because this is executed
      automatically when a captcha error is generated, so we will always
      miss the error message (LP: #955010).
    - Removing the align property from the label that wasn't necessary
      and was breakint the work wrap. Also adjust the height of the widget
      depending if it has more than one line (LP: #940392).
    - Improve logging operations (LP: #934500).
    - Making LINK_STYLE to be unicode (LP: #950953).
    - Setting the window title equal to the app_name (LP: #949744).
    - The _move_to_email_verification_page wasn't receiving the params
      that the signal emits (LP: #945066).
    - Improve the grammar for the CLOSE_AND_SETUP_LATER button text
      (LP: #949978).
    - Changed the way in which we deal with proxies to work around bugs
      found in the QNetworkAccessManager (LP: #957313).
    - Stopped listening to the proxyAuthenticationRequired to avoid the
      dialog showing more than once (LP: #957170)
    - Made changes in the way the webclient is selected to ensure that qt
      is used when possible (LP: #957169).
    - Connected the WebKit browser correctly so that the tc page gets
      loaded (LP: #933081).
    - Added code to check if the browser with the t&c was already loaded.
      If it is just show the t&c page, otherwise perform the request
      (LP: #956185).
    - Added a translatable string to give more context of the ssl cert
      info to the user (LP: #948119).
    - Provided the logic required for the Qt webclient implementation to
      detect ssl errors and spawn the ssl dialog to allow the user accept
      the ssl cert exceptions (LP: #948134).
    - Changed the qt webclient implementation to use a proxy factory so
      that the correct proxy is chosen according to the request
      (LP: #950088).
    - Added the required code to allow the webclient use authenticated
      proxies and request the creds when needed (LP: #933727).
    - The tooltip should not be shown for titles and subtitles when
      no cut off was needed (LP: #949741).
    - Enable platform-specific styling (LP: #953318).
    - Only import DBus on Linux (LP: #956304).
    - Don't hard-code font sizes.
    - Remove usage of weight property as a numeric; just use...

Read more...

Changed in ubuntu-sso-client (Ubuntu):
status: Confirmed → Fix Released

Bug is fixed. Thank you.

Laurent Montet (laurentmontet) wrote :

Bug not fixed for me.
'Sign in' and 'forgot password ?' still inactive after installation of last upgrade (and restart of the machine)

Natalia Bidart (nataliabidart) wrote :

Hello Laurent,

can you please specific the versions you're running of the following packages:

ubuntu-sso-client
ubuntuone-client
ubuntuone-control-panel

Thanks!

Laurent Montet (laurentmontet) wrote :

Today's upgrade fixed it. Thank you !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers