Several strings untranslatable in ubuntone-client registration

Bug #951376 reported by Timo Jyrinki on 2012-03-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Trunk
High
Diego Sarmentero
Ubuntu Translations
High
Unassigned
ubuntu-sso-client (Ubuntu)
Undecided
Unassigned

Bug Description

As noted in the bug #951371 screenshot - https://launchpadlibrarian.net/96189250/screenshot.png -, several strings are not set translatable, ie. not available in Launchpad for translation and not included in the language packs.

These include at least "Sign Up to Ubuntu One", "Email", "Retype email", "Create a password", "Retype password", "If you can't read this then refresh this page", "By signing up to Ubuntu One you agree to our Terms of Service and Privac..." (cut off) and "Set Up Account", but please check all the strings while you're at it.

Related branches

description: updated
description: updated
no longer affects: ubuntuone-client
Gabor Kelemen (kelemeng) on 2012-03-10
affects: ubuntuone-client (Ubuntu) → ubuntu-sso-client (Ubuntu)
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
Gabor Kelemen (kelemeng) wrote :

If I choose Sign in with existing account, there are untranslated strings too.

Gabor Kelemen (kelemeng) wrote :

The Forgotten password page has some too.

Changed in ubuntu-sso-client (Ubuntu):
status: New → Confirmed
Gabor Kelemen (kelemeng) wrote :

And one more during logging in.

Gabor Kelemen (kelemeng) wrote :

And on the last page too.

Changed in ubuntu-sso-client:
importance: Undecided → High
status: New → Triaged
assignee: nobody → Diego Sarmentero (diegosarmentero)
Natalia Bidart (nataliabidart) wrote :

Hello Timo, Gabor,

Thanks a lot for catching this! We will start fixing these ASAP.

Regards, Natalia.

Changed in ubuntu-sso-client:
status: Triaged → In Progress
Changed in ubuntu-sso-client:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package ubuntu-sso-client - 2.99.91-0ubuntu1

---------------
ubuntu-sso-client (2.99.91-0ubuntu1) precise; urgency=low

  * New upstream release:
    - Do not allow ssl errors to be ignored (LP: #959390).
    - Handle wrong credentials properly in qtnetwork webclient
      (LP: #957317).
    - Use HTTPClientFactory to allow replacing the reactor used to connect
      (LP: #929207).
    - Decode the content of help_text (LP: #951371).
    - Adding missing file for translation (LP: #951376).
    - Adding a general error message when the argument received by
      build_general_error_message is not a dict (LP: #865176).
    - Adding some checks to setup_page (LP: #951461).
    - Adding a padding to the right margin of the reset layout, and align
      one of its layout to the left (LP: #945065).
    - Executing hide_error when the user click the refresh captcha link,
      not inside of the _refresh_captcha method, because this is executed
      automatically when a captcha error is generated, so we will always
      miss the error message (LP: #955010).
    - Removing the align property from the label that wasn't necessary
      and was breakint the work wrap. Also adjust the height of the widget
      depending if it has more than one line (LP: #940392).
    - Improve logging operations (LP: #934500).
    - Making LINK_STYLE to be unicode (LP: #950953).
    - Setting the window title equal to the app_name (LP: #949744).
    - The _move_to_email_verification_page wasn't receiving the params
      that the signal emits (LP: #945066).
    - Improve the grammar for the CLOSE_AND_SETUP_LATER button text
      (LP: #949978).
    - Changed the way in which we deal with proxies to work around bugs
      found in the QNetworkAccessManager (LP: #957313).
    - Stopped listening to the proxyAuthenticationRequired to avoid the
      dialog showing more than once (LP: #957170)
    - Made changes in the way the webclient is selected to ensure that qt
      is used when possible (LP: #957169).
    - Connected the WebKit browser correctly so that the tc page gets
      loaded (LP: #933081).
    - Added code to check if the browser with the t&c was already loaded.
      If it is just show the t&c page, otherwise perform the request
      (LP: #956185).
    - Added a translatable string to give more context of the ssl cert
      info to the user (LP: #948119).
    - Provided the logic required for the Qt webclient implementation to
      detect ssl errors and spawn the ssl dialog to allow the user accept
      the ssl cert exceptions (LP: #948134).
    - Changed the qt webclient implementation to use a proxy factory so
      that the correct proxy is chosen according to the request
      (LP: #950088).
    - Added the required code to allow the webclient use authenticated
      proxies and request the creds when needed (LP: #933727).
    - The tooltip should not be shown for titles and subtitles when
      no cut off was needed (LP: #949741).
    - Enable platform-specific styling (LP: #953318).
    - Only import DBus on Linux (LP: #956304).
    - Don't hard-code font sizes.
    - Remove usage of weight property as a numeric; just use...

Read more...

Changed in ubuntu-sso-client (Ubuntu):
status: Confirmed → Fix Released
Gabor Kelemen (kelemeng) on 2012-03-21
Changed in ubuntu-translations:
status: Triaged → Fix Released
Gabor Kelemen (kelemeng) wrote :

I don't see the < Back and Finish button labels in the ubuntu-sso-client template, neither in the source - those are probably from some other package, I'll open another bug.

Natalia Bidart (nataliabidart) wrote :

Hello Gabor!

Those strings are being shown by the QT engine itself (they are part of the QWizard default set of buttons), I just confirmed in a clean VM with French locale that those shown translated, so I think that no new bug is needed :-).

Thanks for checking though!

Regards, Natalia.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers