ubuntu-sso-login crashed with ImportError in start_setup(): No module named qt

Bug #939173 reported by Nicolás Abel Carbone
260
This bug affects 48 people
Affects Status Importance Assigned to Milestone
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Trunk
High
Natalia Bidart
ubuntu-sso-client (Ubuntu)
High
Natalia Bidart
Precise
High
Natalia Bidart

Bug Description

The crash happened after a system update.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: ubuntu-sso-client 2.99.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.92-0ubuntu1
Architecture: amd64
Date: Wed Feb 22 22:33:45 2012
ExecutablePath: /usr/lib/ubuntu-sso-client/ubuntu-sso-login
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120211)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: python /usr/lib/ubuntu-sso-client/ubuntu-sso-login
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=es_AR:es:en
 LANG=es_AR.utf8
PythonArgs: ['/usr/lib/ubuntu-sso-client/ubuntu-sso-login']
SourcePackage: ubuntu-sso-client
Title: ubuntu-sso-login crashed with ImportError in start_setup(): No module named qt
UpgradeStatus: Upgraded to precise on 2012-02-16 (6 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Revision history for this message
Nicolás Abel Carbone (nicocarbone) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-sso-client (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Martin Pitt (pitti)
visibility: private → public
Changed in ubuntu-sso-client (Ubuntu):
importance: Undecided → High
Changed in ubuntu-sso-client (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-1
assignee: nobody → Ubuntu One hackers (ubuntuone-hackers)
Revision history for this message
Oscar Tiderman (oscar-tiderman) wrote :

Happened to me too while running updates

Revision history for this message
Jim (jimvernon) wrote :

Same here. Popped up while running updates.

Changed in ubuntu-sso-client (Ubuntu Precise):
assignee: Ubuntu One hackers (ubuntuone-hackers) → Natalia Bidart (nataliabidart)
Changed in ubuntu-sso-client:
status: New → In Progress
assignee: nobody → Natalia Bidart (nataliabidart)
importance: Undecided → High
Changed in ubuntu-sso-client:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 2.99.5-0ubuntu2

---------------
ubuntu-sso-client (2.99.5-0ubuntu2) precise; urgency=low

  * debian/patches/fix-939173.patch:
    - Do not mask ImportError by importing inside a function (LP: #939173).
 -- Natalia Bidart (nessita) <email address hidden> Thu, 23 Feb 2012 10:50:43 -0300

Changed in ubuntu-sso-client (Ubuntu Precise):
status: Confirmed → Fix Released
Revision history for this message
Grizzly(Francis Smit) (grizzly-smit) wrote :

I keep getting Precise reporting this but synaptic doesn't always crash as far as I can tell

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers