package ubuntu-sso-client 1.0.3-0ubuntu1 failed to install/upgrade: subprocess new pre-installation script returned error exit status 127

Bug #658768 reported by Hansen zhang on 2010-10-11
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-sso-client (Ubuntu)
High
Natalia Bidart
Maverick
High
Natalia Bidart
Natty
High
Natalia Bidart

Bug Description

Binary package hint: ubuntu-sso-client

Release: Ubuntu 10.10 Maverick Meerkat
Happened on startup, no user input. Recently upgraded distribution, with couple of errors fixed with previous kernel.

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: ubuntu-sso-client 1.0.3-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Mon Oct 11 17:01:53 2010
ErrorMessage: subprocess new pre-installation script returned error exit status 127
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
PackageArchitecture: all
SourcePackage: ubuntu-sso-client
Title: package ubuntu-sso-client 1.0.3-0ubuntu1 failed to install/upgrade: subprocess new pre-installation script returned error exit status 127

Related branches

Hansen zhang (hzhang5) wrote :
Changed in ubuntu-sso-client (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Naty Bidart (nataliabidart)
Changed in ubuntu-sso-client (Ubuntu):
status: In Progress → Triaged
Natalia Bidart (nataliabidart) wrote :

This is caused by the dpkg dependency being set as a "Depends" instead of a "Pre-Depends". Adding it to Pre-Depends will fix this issue.

Accepted ubuntu-sso-client into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubuntu-sso-client (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Changed in ubuntu-sso-client (Ubuntu Maverick):
importance: Undecided → High
assignee: nobody → Naty Bidart (nataliabidart)
Natalia Bidart (nataliabidart) wrote :

Tested on a clean maverick install with -proposed enabled. After installation, no error messages were reported by the package manager.

Jean-Baptiste Lallement (jibel) wrote :

Natalia, you can't reproduce in a fresh maverick environment because dpkg-maintscript-helper (which causes the failure) was renamed in dpkg 1.15.7.2 and 1.15.8.4ubuntu3 is available in maverick.

The only way to reproduce is either to upgrade from lucid (and ensure that dpkg is installed after ubuntu-sso-client which can be tricky because many packages pre-depend on dpkg), the other way to reproduce is to install dpkg < 1.15.7.2 in maverick and then upgrade both dpkg and ubuntu-sso-client.

Natalia Bidart (nataliabidart) wrote :

Jean,

Thanks for the pointers, but as you can see below, I managed to have both old ubuntu-sso-client and old dpkg but the update went just fine. Not sure how to force the update order when using dpkg...

yadda@yadda-desktop:~$ sudo aptitude show ubuntu-sso-client
Package: ubuntu-sso-client
State: installed
Automatically installed: no
Version: 0.99.4-0ubuntu1

yadda@yadda-desktop:~$ sudo aptitude show dpkg
Package: dpkg
Essential: yes
State: installed
Automatically installed: no
Version: 1.15.5.6ubuntu4

yadda@yadda-desktop:~$ sudo aptitude install ubuntu-sso-client
The following packages will be upgraded:
  dpkg ubuntu-sso-client
2 packages upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0B/2,101kB of archives. After unpacking 692kB will be freed.
Do you want to continue? [Y/n/?]
(Reading database ... 142445 files and directories currently installed.)
Preparing to replace dpkg 1.15.5.6ubuntu4 (using .../dpkg_1.15.8.4ubuntu3_i386.deb) ...
Unpacking replacement dpkg ...
Processing triggers for man-db ...
Setting up dpkg (1.15.8.4ubuntu3) ...
Installing new version of config file /etc/logrotate.d/dpkg ...
(Reading database ... 142453 files and directories currently installed.)
Preparing to replace ubuntu-sso-client 0.99.4-0ubuntu1 (using .../ubuntu-sso-client_1.0.3-0ubuntu1_all.deb) ...
Moving obsolete conffile /etc/xdg/ubuntu-sso/oauth_registration.d/ubuntuone out of the way...
Moving obsolete conffile /etc/xdg/ubuntu-sso/oauth_urls out of the way...
Unpacking replacement ubuntu-sso-client ...
dpkg: warning: unable to delete old directory '/etc/xdg/ubuntu-sso/oauth_registration.d': Directory not empty
dpkg: warning: unable to delete old directory '/etc/xdg/ubuntu-sso': Directory not empty
Processing triggers for python-support ...
Setting up ubuntu-sso-client (1.0.3-0ubuntu1) ...
Removing obsolete conffile /etc/xdg/ubuntu-sso/oauth_registration.d/ubuntuone ...
Removing obsolete conffile /etc/xdg/ubuntu-sso/oauth_urls ...
Processing triggers for python-support ...

Any other ideas how to verify this change, besides the obvious correctness of the change to the debian/control file?

Thanks!

Changed in ubuntu-sso-client (Ubuntu Natty):
status: Triaged → Fix Released
Jean-Baptiste Lallement (jibel) wrote :

You're right, that's pretty tricky to reproduce even by forcing version of dpkg it is always upgraded before ubuntu-sso-client. This is really a corner case. I'm marking as verification-done because the tests show that it's not reproducible and the pre-depends force the upgrade of dpkg before ubuntu-sso-client anyhow.

Thanks for the fix.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 1.0.4-0ubuntu1

---------------
ubuntu-sso-client (1.0.4-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release:

  [ Alejandro J. Cura <email address hidden> ]
    * Replace twisted gtk reactor with the standard gtk mainloop. (LP: #655327).

  [ Alejandro J. Cura <email address hidden> ]
    * Call the dbus mainloop thread init (fixes LP: #656545).

  * Adding .bzr-builddeb/default.conf as per Michael Vog (mvo) request.

  * Adding dpkg (>= 1.15.7.2) as Pre-Depends (fixes LP: #658768).

  * Adding gnome-keyring as dep since python-gnomekeyring doesn't install it.
 -- Natalia Bidart (nessita) <email address hidden> Tue, 12 Oct 2010 10:07:55 -0300

Changed in ubuntu-sso-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers