GNOME default to a document font not installed by Ubuntu

Bug #1828108 reported by Sebastien Bacher on 2019-05-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-flashback (Ubuntu)
Undecided
Unassigned
ubuntu-settings (Ubuntu)
Low
Unassigned
Disco
Undecided
Unassigned

Bug Description

* Impact

The document font changed in GNOME 3.31 to be 'Cantarell 11' but that font is not installed in Ubuntu so a fallback font is used instead.

* Test case
Install gnome-tweaks and look at the document font, it should be 'Sans 11' and not 'undefined'

* Regression potential
It's just changing the default value to be what it was before, the impact should be low (the UI is going to look different in place where the fallback was used but that's what the fix is about)

Changed in ubuntu-settings (Ubuntu):
importance: Undecided → Low
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 19.04.4

---------------
ubuntu-settings (19.04.4) eoan; urgency=medium

  * ubuntu-settings.gsettings-override:
    - set the document font to 'Sans 11' for Ubuntu, the GNOME default
      changed to Cantarell which is not installed for us (lp: #1828108)

 -- Sebastien Bacher <email address hidden> Tue, 07 May 2019 20:19:36 +0200

Changed in ubuntu-settings (Ubuntu):
status: In Progress → Fix Released

Hello Sebastien, or anyone else affected,

Accepted ubuntu-settings into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-settings/19.04.3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-settings (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-flashback (Ubuntu):
status: New → Confirmed
KyL416 (kyl416) wrote :

This also affects gnome-flashback, when you use that session "Cantarell 11" is the default document font instead of Sans 11.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-flashback - 3.32.0-1ubuntu2

---------------
gnome-flashback (3.32.0-1ubuntu2) eoan; urgency=medium

  * Set document-font-name to "Sans 11", following ubuntu-settings
    (LP: #1828108).

 -- Dmitry Shachnev <email address hidden> Fri, 10 May 2019 12:31:23 +0300

Changed in gnome-flashback (Ubuntu):
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

Installing ubuntu-settings 19.04.3.1 the correct font is listed/displayed

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 19.04.3.1

---------------
ubuntu-settings (19.04.3.1) disco; urgency=medium

  * ubuntu-settings.gsettings-override:
    - set the document font to 'Sans 11' for Ubuntu, the GNOME default
      changed to Cantarell which is not installed for us (lp: #1828108)

 -- Sebastien Bacher <email address hidden> Tue, 07 May 2019 20:19:36 +0200

Changed in ubuntu-settings (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-settings has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers