[regression] New windows are all centred

Bug #1796548 reported by Daniel van Vugt on 2018-10-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-settings (Ubuntu)
Medium
Unassigned

Bug Description

In a fresh cosmic installation new windows all appear in the same place; the middle of the screen. This makes opening multiple windows annoying.

WORKAROUND:

Gnome Tweaks > Windows > Center New Windows = OFF

tags: added: cosmic
description: updated
tags: added: rls-cc-incoming
Will Cooke (willcooke) on 2018-10-16
tags: added: rls-cc-notfixing
removed: rls-cc-incoming
Sebastien Bacher (seb128) wrote :

That's an upstream design decision, unsure it can be considered as a regression if it's by design

Daniel van Vugt (vanvugt) wrote :

From the Ubuntu perspective I think it is a regression.

With auto-placement, you can launch an app and use it immediately without needing to move the window. However if all windows appear in the same location, you have to do the extra work of moving every single one. It's surprisingly annoying.

affects: gnome-shell (Ubuntu) → ubuntu-settings (Ubuntu)
Changed in ubuntu-settings (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 19.04.3

---------------
ubuntu-settings (19.04.3) disco; urgency=medium

  * ubuntu-settings.gsettings-override:
    - don't center dialogs on screen by default, that leads to non
      smart windows placement (lp: #1796548)

 -- Sebastien Bacher <email address hidden> Fri, 01 Mar 2019 21:41:37 +0100

Changed in ubuntu-settings (Ubuntu):
status: Fix Committed → Fix Released
amano (jyaku) wrote :

I really liked the previous behavior. I think that this was changed by did rocks and suugested by me.

What makes it "annoying"? I find th upstream behavior annoying.

Carlo Lobrano (c-lobrano) wrote :

I agree with amano, I do expect the window I want to work on to present itsel just in front of me. The good thing I see in auto-placement is only that it looks for free space (if my understanding is correct), so the best solution for me would be to mix this two features

Sebastien Bacher (seb128) wrote :

The annoying part is that it stacks windows instead of placing it in a smart way, you would expect them to be in some free space so they don't hide other useful part of the screen by default

Daniel van Vugt (vanvugt) wrote :

Sounds like this is another setting which should be in Settings and not hidden in gnome-tweaks. Because generally if a setting is more easily adjustable then nobody complains about its default value :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers