Turn on background plugin by default (Ubuntu 18.10)

Bug #1795145 reported by Khurshid Alam on 2018-09-29
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-settings (Ubuntu)
Undecided
Khurshid Alam

Bug Description

In https://git.launchpad.net/~ubuntu-desktop/ubuntu/+source/ubuntu-settings/tree/debian/ubuntu-settings.gsettings-override#n139

we have,

[org.gnome.settings-daemon.plugins.background:ubuntu]
active = false

which disables the plugin. Gnome-settings-daemon doesn't use that key anymore (They are auto started by desktop files), But unity-settings-daemon now requires it to be enabled by default due to recent changes in lightdm and u-s-d

Lightdm now use AccountsService extension system for extended greeter information (like wallpaper) used by unity-greeter (https://github.com/CanonicalLtd/lightdm/commit/6015bce25f241e7580c03594d846769f8236232f)

And unity-settings-daemon now depends on new AccountsService method of setting background file for unity greeter. (https://bazaar.launchpad.net/~unity-settings-daemon-team/unity-settings-daemon/trunk/revision/4179)

How-to-reproduce:
------------------

1) First disable the background plugin if it is already enabled.

    gsettings set org.gnome.settings-daemon.plugins.sharing active false

2) Change the wallpaper from unity-control-center.

3) Log out.

    Unity-greeter should reflect the change of wallpaper.

    But it doesn't.

4) Re-enable the background plugin.

    gsettings set org.gnome.settings-daemon.plugins.sharing active true

5) Change the wallpaper again and then log out.

    Unity-greeter now reflects the change in wallpaper properly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-settings (Ubuntu):
status: New → Confirmed
Changed in ubuntu-settings (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
Jeremy Bicha (jbicha) wrote :

I'm unsubscribing ubuntu-sponsors since I uploaded this to the cosmic UNAPPROVED queue. A Release Team member will need to manually approve this upload.

Changed in ubuntu-settings (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 18.10.6

---------------
ubuntu-settings (18.10.6) cosmic; urgency=medium

  [ Jeremy Bicha ]
  * ubuntu-settings.gsettings-override: Update for evolution 3.30
    (LP: #1789090)

  [ Khurshid Alam ]
  * ubuntu-settings.gsettings-override: Enable background settings daemon
    plugin for Unity (LP: #1795145)

 -- Jeremy Bicha <email address hidden> Mon, 01 Oct 2018 11:08:39 -0400

Changed in ubuntu-settings (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers