UIFe: Drop imagemagick-display from the default install

Bug #1717951 reported by Jeremy Bicha on 2017-09-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
imagemagick (Debian)
New
Unknown
ubuntu-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Impact
======
I'm proposing to drop the ImageMagick app from the default Ubuntu 17.10.

It is visible in the Show Applications view of the Activities Overview so this could impact screenshots.

Justification
=============
imagemagick is a collection of commandline utilities for working with images, photos, etc. It is a required dependency for many things and will still be installed by default.

Bundled with imagemagick is the "display" app, which is an app with an unusual, difficult-to-use UI. It was not intentionally included in the default Ubuntu install but was only there because it was packaged together.

I am proposing splitting the display app to a separate binary package so that it is available for install for the few who do want to use the app.

I tried proposing this to Debian. See comment #60 on the attached Debian bug but the Debian maintainer doesn't seem interested in accepting my proposal any time soon. (I emailed him directly a few months ago too.)

List Notifications
==================
https://lists.ubuntu.com/archives/ubuntu-doc/2017-September/020534.html
https://lists.ubuntu.com/archives/ubuntu-translators/2017-September/007403.html

Other Info
==========
I will be attaching a patch for review by the Desktop Team here soon.

Jeremy Bicha (jbicha) on 2017-09-18
affects: ubuntu-meta (Ubuntu) → imagemagick (Ubuntu)
description: updated
Jeremy Bicha (jbicha) on 2017-09-18
description: updated
Sebastien Bacher (seb128) wrote :

The tools doesn't fit well in a modern desktop and can confuse user, sounds like a good idea to not list it by default

Gunnar Hjalmarsson (gunnarhj) wrote :

Not a problem from a docs POV.

Changed in imagemagick (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in imagemagick (Ubuntu):
status: New → Confirmed
amano (jyaku) wrote :

To add to the things mentioned above:

Since “display app“ is confusing and looks dated, people might be tempted to remove it in gnome-software. Doing so will remove the whole cups stack and leaves the user without any printing possibly. And the user has no visual clue that imagemagick was related to printing at all.

Gnome-shell just highlights some crufty icons much more than the Ubuntu Dash. People will wonder what XTerm and Imagemagick with their icons straight from the Nineties are. Removing (ugly) Xterm will currently remove the ubuntu-desktop metapackage. And removing (ugly) Imagemagick will remove the printing stack.

amano (jyaku) wrote :

s/possibly/possibility

Jeremy Bicha (jbicha) wrote :

Here's a patch for ubuntu-settings to hide the Display app from the Ubuntu and Ubuntu on Xorg desktops. This is similar to what Ubuntu Budgie, Ubuntu MATE and Ubuntu GNOME already do.

Alternatively, we could just modify Ubuntu's imagemagick to either not install the .desktop or set NoDisplay=true there.

My original proposal to split imagemagick's display app to a separate package ended up being more difficult than I expected because imagemagick's packaging is complicated.

amano (jyaku) wrote :

Will that work for the gnome session (and gnome-on-xorg-session). Since imagemagick isn't “gnomey“ at all, it should be hidden there as well...

On Wed, Oct 04, 2017 at 02:00:59AM -0000, Jeremy Bicha wrote:
> Here's a patch for ubuntu-settings to hide the Display app from the
> Ubuntu and Ubuntu on Xorg desktops. This is similar to what Ubuntu
> Budgie, Ubuntu MATE and Ubuntu GNOME already do.

This looks like a reasonable approach I think. It sucks a bit that then
you can't see it even if you want to, so I think the right approach long
term is to convince the maintainer to split the packaging.

I golfed your diff a little bit, and made the ubuntu-xorg desktop files
a symlink to the ubuntu ones to save a bit of space. See the packaging
VCS (lp:~ubuntu-desktop/+junk/ubuntu-settings) and feel free to upload
if it still works for you.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Jeremy Bicha (jbicha) on 2017-10-05
affects: imagemagick (Ubuntu) → ubuntu-settings (Ubuntu)
Changed in ubuntu-settings (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 17.10.17

---------------
ubuntu-settings (17.10.17) artful; urgency=medium

  * Hide imagemagick's Display app from the Ubuntu session (LP: #1717951)

 -- Jeremy Bicha <email address hidden> Tue, 03 Oct 2017 21:36:30 -0400

Changed in ubuntu-settings (Ubuntu):
status: Fix Committed → Fix Released
amano (jyaku) wrote :

While the visual side of this bug is fixed now (the ugly wizard-icon is gone from the launcher), the usability side is still alive:

You can still test the "imagemagick" app from within Ubuntu Software and decide to remove it from there. With the ugly side-effect of removing printing support without even realizing that this is printing related at all.

Jeremy, Ian, can you remove the app from being listed in Ubuntu Software as well? Or at least move it to the "System Apps" section to prevent useres to unvoluntarily remove CUPS?

Jeremy Bicha (jbicha) wrote :

amano, please file a separate bug for the cups issue.

Martin Zbořil (buntubugzilla) wrote :

while I agree with removing, imagemagick is used for printint and in several graphics applications, I would propose to get rid of a particular file from the imagemagick package: /usr/lib/mime/packages/imagemagick-6.q16

this should disassociate the display gui application as being default in for example firefox.

Jeremy Bicha (jbicha) wrote :

Martin, please open a new bug with specific details.

Generally speaking, people don't look at bugs that are marked Fix Released.

amano (jyaku) wrote :

Hmm. I upgraded to Disco today and the icon is back. Is that expected?

Jeremy Bicha (jbicha) wrote :

amano, please open a new bug for new issues instead of commenting on old closed bugs.

amano (jyaku) wrote :

As Sebastien Bacher pointed out, ImageMagick can be removed for good now as CUPS does no longer depend on it in Disco.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.