after upgrading, tap-to-click no longer works by default

Bug #1489730 reported by Nobuto Murata on 2015-08-28
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-settings (Ubuntu)
High
Nobuto Murata

Bug Description

After apt upgrade on wily, one finger tap on touchpad no longer works.

libunity-settings-daemon1:
- 15.04.1+15.10.20150720-0ubuntu1
+ 15.04.1+15.10.20150825-0ubuntu1

libunity-control-center1:
- 15.04.0+15.10.20150814-0ubuntu1
+ 15.04.0+15.10.20150818-0ubuntu1

unity-settings-daemon:
- 15.04.1+15.10.20150720-0ubuntu1
+ 15.04.1+15.10.20150825-0ubuntu1

unity-control-center:
- 15.04.0+15.10.20150814-0ubuntu1
+ 15.04.0+15.10.20150818-0ubuntu1

gnome-settings-daemon-schemas:
- 3.14.2-3ubuntu2
+ 3.16.2-3ubuntu1

[before the upgrade]
$ synclient | grep TapButton
    TapButton1 = 1
    TapButton2 = 3
    TapButton3 = 0

[after the upgrade]
$ synclient | grep TapButton
    TapButton1 = 0
    TapButton2 = 0
    TapButton3 = 0

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: unity-settings-daemon 15.04.1+15.10.20150825-0ubuntu1
ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
Uname: Linux 4.1.0-3-generic x86_64
ApportVersion: 2.18-0ubuntu7
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Aug 28 15:39:04 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-05-13 (106 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150512)
SourcePackage: unity-settings-daemon
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Nobuto Murata (nobuto) wrote :
Tim Lunn (darkxst) wrote :

Nobuto, It doesn't work? or the setting didn't migrate (seems like the default setting has always been off)?

Nobuto Murata (nobuto) wrote :

@Tim,
default setting has always been off. I can activate it by synclient, but just after login it's always off.

Nobuto Murata (nobuto) on 2015-09-26
affects: unity-settings-daemon (Ubuntu) → ubuntu-settings (Ubuntu)
Changed in ubuntu-settings (Ubuntu):
assignee: nobody → Nobuto Murata (nobuto)
Nobuto Murata (nobuto) on 2015-09-26
summary: - after upgrading, one finger tap no longer works
+ after upgrading, tap-to-click no longer works by default
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-settings (Ubuntu):
status: New → Confirmed

Some details, just in case it helps:

- I did a fresh install with daily build of 24 sept. 2015
- I lost tap-to-click and two-fingers scroll
- Everything looks fine (ie. checked) from mouse settings window
- Everything looks fine from synclient values (i.e. TapButton values are set)

  $ xinput list

    Virtual core pointer id=2 [master pointer (3)]
    ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
    ⎜ ↳ ETPS/2 Elantech Touchpad id=13 [slave pointer (2)]

I don't know how I can help :/ Don't hesitate if you need testers :)

Oh, I updated and upgraded everything, and after logout and re-login the problem was gone.
I am sorry I couldn't figure out what caused it :(

Good luck !

Sebastien Bacher (seb128) wrote :

Thank you for your work

Changed in ubuntu-settings (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
Changed in ubuntu-settings (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 15.10.4

---------------
ubuntu-settings (15.10.4) wily; urgency=medium

  * debian/ubuntu-settings.override:
    - restore previous tap-to-click behavior by reflecting peripheral
      schema changes (lp: #1489730)

 -- Nobuto Murata <email address hidden> Mon, 28 Sep 2015 15:31:48 +0200

Changed in ubuntu-settings (Ubuntu):
status: Fix Committed → Fix Released
raj patel (rajrajpatel2007) wrote :

Hello,

I still have the same issue on Linux 16.04 ...
Every time I log off /shut down and login, I can not use the tap to click on my laptop...

Anyone has a permanent solution?

Cheers!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers