[regression] Wall: keyboard bindings for 'Move up & Move down' are being set to "shift+super+prior & shift+super+next' for "Move with window with wall'

Bug #1241282 reported by Doug McMahon on 2013-10-18
134
This bug affects 31 people
Affects Status Importance Assigned to Milestone
ubuntu-settings (Ubuntu)
High
Christopher Townsend
Saucy
Undecided
Unassigned

Bug Description

This is just another issue as seen in Bug 1201405 which was fixed for moving workspaces
In this case the same is happening with "Move with window within wall'

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubuntu-settings 13.10.9
ProcVersionSignature: Ubuntu 3.11.0-11.17-generic 3.11.3
Uname: Linux 3.11.0-11-generic x86_64
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
Date: Thu Oct 17 21:16:34 2013
InstallationDate: Installed on 2013-08-07 (71 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130803)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: ubuntu-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
summary: - [regression] Wall: keyboard bindings for 'Move up & Move down' are
- being set to "shift+super+prior & shift+super+next' Edit
+ [regression] Wall: keyboard bindings for 'Move up & Move down' are being
+ set to "shift+super+prior & shift+super+next' for "Move with window
+ with wall'
Doug McMahon (mc3man) wrote :

As seen in new user account

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-settings (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Should be straightforward & hopefully not require an SRU, noting that adding the 2 add. lines to 10_ubuntu-settings.gshema.override & recompiling schemas fixed the prev. wrong bindings for my new user & gave correct for a user created after the change
move-to-workspace-up = ['<Shift><Control><Alt>Up']
move-to-workspace-down = ['<Shift><Control><Alt>Down']

Christoph Korn (c-korn) wrote :

Hum, is it already fixed? Because if you click on the button to put in the default value in ccsm it puts the correct key binding in.

Jep this fixes it, thanks a lot!

> Date: Sun, 20 Oct 2013 20:34:55 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 1241282] Re: [regression] Wall: keyboard bindings for 'Move up & Move down' are being set to "shift+super+prior & shift+super+next' for "Move with window with wall'
>
> Hum, is it already fixed? Because if you click on the button to put in
> the default value in ccsm it puts the correct key binding in.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1242308).
> https://bugs.launchpad.net/bugs/1241282
>
> Title:
> [regression] Wall: keyboard bindings for 'Move up & Move down' are
> being set to "shift+super+prior & shift+super+next' for "Move with
> window with wall'
>
> Status in “ubuntu-settings” package in Ubuntu:
> Confirmed
>
> Bug description:
> This is just another issue as seen in Bug 1201405 which was fixed for moving workspaces
> In this case the same is happening with "Move with window within wall'
>
> ProblemType: Bug
> DistroRelease: Ubuntu 13.10
> Package: ubuntu-settings 13.10.9
> ProcVersionSignature: Ubuntu 3.11.0-11.17-generic 3.11.3
> Uname: Linux 3.11.0-11-generic x86_64
> ApportVersion: 2.12.5-0ubuntu2
> Architecture: amd64
> Date: Thu Oct 17 21:16:34 2013
> InstallationDate: Installed on 2013-08-07 (71 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130803)
> MarkForUpload: True
> PackageArchitecture: all
> SourcePackage: ubuntu-settings
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-settings/+bug/1241282/+subscriptions

Doug McMahon (mc3man) wrote :

On 10/20/2013 04:34 PM, Christoph Korn wrote:
> Hum, is it already fixed? Because if you click on the button to put in
> the default value in ccsm it puts the correct key binding in.
>
No, that's the way it's been, the default is correct, it just isn't used
when the user account is first set up.
Should be easily tested by creating a new user account, they should get
the incorrect bindings
(if trying do make sure you log out of your current user before logging
into the new user for the first time, or do a restart before 1st. use of
that new user.

Christopher Townsend (townsend) wrote :

*Sigh* This must have slipped in at the last moment, because it was not there when I fixed the other issue:/

Yeah, this will require an SRU. I'll propose this and try to push folks to get the SRU done in a timely manner.

Christopher Townsend (townsend) wrote :

Ah, I got a little confused about what the shortcut key is. This issue was there when I did the other fix. Oh well. Will still require an SRU.

Changed in ubuntu-settings (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Christopher Townsend (townsend)
Dražen Lučanin (kermit666) wrote :

Also, the description of the shortcuts you get when pressing and holding super in the overlay cheat-sheet is wrong - it says:

  ctrl + alt + left + arrow... switches workspaces
  shift + ctrl + alt + left... moves focused window to another workspace

Should read:

  ctrl + alt + arrow switches workspaces
  shift + ctrl + alt + arrow moves focused window to another workspace

(I know it's not the same thing, but it's sort of related)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 14.04.0

---------------
ubuntu-settings (14.04.0) trusty; urgency=low

  * Set the keybindings for moving windows to workspace up & down to only
    be <Shift><Ctrl><Alt>Up/Down instead of <Super><Shift>Page_Up/Page_Down
    since Compiz sometimes binds the wrong combination. (LP: #1241282)
 -- Chris Townsend <email address hidden> Mon, 21 Oct 2013 10:25:44 -0400

Changed in ubuntu-settings (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-settings (Ubuntu Saucy):
status: New → Confirmed
Changed in ubuntu-settings (Ubuntu Saucy):
status: Confirmed → Invalid
Changed in ubuntu-settings (Ubuntu Saucy):
status: Invalid → Confirmed
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in ubuntu-settings (Ubuntu Saucy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers