Collect DCD file

Bug #1786432 reported by Jean-Baptiste Lallement on 2018-08-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-report (Ubuntu)
Undecided
Didier Roche
Bionic
Undecided
Didier Roche

Bug Description

[Impact]
 * OEM images provided by Canonical and other companies use a tracking id called Distribution Channel Descriptor (DCD). There is interest of reporting this as part of ubuntu-report one.

[Test Case]
 * Install the new version from -proposed
 * run `ubuntu-report show`
   -> check there are no DCD field in OEM on the outputed json
 * Ship a valid DCD file as /var/lib/ubuntu_dist_channel (see below for one)
 * run `ubuntu-report show`
   -> check that DCD field is part of the OEM stenza, and corresponds to the non commented full line string in /var/lib/ubuntu_dist_channel.

[Regression Potential]
 * The only impact is for OEM shipping a DCD file. The field is ommitted if empty and have the same logic than other fields (not failing if any bug in that code path appears)
 * Backed up via a lot of new and existing tests, checking corner cases like no valid file, empty file, no file, file with only commented, file with extra \n…

____

OEM use a tracking id called Distribution Channel Descriptor (DCD) located in .disk/ubuntu_dist_channel and installed by Ubiquity to /var/lib/ubuntu_dist_channel

When this information exists ubuntu-report must collect the tracking id. The proposal is to store it in the OEM key:

[...]
"OEM": {
    "Vendor": "Vendor Name",
    "Product": "4287CTO",
    "DCD": "<Tracking Id>
  }
[...]

An example of content of a DCD file is:
"""""
# This is a distribution channel descriptor
# For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
canonical-oem-somerville-xenial-amd64-20160624-2
"""""

[1] https://wiki.ubuntu.com/FoundationsTeam/Specs/OemTrackingId

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: ubuntu-report 1.2.0
ProcVersionSignature: Ubuntu 4.17.0-6.7-generic 4.17.9
Uname: Linux 4.17.0-6-generic x86_64
ApportVersion: 2.20.10-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Aug 10 10:23:04 2018
Dependencies:
 gcc-8-base 8.2.0-1ubuntu2
 libc6 2.27-3ubuntu1
 libgcc1 1:8.2.0-1ubuntu2
InstallationDate: Installed on 2014-07-15 (1487 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
SourcePackage: ubuntu-report
UpgradeStatus: Upgraded to cosmic on 2018-03-24 (138 days ago)

Jean-Baptiste Lallement (jibel) wrote :
Didier Roche (didrocks) wrote :

I just have one question: do we keep the OEM field in ubiquity (the boolean true/false?). I think once we get DCD, this is of less value.

No need to SRU that, but maybe for bionic, WDYT?

description: updated
description: updated
Jean-Baptiste Lallement (jibel) wrote :

I'm not sure all the OEM use the DCD file. We can keep the OEM true/false as it is an installation mode that can be used by anyone without remastering the entire image.

Jean-Baptiste Lallement (jibel) wrote :

We need to SRU that to bionic.

Didier Roche (didrocks) wrote :

Sorry for being unclear, the "no need to SRU that" was intended for the optional ubiquity removal.

Didier Roche (didrocks) on 2018-08-28
Changed in ubuntu-report (Ubuntu):
status: New → Triaged
Didier Roche (didrocks) on 2018-08-30
Changed in ubuntu-report (Ubuntu Bionic):
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
Changed in ubuntu-report (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) on 2018-08-30
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-report - 1.3.0

---------------
ubuntu-report (1.3.0) cosmic; urgency=medium

  * Include optional DCD OEM file (LP: #1786432)
  * Collect number of disks and their sizes (LP: #1784383)
  * Misc grammar updates, thanks Robin Hood

 -- Didier Roche <email address hidden> Thu, 30 Aug 2018 10:05:54 +0200

Changed in ubuntu-report (Ubuntu):
status: Triaged → Fix Released

Hello Jean-Baptiste, or anyone else affected,

Accepted ubuntu-report into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-report/1.3.0~18.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-report (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Bionic:
I have verified that the version of ubuntu-report 1.3.0~18.04 in -proposed fixes the issue. Note that if the tracking id contains whitespaces it is considered invalid and the field is not present in the report but I think that's ok.

Marking as verification-done

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for ubuntu-report has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-report - 1.3.0~18.04

---------------
ubuntu-report (1.3.0~18.04) bionic; urgency=medium

  * Include optional DCD OEM file (LP: #1786432)
  * Collect number of disks and their sizes (LP: #1784383)
  * Misc grammar updates, thanks Robin Hood

 -- Didier Roche <email address hidden> Thu, 30 Aug 2018 14:04:13 +0200

Changed in ubuntu-report (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers