Collect number of disks and disk size

Bug #1784383 reported by Jean-Baptiste Lallement on 2018-07-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-report (Ubuntu)
Undecided
Didier Roche
Bionic
Undecided
Didier Roche

Bug Description

[Impact]
 * Currently the guided methods of the Ubuntu installer only address single disk setup. When a user have several disks on his machine he has to use the manual partitioning which is prone to failure for inexperienced users.
 * It would be useful to understand how many disks are installed on a system and their size to determine how update the installer to best suit users' needs.
 * We only report mounted partitions size

[Test Case]
 * Install the new version from -proposed
 * run `ubuntu-report show`
   -> check that there is a Disks field, corresponding to arrays in GiB of disk sizes attached to the system. Non spinning disks, ssds or virtual machine disks are ignored.

[Regression Potential]
 * As with the rest of ubuntu-report code, any error results in an empty, and so ommitted field. We report as many valid values as possible and discare invalid ones.
 * Backed up via a lot of new and existing tests, checking corner cases like no valid size/number of block, empty size/number of block file, missing partial informations from the kernel, ignoring loop and other random devices…

____

Currently the guided methods of the Ubuntu installer only address single disk setup. When a user have several disks on his machine he has to use the manual partitioning which is prone to failure for inexperienced users.

It would be useful to understand how many disks are installed on a system and their size to determine how update the installer to best suit users' needs.

This information is available from /sys/block/<device>/size . The information is in blocks. The block size is available from /sys/block/<device>/queue/{logical|physical}_block_size

For example on my system

$ cat /sys/block/sda/{size,queue/*_block_size}
125045424
512
512

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: ubuntu-report 1.2.0
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
Uname: Linux 4.15.0-23-generic x86_64
ApportVersion: 2.20.10-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Jul 30 14:42:25 2018
Dependencies:
 gcc-8-base 8.2.0-1ubuntu2
 libc6 2.27-3ubuntu1
 libgcc1 1:8.2.0-1ubuntu2
InstallationDate: Installed on 2014-07-15 (1476 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
SourcePackage: ubuntu-report
UpgradeStatus: Upgraded to cosmic on 2018-03-24 (127 days ago)

Jean-Baptiste Lallement (jibel) wrote :
Didier Roche (didrocks) on 2018-07-30
Changed in ubuntu-report (Ubuntu):
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
description: updated
Didier Roche (didrocks) on 2018-08-30
Changed in ubuntu-report (Ubuntu Bionic):
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) on 2018-08-30
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-report - 1.3.0

---------------
ubuntu-report (1.3.0) cosmic; urgency=medium

  * Include optional DCD OEM file (LP: #1786432)
  * Collect number of disks and their sizes (LP: #1784383)
  * Misc grammar updates, thanks Robin Hood

 -- Didier Roche <email address hidden> Thu, 30 Aug 2018 10:05:54 +0200

Changed in ubuntu-report (Ubuntu):
status: Triaged → Fix Released

Hello Jean-Baptiste, or anyone else affected,

Accepted ubuntu-report into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-report/1.3.0~18.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-report (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Bionic:
I have verified that the version of ubuntu-report 1.3.0~18.04 in -proposed fixes the issue. I have verified with a single disk and 2 disks.

Marking as verification-done

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for ubuntu-report has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-report - 1.3.0~18.04

---------------
ubuntu-report (1.3.0~18.04) bionic; urgency=medium

  * Include optional DCD OEM file (LP: #1786432)
  * Collect number of disks and their sizes (LP: #1784383)
  * Misc grammar updates, thanks Robin Hood

 -- Didier Roche <email address hidden> Thu, 30 Aug 2018 14:04:13 +0200

Changed in ubuntu-report (Ubuntu Bionic):
status: Fix Committed → Fix Released
Download full text (3.5 KiB)

 I will go back to the previous version, what is the command to apply, because this version 18.04 has a lot of problem.Thank you for your help

    Le jeudi 6 septembre 2018 à 10:01:56 UTC+2, Launchpad Bug Tracker <email address hidden> a écrit :

 This bug was fixed in the package ubuntu-report - 1.3.0~18.04

---------------
ubuntu-report (1.3.0~18.04) bionic; urgency=medium

  * Include optional DCD OEM file (LP: #1786432)
  * Collect number of disks and their sizes (LP: #1784383)
  * Misc grammar updates, thanks Robin Hood

 -- Didier Roche <email address hidden>  Thu, 30 Aug 2018 14:04:13 +0200

** Changed in: ubuntu-report (Ubuntu Bionic)
      Status: Fix Committed => Fix Released

--
You received this bug notification because you are subscribed to Bionic.
Matching subscriptions: marwa
https://bugs.launchpad.net/bugs/1784383

Title:
  Collect number of disks and disk size

Status in ubuntu-report package in Ubuntu:
  Fix Released
Status in ubuntu-report source package in Bionic:
  Fix Released

Bug description:
  [Impact]
  * Currently the guided methods of the Ubuntu installer only address single disk setup. When a user have several disks on his machine he has to use the manual partitioning which is prone to failure for inexperienced users.
  * It would be useful to understand how many disks are installed on a system and their size to determine how update the installer to best suit users' needs.
  * We only report mounted partitions size

  [Test Case]
  * Install the new version from -proposed
  * run `ubuntu-report show`
    -> check that there is a Disks field, corresponding to arrays in GiB of disk sizes attached to the system. Non spinning disks, ssds or virtual machine disks are ignored.

  [Regression Potential]
  * As with the rest of ubuntu-report code, any error results in an empty, and so ommitted field. We report as many valid values as possible and discare invalid ones.
  * Backed up via a lot of new and existing tests, checking corner cases like no valid size/number of block, empty size/number of block file, missing partial informations from the kernel, ignoring loop and other random devices…

  ____

  Currently the guided methods of the Ubuntu installer only address single disk setup. When a user have several disks on his machine he has to use the manual partitioning which is prone to failure for inexperienced users.

  It would be useful to understand how many disks are installed on a
  system and their size to determine how update the installer to best
  suit users' needs.

  This information is available from /sys/block/<device>/size . The
  information is in blocks. The block size is available from
  /sys/block/<device>/queue/{logical|physical}_block_size

  For example on my system

  $ cat /sys/block/sda/{size,queue/*_block_size}
  125045424
  512
  512

  ProblemType: Bug
  DistroRelease: Ubuntu 18.10
  Package: ubuntu-report 1.2.0
  ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
  Uname: Linux 4.15.0-23-generic x86_64
  ApportVersion: 2.20.10-0ubuntu7
  Architecture: amd64
  CurrentDesktop: ubuntu:GNOME
  Date: Mon Jul 30 14:42:25 2018
  Dependencies:
   gcc-8-base 8.2.0-1ubuntu2
   ...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers