do-release-upgrade: Can not run the upgrade, 'No such file or directory'.

Bug #994152 reported by ill on 2012-05-03
This bug report is a duplicate of:  Bug #1178245: missed python-apt dependency. Edit Remove
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

I am also having this problem.

$ sudo do-release-upgrade
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1,206 kB]
Fetched 1,206 kB in 0s (0 B/s)
authenticate 'raring.tar.gz' against 'raring.tar.gz.gpg'
extracting 'raring.tar.gz'
Can not run the upgrade
The error message is 'No such file or directory'.

* Original Description

[The originally reported error “/tmp is mounted noexec” is not a bug.]

Whenever attempting to run do-release-upgrade I get an error:
$ do-release-upgrade
Checking for a new ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1550 kB]
Fetched 1550 kB in 0s (0 B/s)
authenticate 'precise.tar.gz' against 'precise.tar.gz.gpg'
extracting 'precise.tar.gz'
Can not run the upgrade
This usually is caused by a system where /tmp is mounted noexec. Please remount without noexec and run the upgrade again.

I have checked /tmp
$ ls -l / |grep tmp
drwxrwxrwt 15 root root 360 2012-05-03 13:00 tmp

which is obviously not mounted noexec.

[This is not the proper way to check noexec, use ‘mount’.]

Please post the output of:
mount

ill (illumilore) wrote :

mount says that /tmp is mounted noexec for some reason, which means I misinterpreted what the noexec does for folders instead of files?
What would cause /tmp to mount noexec like that when I have other machines that do not have that problem?

I don't know, but you could try this:
sudo mount -o remount,exec /tmp

ill (illumilore) on 2012-05-03
Changed in ubuntu:
status: New → Invalid

Hi,

I am also having this problem.

$ sudo do-release-upgrade
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1,206 kB]
Fetched 1,206 kB in 0s (0 B/s)
authenticate 'raring.tar.gz' against 'raring.tar.gz.gpg'
extracting 'raring.tar.gz'
Can not run the upgrade
The error message is 'No such file or directory'.

But my /tmp folder is already mounted without noexec.

$ mount
/dev/vda1 on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
tmpfs on /tmp type tmpfs (rw)

What happened?

Changed in ubuntu:
status: Invalid → Confirmed
papukaija (papukaija) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage . I have classified this bug as a bug in apt.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

affects: ubuntu → apt (Ubuntu)
Daniel Hartwig (wigs) wrote :

> I have classified this bug as a bug in apt.

No error messages in that output are from apt and do-release-upgrade is from ubuntu-release-upgrader-core not apt.

Richard Cheung (richardcheung-hk) wrote on 2013-05-19:
> Hi,
>
> I am also having this problem.
> …
> Can not run the upgrade
> The error message is 'No such file or directory'.
>
> But my /tmp folder is already mounted without noexec.

As this is really a different problem (very different error message) you should have reported a new bug.

affects: apt (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → New
ill (illumilore) wrote :

This started happening to me again when trying to upgrade to 13.04.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Daniel Hartwig (wigs) wrote :

> This started happening to me again when trying to upgrade to 13.04.

What did? The problem with noexec?

> status: New → Confirmed

Again, please do not confirm your own bugs. It has already been explained that the issue on your system with noexec is not a bug.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → New
Daniel Hartwig (wigs) wrote :

The status of ‘new’ is for ubuntu-release-upgrader to verify the issue reported by Richard Cheung.

Hi,

I have found a solution.

sudo apt-get install python-apt

Problem should be related to the do-release-upgrade script.

On 2 June 2013 15:59, Richard Cheung <email address hidden> wrote:
> Hi,
>
> I have found a solution.
>
> sudo apt-get install python-apt
>

After this, do-release-upgrade does work for you?

Which version of python-apt did you upgrade from and to?

Yes, do-release-upgrade work again.

My ubuntu was installed with virtual machine mode with cd-rom iso and python-apt was not installed before.

$ dpkg -s python-apt
Package: python-apt
Status: install ok installed
Priority: standard
Section: python
Installed-Size: 718
Maintainer: Ubuntu Core Developers <email address hidden>
Architecture: amd64
Multi-Arch: allowed
Version: 0.8.8ubuntu6
Provides: python2.7-apt
Depends: python (>= 2.7.1-0ubuntu2), python (<< 2.8), libapt-inst1.5 (>= 0.8.11), libapt-pkg4.12 (>= 0.8.16~exp9), libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), libstdc++6 (>= 4.4.0), python-apt-common
Recommends: lsb-release, iso-codes, xz-utils (>= 5.1.1alpha+20120614-1)
Suggests: python-apt-dbg, python-gtk2, python-vte, python-apt-doc
Breaks: apt-forktracer (<< 0.3), apt-listchanges (<< 2.85), apt-p2p (<< 0.1.6), apt-xapian-index (<< 0.25), aptdaemon (<< 0.11+bzr343-1~), aptoncd (<< 0.1.98+bzr117), bcfg2 (<< 1.0.1), bzr-builddeb (<< 2.4), computer-janitor (<< 1.14.1-1+), debdelta (<< 0.41+), debpartial-mirror (<< 0.2.98), debsecan (<< 0.4.15), gdebi (<< 0.6.1), germinate (<< 1.21), gnome-codec-install (<< 0.4.5), mini-dinstall (<< 0.6.28), packagekit-backend-apt (<= 0.4.8-0ubuntu4), python-cdd (<< 0.0.10), python-dogtail (<< 0.6.1-3.1+), python-software-properties (<< 0.70.debian-1+), rebuildd (<< 0.3.9), software-center (<< 1.1.21debian2), tla-buildpackage (<< 0.9.14), ubuntu-dev-tools (<< 0.93debian1), unattended-upgrades (<< 0.42debian2), update-manager (<< 0.200.2-1), update-notifier (<< 0.99.3debian9), wajig (<< 2.0.46)
Description: Python interface to libapt-pkg
 The apt_pkg Python interface will provide full access to the internal
 libapt-pkg structures allowing Python programs to easily perform a
 variety of functions, such as:
 .
  - Access to the APT configuration system
  - Access to the APT package information database
  - Parsing of Debian package control files, and other files with a
    similar structure
 .
 The included 'aptsources' Python interface provides an abstraction of
 the sources.list configuration on the repository and the distro level.
Original-Maintainer: APT Development Team <email address hidden>
Python-Version: 2.7

Why I found this solution was because another virtual machine prompt me about the missing of python-apt.

The strange part was that both virtual machine are installed with VM mode (ubuntu 12.10)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Daniel Hartwig (wigs) on 2013-06-04
description: updated
summary: - do-release-upgrade says it can not run the upgrade
+ do-release-upgrade: Can not run the upgrade, 'No such file or
+ directory'.
mcfedr (mcfedr) wrote :

I have just installed python-apt and now it works.

I am also running on a virtual distribution, python-apt wasn't installed before.

Maybe python-apt needs to be a dependancy of ubuntu-release-upgrader-core

spbike (bill-broadley) wrote :

I just installed a ubuntu 13.04 system from scratch, ran:
apt-get install update-manager-core

And got the:
authenticate 'saucy.tar.gz' against 'saucy.tar.gz.gpg'
extracting 'saucy.tar.gz'
Can not run the upgrade
The error message is 'No such file or directory'.

After running apt-get install python-apt it worked.

I think it's just the missing dependency on python-apt.

rantsh (rantsh) wrote :

I had exactly the same situation as "spbike" and got it fixed exactly the same way with a 12.10 (quantal) server

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers