Remove the XFS /boot upgrade check for noble

Bug #2067886 reported by Julian Andres Klode
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Fix Released
Undecided
Nick Rosbrook
Noble
Fix Released
Undecided
Nick Rosbrook

Bug Description

[Impact]
Upgrades for users with XFS /boot are wrongly blocked for noble as the workaround for mantic hasn't been removed.

[Test plan]
Run an upgrade on an affected system. The upgrade should not be blocked:

$ do-release-upgrade --proposed

[Where problems could occur]
We are just removing a quirk, so there is very low risk. However, it is possible that other upgrade bugs exist for such platforms, and that they would be revealed by us removing this quirk.

Related branches

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
tags: added: foundations-todo
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Nick Rosbrook (enr0n)
Nick Rosbrook (enr0n)
description: updated
Changed in ubuntu-release-upgrader (Ubuntu Noble):
status: New → Triaged
Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Noble):
assignee: nobody → Nick Rosbrook (enr0n)
Nick Rosbrook (enr0n)
Changed in ubuntu-release-upgrader (Ubuntu Noble):
status: Triaged → In Progress
Changed in ubuntu-release-upgrader (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:24.10.4

---------------
ubuntu-release-upgrader (1:24.10.4) oracular; urgency=medium

  * DistUpgrade: drop quirk for systems with BIOS and XFS /boot (LP: #2067886)
  * DistUpgrade: use tempfile for apt extended_states during simulation
    (LP: #2067585)
  * DistUpgradeQuirks: drop t64 replacement quirk
  * Run pre-build.sh: updating mirrors, demotions, and translations.

 -- Nick Rosbrook <email address hidden> Wed, 05 Jun 2024 16:58:21 -0400

Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
xghost (h-k-ghost) wrote :

Thanks for the follow-up and fix. Looking forward to the updated packages downstream.

Revision history for this message
Lorin Ricker (lorin) wrote :

I've tried to upgrade from 23.10 to 24.04/LTS twice, once last week (1Jun2024) and again today (12June2024), expecting this problem to be resolved/fixed and a "normal upgrade" would work.

Still encountering the same refusal box: "Cannot upgrade this system; Due to a bug in grub, tihs system cannot be safely upgraded at this time. See https://launchpad.net/bugs/2039172" and that bug 2039127 leads to this one, 2067886.

Respectfully: When will this "quirk" be fixed so that upgrades actually work, and how can I find out when the fix is in? Camp on this page? TIA, Lorin

Revision history for this message
xghost (h-k-ghost) wrote :

What's the ETA for the fix making it to users downstream?...

Revision history for this message
Julian Andres Klode (juliank) wrote :

The ubuntu-release-upgrader fix for noble has been uploaded on the 5th and is waiting for an SRU team member to approve it, then it will enter proposed, and after validation, and 7 days of no complaints, it will be released (not on Fridays).

So the earliest possible release date would be the 24th, but of course we don't know if this will be approved today, there are plenty more SRUs in the queue ahead of it.

Revision history for this message
Andreas Hasenack (ahasenack) wrote : Please test proposed package

Hello Julian, or anyone else affected,

Accepted ubuntu-release-upgrader into noble-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:24.04.19 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-noble to verification-done-noble. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-noble. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-release-upgrader (Ubuntu Noble):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-noble
Revision history for this message
Lorin Ricker (lorin) wrote :

Julian and Andreas! Many thanks for your prompt responses... together, these shed a lot of light and clarity on the release process for those of us who don't deal with these issues/processes very much (probably the vast majority of the Ubuntu user community).

Please know that those of us who use and rely upon Ubuntu do thank you and extend our sincere appreciation to those of you community volunteers and Canonical employees who provide these major releases, upgrades and bug fixes! Many thanks... ongoing!

Revision history for this message
Nick Rosbrook (enr0n) wrote :

If you are currently hitting this problem, and would like to help verify the fix, please run the upgrade again with:

$ do-release-upgrade --proposed

description: updated
Revision history for this message
Bart Seghers (seghersbart89) wrote :

I just performed the upgrade from mantic 23.10 to noble 24.04 on a system with /boot as XFS via do-release-upgrade --proposed and can confirm the fix works

bart@bart-All-Series:/var/log/apt$ df -T
Bestandssysteem Type 1K-blokken Gebruikt Beschikbaar Geb% Aangekoppeld op
tmpfs tmpfs 1625076 2264 1622812 1% /run
/dev/sdd1 xfs 74962164 15290716 59671448 21% /
tmpfs tmpfs 8125380 12 8125368 1% /dev/shm
tmpfs tmpfs 5120 16 5104 1% /run/lock
/dev/sdd2 ext4 165432960 80507632 76449016 52% /home
/dev/sda2 vfat 97280 32757 64523 34% /boot/efi
tmpfs tmpfs 1625076 148 1624928 1% /run/user/1000

bart@bart-All-Series:/var/log/apt$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=24.04
DISTRIB_CODENAME=noble
DISTRIB_DESCRIPTION="Ubuntu 24.04 LTS"

Please let me know if you require any additional logs as proof

Revision history for this message
Nick Rosbrook (enr0n) wrote :

Thanks, Bart! Can you please attach /var/log/dist-upgrade/main.log as well?

Revision history for this message
Bart Seghers (seghersbart89) wrote :

Please find the requested log file /var/log/dist-upgrade/main.log.

Revision history for this message
Nick Rosbrook (enr0n) wrote :

Thanks! That log confirms that you ran the upgrade using the upgrader from noble-proposed. That along with your previous comment confirms the fix.

Thanks again!

tags: added: verification-done-noble
removed: verification-needed-noble
Revision history for this message
xghost (h-k-ghost) wrote :

I upgraded using the `--proposed` command. When it asked me to reboot at the end, I did, and then, after the GRUB menu, the graphical interface never came up. (I waited a reasonable amount of time.) I had to power off the PC (holding down power button). After that, I was able to boot the system successfully after entering recovery mode and then resuming the normal boot sequence. (I'll do a normal (re)boot later.) I'm not sure what's so "special" about rebooting that my system would hang.

There are other issues, like icon-only taskbar icons for the Firefox and Thunderbird going missing, and them not showing up using the built-in search of the Application Launcher... or anywhere else, for that matter. (No, they're not even listed under the Internet section...)

I suppose that at least the particular fix of removing the obsolete upgrade-aborting workaround worked as intended. As for the rest of it, well...

Revision history for this message
xghost (h-k-ghost) wrote :

Regular boots don't work for me. I have to keep entering Recovery Mode -> Resume in order to boot the system without it hanging. This is likely caused by something else and unrelated to this particular issue, though. How you intend to proceed is up to you guys.

Revision history for this message
Nick Rosbrook (enr0n) wrote :

@xghost it does not sound like you are hitting the original bug that this upgrader quirk was meant to prevent (bug 2039172), so I would suggest asking for help on e.g. askubuntu.com or IRC, or look at https://discourse.ubuntu.com/t/community-support/709. Or, open a new bug report and provide relevant logs etc.

Revision history for this message
Lorin Ricker (lorin) wrote :

Like Mr Seghers (06-24-2024), I have today (06-25-2024) successfully upgraded to 24.04/LTS using:

$ do-release-upgrade --proposed

Once launched, worked fine just like a "normal" upgrade.

burro$ df -T
Filesystem Type 1K-blocks Used Available Use% Mounted on
tmpfs tmpfs 1629436 2516 1626920 1% /run
/dev/sda6 xfs 124937624 46031360 78906264 37% /
tmpfs tmpfs 8147180 16 8147164 1% /dev/shm
tmpfs tmpfs 5120 12 5108 1% /run/lock
/dev/sda7 xfs 847440604 484964856 362475748 58% /home
tmpfs tmpfs 1629436 2628 1626808 1% /run/user/1000

/home/lorin -- ruby 3.3.0 -- [clock 15:02:54]
burro$ uname -a
Linux burro 6.8.0-35-generic #35-Ubuntu SMP PREEMPT_DYNAMIC Mon May 20 15:51:52 UTC 2024 x86_64 x86_64 x86_64 GNU/Linux

/home/lorin -- ruby 3.3.0 -- [clock 15:03:00]
burro$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=24.04
DISTRIB_CODENAME=noble
DISTRIB_DESCRIPTION="Ubuntu 24.04 LTS"

Also attaching /var/log/dist-upgrade/main.log

Thanks -- Lorin

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:24.04.19

---------------
ubuntu-release-upgrader (1:24.04.19) noble; urgency=medium

  * DistUpgrade: drop quirk for systems with BIOS and XFS /boot (LP: #2067886)
  * DistUpgradeQuirks: make sure replacement.candidate is not None
    (LP: #2067071)
  * DistUpgrade: use tempfile for apt extended_states during simulation
    (LP: #2067585)
  * Run pre-build.sh: updating mirrors, demotions, and translations.

 -- Nick Rosbrook <email address hidden> Tue, 04 Jun 2024 11:55:51 -0400

Changed in ubuntu-release-upgrader (Ubuntu Noble):
status: Fix Committed → Fix Released
Revision history for this message
Andreas Hasenack (ahasenack) wrote : Update Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Phillip Smith (fukawi2) wrote :

This appears to still be blocking 22.04 to 24.04 upgrades.

With `do-release-upgrade -d` I get the original error:

========
  Cannot upgrade this system

  Due to a bug in grub, this system cannot be safely upgraded at this time.

  See https://launchpad.net/bugs/2039172.
========

With `do-release-upgrade -p` it tries to upgrade to 23.10 instead of 24.04

I have installed all available updates, include python3-update-manager ubuntu-minimal ubuntu-server ubuntu-standard update-manager-core which were "kept back"

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.