tried to upgrade the distro to 22.04

Bug #2036295 reported by Xavier MAXIMIN
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)

Bug Description

Could not determine the upgrade

An unresolvable problem occurred while calculating the upgrade.

This was likely caused by:
* Unofficial software packages not provided by Ubuntu
Please use the tool 'ppa-purge' from the ppa-purge
package to remove software from a Launchpad PPA and
try the upgrade again.

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If
you want to investigate this yourself the log files in
'/var/log/dist-upgrade' will contain details about the upgrade.
Specifically, look at 'main.log' and 'apt.log'.


2023-09-15 19:16:24,378 DEBUG Installing 'linux-generic' (linux metapackage may have been accidentally uninstalled)
2023-09-15 19:16:24,396 DEBUG Marking 'ubuntu-desktop' for upgrade
2023-09-15 19:16:24,517 WARNING Can't mark 'ubuntu-desktop' for upgrade (E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.)
2023-09-15 19:16:24,739 ERROR Dist-upgrade failed: 'Broken packages after upgrade: evolution-data-server, gnome-control-center, libgirepository-1.0-1, ubuntu-desktop'
2023-09-15 19:16:24,756 DEBUG abort called

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ubuntu-release-upgrader-core 1:20.04.41
ProcVersionSignature: Ubuntu 5.15.0-83.92~20.04.1-generic 5.15.116
Uname: Linux 5.15.0-83-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu27.27
Architecture: amd64
CasperMD5CheckResult: skip
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Fri Sep 15 19:22:36 2023
InstallationDate: Installed on 2021-08-01 (775 days ago)
InstallationMedia: Ubuntu LTS "Focal Fossa" - Release amd64 (20210209.1)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to focal on 2023-09-15 (0 days ago)

Revision history for this message
Xavier MAXIMIN (xmaximin) wrote :
Revision history for this message
Nick Rosbrook (enr0n) wrote :

Reviewing the files from your upgrade attempt, you have installed packages from the deadsnakes PPA. Some of the packages installed are newer than those in the official archive, which is keeping some python packages installed which then prevents the upgrade from being calculated. Please try using the ppa-purge tool to remove packages installed from ppa:deadsnakes/ppa. After that you can try upgrading again and if it still fails open a new bug report. Thanks and good luck!

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Invalid
tags: added: deadsnakes-ppa
Revision history for this message
Xavier MAXIMIN (xmaximin) wrote :


I manage to do that using that sudo add-apt-repository --remove ppa:deadsnakes/ppa
That did not work but that

 sudo ppa-purge deadsnakes worked and now

I have a new problem, that I think I will be able to deal with thanks ( since documentation and problem already exist on other forum. )

Revision history for this message
Xavier MAXIMIN (xmaximin) wrote : solved the problem by the way But I had to restart to the efi stuff was really mounted as the fstab stuff needs to be loaded on start of the machine. voila thanks again

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.