[FFe] Update the ubuntu-desktop-minimal seed to use the firefox snap

Bug #1943840 reported by Olivier Tilloy
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-meta (Ubuntu)
Fix Released
Undecided
Olivier Tilloy
Impish
Fix Released
Undecided
Olivier Tilloy
ubuntu-release-upgrader (Ubuntu)
Fix Released
Undecided
Olivier Tilloy
Impish
Fix Released
Undecided
Olivier Tilloy
ubuntu-settings (Ubuntu)
Fix Released
Undecided
Olivier Tilloy
Impish
Fix Released
Undecided
Olivier Tilloy

Bug Description

Per Canonical's distribution agreement with Mozilla, we're making the snap¹ the default installation of firefox on desktop ISOs starting with Ubuntu 21.10.

The snap is built and published for amd64, armhf and arm64. It is jointly maintained by Mozilla and the Ubuntu desktop team, and published by Mozilla.

This requires updating the desktop-minimal seed, as well as ubuntu-release-upgrader.

¹ https://snapcraft.io/firefox

Tags: fr-1722

Related branches

tags: added: fr-1722
Revision history for this message
Oliver Grawert (ogra) wrote (last edit ):

for people not using the official announcement channels, here is a link to the related public announcement (with details on the reasoning and a place for discussion and feedback):

https://discourse.ubuntu.com/t/feature-freeze-exception-seeding-the-official-firefox-snap-in-ubuntu-desktop/24210

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon)
Changed in ubuntu-meta (Ubuntu Impish):
assignee: nobody → Olivier Tilloy (osomon)
Changed in ubuntu-release-upgrader (Ubuntu Impish):
assignee: nobody → Olivier Tilloy (osomon)
Revision history for this message
Olivier Tilloy (osomon) wrote :
Revision history for this message
Olivier Tilloy (osomon) wrote :

Proposed update for ubuntu-release-upgrader: https://code.launchpad.net/~osomon/ubuntu-release-upgrader/+git/ubuntu-release-upgrader/+merge/408838

Please note that these were not actually tested. This requires thorough testing before actually being considered for upload.

Revision history for this message
Olivier Tilloy (osomon) wrote :

I opened and closed the stable/ubuntu-21.10 channel for the firefox snap, per https://wiki.ubuntu.com/UbuntuSeededSnaps#Channel_availability.

I then tested a dist-upgrade with my branch of ubuntu-release-upgrader in a clean and fully up-to-date hirsute VM, and I observed that the firefox snap was being installed and the deb uninstalled, and I also saw that:

 - the snap-store snap is being upgraded, as expected

 - firefox-locale-* debs are not being removed, they probably should

 - the gnome-3-34-1804 snap isn't being removed, despite becoming unnecessary (on a clean system with only the minimally seeded snaps − in practice though it is likely that on an actual system there will be other snaps that require it)

 - rebooting after the dist upgrade gives a blank login screen, there appears to be something broken there (probably unrelated to this change)

 - the default firefox launcher in the dock will be removed when the deb is uninstalled, it would be good to replace it with a launcher for the snap

Revision history for this message
Olivier Tilloy (osomon) wrote :

Proposed update to ubuntu-settings to address the last point in the previous comment (firefox launcher in the dock): https://code.launchpad.net/~osomon/ubuntu/+source/ubuntu-settings/+git/ubuntu-settings/+merge/408924

Revision history for this message
Brian Murray (brian-murray) wrote :

ubuntu-meta (1.472) impish; urgency=medium

  * Refreshed dependencies
  * Added dmidecode to standard [riscv64]
  * Added gnome-initial-setup to desktop-minimal-recommends [riscv64],
    desktop-recommends [riscv64]
  * Added language-selector-common to desktop, desktop-minimal, desktop-
    raspi
  * Added open-vm-tools to server-raspi-recommends [arm64], server-
    recommends [arm64]
  * Added ubuntu-report to desktop-minimal-recommends [riscv64], desktop-
    recommends [riscv64]
  * Removed firefox from desktop-minimal-recommends [amd64 arm64 armhf
    ppc64el s390x], desktop-recommends [amd64 arm64 armhf ppc64el s390x]
  * Removed language-selector-common from standard
  * Removed xul-ext-ubufox from desktop-minimal-recommends, desktop-
    recommends

 -- Olivier Tilloy <email address hidden> Wed, 22 Sep 2021 11:09:00 +0200

Changed in ubuntu-meta (Ubuntu Impish):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-settings - 21.10.4

---------------
ubuntu-settings (21.10.4) impish; urgency=medium

  [ Olivier Tilloy ]
  * ubuntu-settings.gsettings-override:
    - Update the dock's gsetting override to pin the launcher for the
      firefox snap (LP: #1943840).

 -- Sebastien Bacher <email address hidden> Wed, 22 Sep 2021 11:39:23 +0200

Changed in ubuntu-settings (Ubuntu Impish):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:21.10.8

---------------
ubuntu-release-upgrader (1:21.10.8) impish; urgency=medium

  [ Olivier Tilloy ]
  * DistUpgrade/deb2snap.json: seed the snaps for firefox (which replaces the
    deb package) and gnome-3-38-2004. (LP: #1943840)

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeFetcherCore.py: when running in non-interactive
    mode do not show the release notes. (LP: #1944475)
  * Run pre-build.sh: updating mirrors, demotions, and translations.

 -- Brian Murray <email address hidden> Wed, 22 Sep 2021 11:22:12 -0700

Changed in ubuntu-release-upgrader (Ubuntu Impish):
status: Confirmed → Fix Released
Changed in ubuntu-meta (Ubuntu Impish):
status: Fix Committed → Fix Released
Olivier Tilloy (osomon)
Changed in ubuntu-settings (Ubuntu Impish):
assignee: nobody → Olivier Tilloy (osomon)
Revision history for this message
Sam Van den Eynde (samvde) wrote :

Honestly, to announce this one month before release without feature parity, is baffling.

As it looks this puts us in a position where we probably have to stop supporting Ubuntu after more than a decade, as the available browsers can't work with our Belgian Identity Card.

And this because of a packaging format. It is honestly mind-boggling.

Revision history for this message
Jonathan White (droidmonkey) wrote :

To expand on the above, have the Firefox and snapd developers figured out how to incorporate native messaging in a snap-based browser? You guys are locking out a significant portion of useful extensions if not figured out.

Revision history for this message
Olivier Tilloy (osomon) wrote :

Sam, that is the reason why we're doing this in a normal, non-LTS release, which gives us time to identify and iron out problems and regressions like this, while exposing the change to real-world testing. The firefox deb package will remain supported for the duration of the 21.10 release, so this is not locking users or extensions out.

Jonathan, native messaging support in strictly-confined browser snaps is being discussed here: https://forum.snapcraft.io/t/native-messaging-support-in-strictly-confined-browser-snaps/26849. Constructive feedback and use cases, as well as suggestions, are welcome. Me-too -like comments and rants are not. Thanks!

Revision history for this message
Sam Van den Eynde (samvde) wrote :

Olivier, I am not sure what is the reasoning here.

That you obviously want to land this in a non-LTS version has nothing to do with the fact the base product is not ready and that the change was announced unacceptably late here. The Flutter-based installer is a nice example. You can obviously develop something for years ánd still land it in a non-LTS.

Locking out users is not just about "the deb still being available". Some people will have the snap, others the deb, and others both. If they have both I have no idea which one is run when they click the FF icon. The upgrade scenario you mention in comment #7 does not seem to be the real world case either.

We just got teleported back in time, where the only way for our helpdesk to know what happens when a user calls the helpdesk, is to open a terminal and run "apt-get" and "ps aux". This is a support hell, especially at scale. Because of a non-critical move to another package format.

And so far no guarantees on the LTS either.

Revision history for this message
Olivier Tilloy (osomon) wrote :

Sam, I know this doesn't address your main grief (it is actively being worked on and tracked in a separate place), but for support purposes, the "Help > About Firefox" dialog will show you whether the application is packaged as a snap. Alternatively opening "about:support" will also reveal this information. That's probably a bit easier than asking users to run commands in a terminal.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers