on azure upgraded from 16 to 18, now can not upgrade from 18 to 20

Bug #1926858 reported by osman d on 2021-05-01

This bug report will be marked for expiration in 58 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

I have upgraded from 16 to 18 LTS on azure. While upgrading I did
change /boot/grub/menu.lst with the newer version and
not change /etc/ssh/sshd_config but the port number with the custom one.
Used these commands after reboot:
sudo su
apt update
apt upgrade
apt dist-upgrade
apt autoremove
apt autoclean
do-release-upgrade

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.44
ProcVersionSignature: Ubuntu 5.4.0-1046.48~18.04.1-azure 5.4.101
Uname: Linux 5.4.0-1046-azure x86_64
ApportVersion: 2.20.9-0ubuntu7.23
Architecture: amd64
CrashDB: ubuntu
Date: Sat May 1 23:50:22 2021
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to bionic on 2021-05-01 (0 days ago)
VarLogDistupgradeLspcitxt:
 00:00.0 Host bridge [0600]: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (AGP disabled) [8086:7192] (rev 03)
 00:07.0 ISA bridge [0601]: Intel Corporation 82371AB/EB/MB PIIX4 ISA [8086:7110] (rev 01)
 00:07.1 IDE interface [0101]: Intel Corporation 82371AB/EB/MB PIIX4 IDE [8086:7111] (rev 01)
 00:07.3 Bridge [0680]: Intel Corporation 82371AB/EB/MB PIIX4 ACPI [8086:7113] (rev 02)
 00:08.0 VGA compatible controller [0300]: Microsoft Corporation Hyper-V virtual VGA [1414:5353]

osman d (iosmandd) wrote :
osman d (iosmandd) wrote :

According to "https://blog.bramp.net/post/2012/04/29/failed-ubuntu-update/" I have found Broken package is "python-is-python2". I have tried "apt-get remove python-is-python2" but couldnt find the package and decided to run "apt-get remove python2*" it removed "python-minimal, python2.7, python2.7-minimal" it looks like solved.

Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this upgrade failure. There is currently a new version of the release upgrader available in -proposed which may resolve the error you've encountered. Please run the following command to test the new version of the upgrader:

  do-release-upgrade -p

Please lets us know the results in this bug report. Thanks again and good luck!

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
tags: added: lp-1928397
osman d (iosmandd) wrote :

I confirm "do-release-upgrade -p" worked well.
Thank you for your time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers