Cannot upgrade to Ubuntu 20.04 despite purging unofficial Launchapd PPAs

Bug #1895574 reported by Omer Farooq Ahmed on 2020-09-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

I tried to upgrade from Ubuntu 18.04 to 20.04 but got the error:

An unresolvable problem occurred while calculating the upgrade.

This was likely caused by:
* Unofficial software packages not provided by Ubuntu
Please use the tool 'ppa-purge' from the ppa-purge
package to remove software from a Launchpad PPA and
try the upgrade again.

I removed two PPAs using ppa-purge and tried again but I am getting the same error.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.38
ProcVersionSignature: Ubuntu 5.4.0-47.51~18.04.1-generic 5.4.55
Uname: Linux 5.4.0-47-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.17
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Mon Sep 14 18:16:30 2020
InstallationDate: Installed on 2019-07-25 (416 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to bionic on 2020-09-14 (0 days ago)
VarLogDistupgradeAptclonesystemstate.tar.gz:
 Error: command ['pkexec', 'cat', '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'] failed with exit code 127: The value for the SHELL variable was not found the /etc/shells file

 This incident has been reported.
mtime.conffile..etc.update-manager.release-upgrades: 2020-06-25T17:43:20.862470

Omer Farooq Ahmed (remo95able) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers