trying upgrade 18.04.5 to 20.04.1 - "There is no development version of an LTS available."

Bug #1890936 reported by Norbert on 2020-08-09
130
This bug affects 19 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Brian Murray
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Have fully upgraded Ubuntu MATE 18.04.5 LTS installed
2. Open terminal and execute

```
sudo do-release-upgrade
```

Expected results:
* upgrade process started

Actual results:
* upgrade process does not start:

```
$ sudo do-release-upgrade
Checking for a new Ubuntu release
There is no development version of an LTS available.
To upgrade to the latest non-LTS develoment release
set Prompt=normal in /etc/update-manager/release-upgrades.
```

Note: this is not expected as per https://wiki.ubuntu.com/FocalFossa/ReleaseNotes

> The -d switch is necessary to upgrade from Ubuntu 18.04 LTS as upgrades have not yet been enabled and will only be enabled after the first point release of 20.04 LTS

The problem is caused by the fact that http://changelogs.ubuntu.com/meta-release-lts is out of date. It does not mention 20.04 LTS (Focal Fossa).

Workaround: setting Prompt=normal in /etc/update-manager/release-upgrades and re-running the do-release-upgrade command starts the upgrade process.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.38
ProcVersionSignature: Ubuntu 4.15.0-112.113-generic 4.15.18
Uname: Linux 4.15.0-112-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.16
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: MATE
Date: Sun Aug 9 12:23:18 2020
InstallationDate: Installed on 2018-04-26 (835 days ago)
InstallationMedia: Ubuntu-MATE 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Saurabh Minni (the100rabh) wrote :

I am facing the same issue with Kubuntu 18.04. Even with the command `sudo do-release-upgrade -d` I get the following error

```
Checking for a new Ubuntu release
Please install all available updates for your release before upgrading.
```

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1890936

tags: added: iso-testing
Rik Mills (rikmills) wrote :

> The problem is caused by the fact that http://changelogs.ubuntu.com/meta-release-lts
> is out of date. It does not mention 20.04 LTS (Focal Fossa).

This has deliberately not been updated yet by the release team AFAIK. The reason being that this is not typically done just before a weekend, as the Canonical/Ubuntu people able to fix unexpected issues may well be unavailable.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Changed in update-manager (Ubuntu):
status: New → Confirmed
mkurz (matthias.kurz) wrote :

> The problem is caused by the fact that http://changelogs.ubuntu.com/meta-release-lts
> is out of date.

Waiting for the update here as well...

Brian Murray (brian-murray) wrote :

There are a couple of issues we are trying to address before we enable upgrades to 20.04.1. The following discourse post is tracking the status of 20.04.1.

https://discourse.ubuntu.com/t/focal-fossa-20-04-1-lts-point-release-status-tracking/17604

Changed in ubuntu-release-upgrader (Ubuntu):
milestone: none → ubuntu-20.04.1
description: updated
Akbarkhon Variskhanov (kbar) wrote :

Update Notifier doesn't notify of a new available version either. Changing "Notify me of a new Ubuntu version" from "For long-term support versions" to "For any new version" makes Update Notifier aware of it. This step is identical to manually editing the file /etc/update-manager/release-upgrades.

The reason is that 20.04.1 is still marked as a development release.

Julian Andres Klode (juliank) wrote :

Yes, that's the reason-ish, and it's correct, there are still severe upgrade bugs that need fixing.

MikeR (mike-rechtman) wrote :

Its the 31st of August, and update to 20.4.1 is stll not released.
When (about) will there be a fix?
Or will 20.04 update be skipped, and 21.xx will come out as an LTS release

Saurabh Minni (the100rabh) wrote :

Relax Mike,
I guess folks are working on it. Some serious issues need to be sorted before this can be fixed. Track them at https://discourse.ubuntu.com/t/focal-fossa-20-04-1-lts-point-release-status-tracking/17604

Roman Shchekin (mrqtros) wrote :

Hi guys, can you please tell me why is it still unassigned? A lot of people are awaiting for this bug to be fixed as blocker for an upgrade to 20.04!

Brian Murray (brian-murray) wrote :

The Ubuntu Release team is aware of the fact that upgrades to 20.04 are not enabled yet and want them enabled like commentors on this bug report. That being said this bug has tasks for ubuntu-release-upgrader and update-manager neither of which are responsible for the meta-release file on changelogs.ubuntu.com and actually there isn't a project for tracking bugs with the meta-release files. Subsequently, assigning the tasks for this bug won't really have any practical effect but I'll assign myself anyway.

Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
Brian Murray (brian-murray) wrote :

I've updated the meta-release file and you no longer need to use '-d' to upgrade to 20.04.

Changed in ubuntu-release-upgrader (Ubuntu):
status: Confirmed → Fix Released
Changed in update-manager (Ubuntu):
status: Confirmed → Fix Released
Max (maxmax) wrote :

I've run "apt update" and "apt-upgrade", there are no further packages available to update. (29/10/2020)

The "Software Updater" (GUI) tool says:

"Sorry, there are no more upgrades for this system. (i386 architecture)".

lsb_release -a shows: "Ubuntu 18.04.5 LTS"

The "release-upgrades" config file is set to: Prompt=lts

"apt dist-upgrade" does not start, also gives the "0 upgraded" etc... output.

Max (maxmax) wrote :

The root-cause for my dist-upgrade problem seems to be this:

https://wiki.ubuntu.com/FocalFossa/ReleaseNotes

Quote: "Users of the i386 architecture will not be presented with an upgrade to Ubuntu 20.04 LTS. Support for i386 as a host architecture was dropped in 19.10."

:-(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions