always come system program problem detected

Bug #1885564 reported by M Ravindra Reddy on 2020-06-29

This bug report will be marked for expiration in 22 days if no further activity occurs. (find out why)

10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

Now i want to upgrade my system in to 20.04 so, please help me by solving that bug

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.37
ProcVersionSignature: Ubuntu 4.15.0-109.110-generic 4.15.18
Uname: Linux 4.15.0-109-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.15
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Mon Jun 29 18:44:17 2020
InstallationDate: Installed on 2019-07-30 (334 days ago)
InstallationMedia: Ubuntu 16.04.6 LTS "Xenial Xerus" - Release amd64 (20190227)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to bionic on 2020-06-29 (0 days ago)

Brian Murray (brian-murray) wrote :

I suspect you have some packages leftover from a previous release of Ubuntu which require python (as opposed to python3) installed on your system. Could you run the command 'ubuntu-support-status --list | grep Unsupported' and add the output to this bug report? Thanks in advance.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
tags: added: could-be-python
Download full text (8.2 KiB)

I used This command :--> 'ubuntu-support-status --list | grep Unsupported
 I am Getting the Following result

adobe-flash-properties-gtk Unsupported
adobe-flashplugin Unsupported
ansible Unsupported
anydesk Unsupported
apt-transport-https Unsupported
aufs-tools Unsupported
browser-plugin-freshplayer-pepperflash Unsupported
cgroupfs-mount Unsupported
containerd.io Unsupported
cpp-5 Unsupported
dconf-editor Unsupported
dconf-tools Unsupported
docker-ce Unsupported
docker-ce-cli Unsupported
e2fsprogs-l10n Unsupported
evolution-data-server-online-accounts Unsupported
fonts-nanum Unsupported
fonts-stix Unsupported
fonts-takao-pgothic Unsupported
g++-5 Unsupported
gcc-5 Unsupported
gcc-5-base Unsupported
gcc-6-base Unsupported
geoclue Unsupported
geoclue-ubuntu-geoip Unsupported
gnome-tweaks Unsupported
gnome-user-share Unsupported
google-chrome-stable Unsupported
gstreamer1.0-fluendo-mp3 Unsupported
gstreamer1.0-vaapi Unsupported
gtk3-nocsd Unsupported
imagemagick-common Unsupported
indicator-appmenu Unsupported
indicator-datetime Unsupported
indicator-printers Unsupported
jayatana Unsupported
libasan2 Unsupported
libbabeltrace-ctf1 Unsupported
libcolumbus1-common Unsupported
libcolumbus1v5 Unsupported
libdata-alias-perl Unsupported
libframe6 Unsupported
libgcc-5-dev Unsupported
libgeis1 Unsupported
libgeoclue0 Unsupported
libgeonames-common Unsupported
libgeonames0 Unsupported
libglewmx1.13 Unsupported
libgrail6 Unsupported
libgsoap-2.8.60 Unsupported
libgtk3-nocsd0 Unsupported
libgtkglext1 Unsupported
libhud2 Unsupported
libisl15 Unsupported
liblircclient0 Unsupported
libmpx0 ...

Read more...

Download full text (10.0 KiB)

And I have a so many Broken packages in my system and i tried to fix it, but not solved

How can i fix that broken packages (I think That is the reason, my system is not upgrade.

ravindra@ravindra:~$ grep Broken /var/log/dist-upgrade/apt.log

Broken dpkg:amd64 Breaks on libapt-pkg5.0:amd64 < 1.6.12ubuntu0.1 @ii mK > (< 1.7~b)
Broken libqt5core5a:amd64 Breaks on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mK > (< 4:4.8.7+dfsg-20~)
Broken libuno-sal3:amd64 Breaks on uno-libs3:amd64 < 6.0.7-0ubuntu0.18.04.10 @ii mK >
Broken python2:amd64 Breaks on python:amd64 < 2.7.15~rc1-1 @ii mK > (< 2.7.15-2)
Broken libpython2-stdlib:amd64 Breaks on libpython-stdlib:amd64 < 2.7.15~rc1-1 @ii mK > (< 2.7.15-2)
Broken python2-minimal:amd64 Breaks on python-minimal:amd64 < 2.7.15~rc1-1 @ii mK IPb > (< 2.7.15-2)
Broken gnome-settings-daemon-common:amd64 Breaks on gnome-settings-daemon-schemas:amd64 < 3.28.1-0ubuntu1.3 @ii mK > (< 3.30.1.2-2~)
Broken libqtdbus4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken libqtgui4:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken libqt4-declarative:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken libpython2-dev:amd64 Breaks on libpython-dev:amd64 < 2.7.15~rc1-1 @ii mK > (< 2.7.15-2)
Broken libqt4-dbus:amd64 Depends on libqtdbus4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken qt-at-spi:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8.0)
Broken libqt4-xml:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken qdbus:amd64 Depends on libqt4-xml:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken libsensors-config:amd64 Conflicts on libsensors4:amd64 < 1:3.4.0-4 @ii mK >
Broken libldb2:amd64 Breaks on libldb1:amd64 < 2:1.2.3-1ubuntu0.1 @ii mK > (< 2:2~)
Broken python-keyring:amd64 Breaks on python-keyrings.alt:amd64 < 3.0-1 @ii mK Ib > (< 3.1)
Broken python2-dev:amd64 Breaks on python-dev:amd64 < 2.7.15~rc1-1 @ii mK Ib > (< 2.7.15-2)
Broken libqt4-sql:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken mysql-client-core-8.0:amd64 Conflicts on mysql-client-5.7:amd64 < 5.7.30-0ubuntu0.18.04.1 @ii mK Ib >
Broken mysql-client-core-8.0:amd64 Conflicts on mysql-client-core-5.7:amd64 < 5.7.30-0ubuntu0.18.04.1 @ii mK Ib >
Broken mysql-client-core-8.0:amd64 Conflicts on virtual-mysql-client-core:amd64 < none @un H >
Broken appmenu-qt:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (>= 4:4.8)
Broken mysql-server-core-8.0:amd64 Conflicts on mysql-server-5.7:amd64 < 5.7.30-0ubuntu0.18.04.1 @ii mK Ib >
Broken mysql-server-core-8.0:amd64 Conflicts on mysql-server-core-5.7:amd64 < 5.7.30-0ubuntu0.18.04.1 @ii mK Ib >
Broken mysql-server-core-8.0:amd64 Conflicts on virtual-mysql-server-core:amd64 < none @un H >
Broken libqt4-network:amd64 Depends on libqtcore4:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR > (= 4:4.8.7+dfsg-7ubuntu1)
Broken libdbusmenu-qt2:amd64 Depends on libqt4-dbus:amd64 < 4:4.8.7+dfsg-7ubuntu1 @ii mR...

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → New
Brian Murray (brian-murray) wrote :

Actually could you run the script, unavailable.py, which I've attached to this bug report? It should give me a reduced set of packages to look at. Thanks in advance!

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
Lukas Märdian (slyon) wrote :

Additionally,
would you mind pasting the output of 'dpkg --get-selections' for us?

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers