[SRU] ubuntu-release-upgrader no longer produces tarballs

Bug #1850851 reported by Adam Conrad on 2019-10-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Adam Conrad
Eoan
Undecided
Adam Conrad

Bug Description

[ SRU Justification ]
ubuntu-release-upgrades was unintentionally relying on a debhelper bug/misfeature where mixing and matching dh(1) and explicit make targets would lead "dh binary" to call a binary-indep target in debian/rules, despite no dependency being declared. This dh(1) misfeature went away when arch/indep handling was reworked in debhelper 12.5, and ubuntu-release-upgrader's binary-indep target (which generated the release-upgrader tarball) hasn't been called since.

[ Test Case ]
1) Make sure the release-upgrader tarball is built, included in .changes, and published to the archive.
2) debdiff .deb binaries from this upload and the last to ensure nothing else has gone amiss.

[ Regression Potential ]
Fairly low. This is just fixing some broken assumptions about makefiles and debhelper to deterministically return us to the situation we were arriving at by accident before.

[ Other Info ]
In doing this, and testing interaction between arch and indep targets and dh(1) itself, I noted that there were a few more small fixes to be made which are no-ops in the current package, but are ticking time-bombs if the package ever grows a non-arch-all package, so I'm including those fixes too.

Adam Conrad (adconrad) on 2019-10-31
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Changed in ubuntu-release-upgrader (Ubuntu Eoan):
assignee: nobody → Adam Conrad (adconrad)
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Fix Committed
Adam Conrad (adconrad) on 2019-10-31
Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: New → In Progress

Hello Adam, or anyone else affected,

Accepted ubuntu-release-upgrader into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:19.10.15.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
Adam Conrad (adconrad) wrote :

Verified in both eoan-proposed and focal-proposed that the tarball is built and published to the correct location, and the debs have no differences from their previous versions other than the version numbers.

tags: added: verification-done verification-done-eoan
removed: verification-needed verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:20.04.2

---------------
ubuntu-release-upgrader (1:20.04.2) focal; urgency=medium

  * Fix binary and binary-indep targets to work as intended (LP: #1850851)

 -- Adam Conrad <email address hidden> Thu, 31 Oct 2019 13:38:35 -0600

Changed in ubuntu-release-upgrader (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:19.10.15.2

---------------
ubuntu-release-upgrader (1:19.10.15.2) eoan; urgency=medium

  * Fix binary and binary-indep targets to work as intended (LP: #1850851)

ubuntu-release-upgrader (1:19.10.15.1) eoan; urgency=medium

  * do-release-upgrade: also check for linux-image- in reboot-required.pkgs,
    refusing upgrading before a reboot is performed. (LP: #1844805)

ubuntu-release-upgrader (1:19.10.15) eoan; urgency=medium

  * Don't check for validity of /usr/bin/python symlink because this is no
    longer relevant to the upgrades (and the printed error message was
    inaccurate). LP: #1825655.
  * Clean up remaining references to /usr/bin/python (tests and utilities)
    in the source.

ubuntu-release-upgrader (1:19.10.14) eoan; urgency=medium

  * DistUpgrade/DistUpgradeCache.py: New python3-apt bindings no longer provide
    Package.section, so switch to using Package.{candidate,installed}.section
    whenever applicable. This fixes broken partial upgrades. (LP: #1841675)

ubuntu-release-upgrader (1:19.10.13) eoan; urgency=medium

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeQuirks.py: do not include gnome-system-monitor in
    the deb to snap transition anymore. (LP: #1845485)
  * DistUpgrade/DistUpgradeQuirks.py: improve wording regarding not being able
    to upgrade from a system with an apt architecture of i386.

  [ Łukasz 'sil2100' Zemczak ]
  * DistUpgrade/DistUpgradeQuirks.py: slightly refactor code to fix related
    unit tests.

 -- Adam Conrad <email address hidden> Thu, 31 Oct 2019 13:38:35 -0600

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers