Remove gnome-system-monitor from deb to snap transition

Bug #1845485 reported by Jean-Baptiste Lallement on 2019-09-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray
Eoan
High
Brian Murray

Bug Description

the release upgrader replaces a static list of deb packages by their snap counterpart.
gnome-system-monitor is now seeded as a deb and must not be replaced by a snap on upgrade.

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: ubuntu-release-upgrader-core 1:19.10.12
ProcVersionSignature: Ubuntu 5.3.0-10.11-generic 5.3.0-rc8
Uname: Linux 5.3.0-10-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: ubuntu:GNOME
Date: Thu Sep 26 13:08:42 2019
InstallationDate: Installed on 2014-07-15 (1899 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140520)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to eoan on 2018-03-24 (550 days ago)
VarLogDistupgradeXorgFixuplog:
 INFO:root:/usr/bin/do-release-upgrade running
 INFO:root:No xorg.conf, exiting

Related branches

Jean-Baptiste Lallement (jibel) wrote :
tags: added: artful2bionic
tags: added: third-party-packages
tags: added: rls-ee-incoming
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: Triaged → Fix Committed
assignee: nobody → Brian Murray (brian-murray)
tags: removed: rls-ee-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:19.10.13

---------------
ubuntu-release-upgrader (1:19.10.13) eoan; urgency=medium

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeQuirks.py: do not include gnome-system-monitor in
    the deb to snap transition anymore. (LP: #1845485)
  * DistUpgrade/DistUpgradeQuirks.py: improve wording regarding not being able
    to upgrade from a system with an apt architecture of i386.

  [ Łukasz 'sil2100' Zemczak ]
  * DistUpgrade/DistUpgradeQuirks.py: slightly refactor code to fix related
    unit tests.

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 03 Oct 2019 14:34:06 +0200

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: Fix Committed → Fix Released

Hello Jean-Baptiste, or anyone else affected,

Accepted ubuntu-release-upgrader into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:19.10.15.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: Fix Released → Fix Committed
tags: added: verification-needed verification-needed-eoan
Brian Murray (brian-murray) wrote :

I tested an upgrade from Ubuntu 19.04 to Ubuntu 19.10 and the gnome-system-monitor snap was not installed or refreshed.

2019-11-01 13:58:25,767 INFO Using config files '['./DistUpgrade.cfg']'
2019-11-01 13:58:25,767 INFO uname information: 'Linux clean-disco-amd64 5.0.0-29-generic #31-Ubuntu SMP Thu Sep 12 13:05:32 UTC 2019 x86_64'
2019-11-01 13:58:26,111 INFO apt version: '1.8.3'
2019-11-01 13:58:26,112 INFO python version: '3.7.3 (default, Aug 20 2019, 17:04:43)
[GCC 8.3.0]'
2019-11-01 13:58:26,114 INFO release-upgrader version '19.10.15.1' started
...
2019-11-01 14:19:46,593 DEBUG quirks: running eoanPostUpgrade
2019-11-01 14:19:46,593 DEBUG running Quirks.eoanPostUpgrade
2019-11-01 14:19:49,071 DEBUG refresh of snap core18 succeeded
2019-11-01 14:19:50,996 DEBUG refresh of snap gnome-3-28-1804 succeeded
2019-11-01 14:19:53,518 DEBUG refresh of snap gtk-common-themes succeeded
2019-11-01 14:19:55,516 DEBUG refresh of snap gnome-calculator succeeded
2019-11-01 14:19:57,936 DEBUG refresh of snap gnome-characters succeeded
2019-11-01 14:19:59,858 DEBUG refresh of snap gnome-logs succeeded

tags: added: verification-done verification-done-eoan
removed: verification-needed verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:19.10.15.2

---------------
ubuntu-release-upgrader (1:19.10.15.2) eoan; urgency=medium

  * Fix binary and binary-indep targets to work as intended (LP: #1850851)

ubuntu-release-upgrader (1:19.10.15.1) eoan; urgency=medium

  * do-release-upgrade: also check for linux-image- in reboot-required.pkgs,
    refusing upgrading before a reboot is performed. (LP: #1844805)

ubuntu-release-upgrader (1:19.10.15) eoan; urgency=medium

  * Don't check for validity of /usr/bin/python symlink because this is no
    longer relevant to the upgrades (and the printed error message was
    inaccurate). LP: #1825655.
  * Clean up remaining references to /usr/bin/python (tests and utilities)
    in the source.

ubuntu-release-upgrader (1:19.10.14) eoan; urgency=medium

  * DistUpgrade/DistUpgradeCache.py: New python3-apt bindings no longer provide
    Package.section, so switch to using Package.{candidate,installed}.section
    whenever applicable. This fixes broken partial upgrades. (LP: #1841675)

ubuntu-release-upgrader (1:19.10.13) eoan; urgency=medium

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeQuirks.py: do not include gnome-system-monitor in
    the deb to snap transition anymore. (LP: #1845485)
  * DistUpgrade/DistUpgradeQuirks.py: improve wording regarding not being able
    to upgrade from a system with an apt architecture of i386.

  [ Łukasz 'sil2100' Zemczak ]
  * DistUpgrade/DistUpgradeQuirks.py: slightly refactor code to fix related
    unit tests.

 -- Adam Conrad <email address hidden> Thu, 31 Oct 2019 13:38:35 -0600

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers