Comment 17 for bug 1844805

Brian Murray (brian-murray) wrote :

do-release-upgrade contains the following code:

190 if os.path.exists('/var/run/reboot-required.pkgs'):
191 reboot = False
192 with open('/var/run/reboot-required.pkgs', 'rb') as f:
193 for line in f:
194 if line == b'libc6\n':
195 reboot = True
196 break
197 if reboot:
198 if not options.quiet:
199 print(_("You have not rebooted after updating a package which "
200 "requires a reboot. Please reboot before upgrading."))
201 sys.exit(1)

It sounds like we should be for checking something else in the reboot-required.pkgs file. What would that be?