Activity log for bug #1844805

Date Who What changed Old value New value Message
2019-09-20 14:54:11 Jonathan Kamens bug added bug
2019-09-20 15:19:32 Jonathan Kamens tags amd64 apport-bug eoan amd64 apport-bug eoan regression-release
2019-09-22 08:58:17 Gianfranco Costamagna virtualbox (Ubuntu): status New Incomplete
2019-09-24 04:21:34 Joe Barnett attachment added make.log https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1844805/+attachment/5290832/+files/make.log
2019-09-24 04:21:50 Joe Barnett bug added subscriber Joe Barnett
2019-09-24 04:22:24 Joe Barnett virtualbox (Ubuntu): status Incomplete New
2019-10-11 10:41:15 Gianfranco Costamagna virtualbox (Ubuntu): status New Invalid
2019-10-11 14:24:39 Jonathan Kamens virtualbox (Ubuntu): status Invalid New
2019-10-12 02:48:26 Launchpad Janitor virtualbox (Ubuntu): status New Confirmed
2019-10-23 13:21:00 Gianfranco Costamagna virtualbox (Ubuntu): status Confirmed Invalid
2019-10-23 13:59:36 Jonathan Kamens bug task added ubuntu-release-upgrader (Ubuntu)
2019-10-23 15:26:52 Seth Forshee bug added subscriber Seth Forshee
2019-10-23 19:13:38 Brian Murray ubuntu-release-upgrader (Ubuntu): status New Incomplete
2019-10-23 19:13:43 Brian Murray ubuntu-release-upgrader (Ubuntu): importance Undecided Medium
2019-10-23 19:13:49 Brian Murray tags amd64 apport-bug eoan regression-release amd64 apport-bug eoan regression-release rls-ff-incoming
2019-10-23 19:13:54 Brian Murray bug added subscriber Brian Murray
2019-10-24 16:34:24 Brian Murray ubuntu-release-upgrader (Ubuntu): status Incomplete Triaged
2019-10-24 16:35:34 Brian Murray tags amd64 apport-bug eoan regression-release rls-ff-incoming amd64 apport-bug eoan regression-release
2019-10-24 16:38:25 Brian Murray nominated for series Ubuntu Focal
2019-10-24 16:38:25 Brian Murray bug task added virtualbox (Ubuntu Focal)
2019-10-24 16:38:25 Brian Murray bug task added ubuntu-release-upgrader (Ubuntu Focal)
2019-10-24 16:38:25 Brian Murray nominated for series Ubuntu Eoan
2019-10-24 16:38:25 Brian Murray bug task added virtualbox (Ubuntu Eoan)
2019-10-24 16:38:25 Brian Murray bug task added ubuntu-release-upgrader (Ubuntu Eoan)
2019-10-24 16:38:38 Brian Murray virtualbox (Ubuntu Eoan): status New Invalid
2019-10-24 16:38:41 Brian Murray ubuntu-release-upgrader (Ubuntu Eoan): status New Triaged
2019-10-24 16:38:44 Brian Murray ubuntu-release-upgrader (Ubuntu Eoan): importance Undecided Medium
2019-10-26 12:43:07 Francis Ginther tags amd64 apport-bug eoan regression-release amd64 apport-bug eoan id-5db1d1e0a5035a6075816b57 regression-release
2019-10-28 15:45:16 Łukasz Zemczak ubuntu-release-upgrader (Ubuntu Focal): assignee Łukasz Zemczak (sil2100)
2019-10-28 15:45:19 Łukasz Zemczak ubuntu-release-upgrader (Ubuntu Eoan): assignee Łukasz Zemczak (sil2100)
2019-10-29 09:01:55 Łukasz Zemczak description I upgraded this morning from 19.04 to 19.10 with `do-release-upgrade -d` and the upgrade reported that virtualbox, virtualbox-qt, and virtualbox-dkms encountered problems during the upgrade. I uninstalled and reinstalled them after rebooting and saw this: ``` ERROR (dkms apport): kernel package linux-headers-5.0.0-29-generic is not supported Error! Bad return status for module build on kernel: 5.0.0-29-generic (x86_64) Consult /var/lib/dkms/virtualbox/6.0.12/build/make.log for more information. ``` I think this means the version of virtualbox in 19.10 doesn't want to compile against a 19.04 kernel? The problem with this, of course, is that everyone who upgrades from 19.04 to 19.10 is going to have a 19.04 kernel installed during the upgrade (and afterward, since one old kernel is saved), so the upgrade will fail for everyone with virtualbox installed. I think this needs to be fixed? ProblemType: Bug DistroRelease: Ubuntu 19.10 Package: virtualbox (not installed) ProcVersionSignature: Ubuntu 5.3.0-10.11-generic 5.3.0-rc8 Uname: Linux 5.3.0-10-generic x86_64 ApportVersion: 2.20.11-0ubuntu7 Architecture: amd64 CurrentDesktop: ubuntu:GNOME Date: Fri Sep 20 10:47:44 2019 InstallationDate: Installed on 2019-09-12 (7 days ago) InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416) SourcePackage: virtualbox UpgradeStatus: Upgraded to eoan on 2019-09-20 (0 days ago) [Impact] Currently some users can encounter an error while upgrading from disco to eoan whenever the kernel has been upgraded before starting the upgrade without a reboot first. This can cause certain dkms packages (like virtualbox-dkms) in certain circumstances to fail. The reported case was that the user was running a not-up-to-date kernel, even though being fully upgraded but not rebooted, while only the one in -upgrades had fixes to support building the virtualbox dkms package. We need to make sure such issues do not happen again. Since such issues can occur, we not only have to force people to be fully up-to-date before starting the upgrade but also request a reboot if the kernel has been upgraded. This way we'll be sure the users are running the latest kernel. [Test Case] * On a disco system, enable disco-proposed and upgrade ubuntu-release-upgrader-core. * Upgrade the kernel packages - This can usually be done by simply installing the new kernel package that is currently in disco-proposed. Basically most of the time there's always a new kernel in-flight. - If not, another possibility is looking for a newer kernel in one of the proposed kernel PPAs. * Make sure your system is fully up-to-date. * Run `do-release-upgrade` and make sure it does not allow you to continue the upgrade without restarting the system first. [Regression Potential] I can't easily think of any regression potential, any issues in the changed code would most likely make the bugfix not work. The most absurd thing I could think of is the match being horribly wrong, asking users to do a reboot where it was not really necessary - but that's basically impossible and, actually, not a big deal. [Original Description] I upgraded this morning from 19.04 to 19.10 with `do-release-upgrade -d` and the upgrade reported that virtualbox, virtualbox-qt, and virtualbox-dkms encountered problems during the upgrade. I uninstalled and reinstalled them after rebooting and saw this: ``` ERROR (dkms apport): kernel package linux-headers-5.0.0-29-generic is not supported Error! Bad return status for module build on kernel: 5.0.0-29-generic (x86_64) Consult /var/lib/dkms/virtualbox/6.0.12/build/make.log for more information. ``` I think this means the version of virtualbox in 19.10 doesn't want to compile against a 19.04 kernel? The problem with this, of course, is that everyone who upgrades from 19.04 to 19.10 is going to have a 19.04 kernel installed during the upgrade (and afterward, since one old kernel is saved), so the upgrade will fail for everyone with virtualbox installed. I think this needs to be fixed? ProblemType: Bug DistroRelease: Ubuntu 19.10 Package: virtualbox (not installed) ProcVersionSignature: Ubuntu 5.3.0-10.11-generic 5.3.0-rc8 Uname: Linux 5.3.0-10-generic x86_64 ApportVersion: 2.20.11-0ubuntu7 Architecture: amd64 CurrentDesktop: ubuntu:GNOME Date: Fri Sep 20 10:47:44 2019 InstallationDate: Installed on 2019-09-12 (7 days ago) InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416) SourcePackage: virtualbox UpgradeStatus: Upgraded to eoan on 2019-09-20 (0 days ago)
2019-10-29 09:08:07 Łukasz Zemczak description [Impact] Currently some users can encounter an error while upgrading from disco to eoan whenever the kernel has been upgraded before starting the upgrade without a reboot first. This can cause certain dkms packages (like virtualbox-dkms) in certain circumstances to fail. The reported case was that the user was running a not-up-to-date kernel, even though being fully upgraded but not rebooted, while only the one in -upgrades had fixes to support building the virtualbox dkms package. We need to make sure such issues do not happen again. Since such issues can occur, we not only have to force people to be fully up-to-date before starting the upgrade but also request a reboot if the kernel has been upgraded. This way we'll be sure the users are running the latest kernel. [Test Case] * On a disco system, enable disco-proposed and upgrade ubuntu-release-upgrader-core. * Upgrade the kernel packages - This can usually be done by simply installing the new kernel package that is currently in disco-proposed. Basically most of the time there's always a new kernel in-flight. - If not, another possibility is looking for a newer kernel in one of the proposed kernel PPAs. * Make sure your system is fully up-to-date. * Run `do-release-upgrade` and make sure it does not allow you to continue the upgrade without restarting the system first. [Regression Potential] I can't easily think of any regression potential, any issues in the changed code would most likely make the bugfix not work. The most absurd thing I could think of is the match being horribly wrong, asking users to do a reboot where it was not really necessary - but that's basically impossible and, actually, not a big deal. [Original Description] I upgraded this morning from 19.04 to 19.10 with `do-release-upgrade -d` and the upgrade reported that virtualbox, virtualbox-qt, and virtualbox-dkms encountered problems during the upgrade. I uninstalled and reinstalled them after rebooting and saw this: ``` ERROR (dkms apport): kernel package linux-headers-5.0.0-29-generic is not supported Error! Bad return status for module build on kernel: 5.0.0-29-generic (x86_64) Consult /var/lib/dkms/virtualbox/6.0.12/build/make.log for more information. ``` I think this means the version of virtualbox in 19.10 doesn't want to compile against a 19.04 kernel? The problem with this, of course, is that everyone who upgrades from 19.04 to 19.10 is going to have a 19.04 kernel installed during the upgrade (and afterward, since one old kernel is saved), so the upgrade will fail for everyone with virtualbox installed. I think this needs to be fixed? ProblemType: Bug DistroRelease: Ubuntu 19.10 Package: virtualbox (not installed) ProcVersionSignature: Ubuntu 5.3.0-10.11-generic 5.3.0-rc8 Uname: Linux 5.3.0-10-generic x86_64 ApportVersion: 2.20.11-0ubuntu7 Architecture: amd64 CurrentDesktop: ubuntu:GNOME Date: Fri Sep 20 10:47:44 2019 InstallationDate: Installed on 2019-09-12 (7 days ago) InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416) SourcePackage: virtualbox UpgradeStatus: Upgraded to eoan on 2019-09-20 (0 days ago) [Impact] Currently some users can encounter an error while upgrading from disco to eoan whenever the kernel has been upgraded before starting the upgrade without a reboot first. This can cause certain dkms packages (like virtualbox-dkms) in certain circumstances to fail. The reported case was that the user was running a not-up-to-date kernel, even though being fully upgraded but not rebooted, while only the one in -upgrades had fixes to support building the virtualbox dkms package. We need to make sure such issues do not happen again. Since such issues can occur, we not only have to force people to be fully up-to-date before starting the upgrade but also request a reboot if the kernel has been upgraded. This way we'll be sure the users are running the latest kernel. [Test Case]  * On a disco system, enable {disco,eoan}-proposed and upgrade ubuntu-release-upgrader-core.  * Upgrade the kernel packages    - This can usually be done by simply installing the new kernel package that is currently in {disco,eoan}-proposed. Basically most of the time there's always a new kernel in-flight.    - If not, another possibility is looking for a newer kernel in one of the proposed kernel PPAs.  * Make sure your system is fully up-to-date.  * Run `do-release-upgrade` and make sure it does not allow you to continue the upgrade without restarting the system first. [Regression Potential] I can't easily think of any regression potential, any issues in the changed code would most likely make the bugfix not work. The most absurd thing I could think of is the match being horribly wrong, asking users to do a reboot where it was not really necessary - but that's basically impossible and, actually, not a big deal. [Original Description] I upgraded this morning from 19.04 to 19.10 with `do-release-upgrade -d` and the upgrade reported that virtualbox, virtualbox-qt, and virtualbox-dkms encountered problems during the upgrade. I uninstalled and reinstalled them after rebooting and saw this: ``` ERROR (dkms apport): kernel package linux-headers-5.0.0-29-generic is not supported Error! Bad return status for module build on kernel: 5.0.0-29-generic (x86_64) Consult /var/lib/dkms/virtualbox/6.0.12/build/make.log for more information. ``` I think this means the version of virtualbox in 19.10 doesn't want to compile against a 19.04 kernel? The problem with this, of course, is that everyone who upgrades from 19.04 to 19.10 is going to have a 19.04 kernel installed during the upgrade (and afterward, since one old kernel is saved), so the upgrade will fail for everyone with virtualbox installed. I think this needs to be fixed? ProblemType: Bug DistroRelease: Ubuntu 19.10 Package: virtualbox (not installed) ProcVersionSignature: Ubuntu 5.3.0-10.11-generic 5.3.0-rc8 Uname: Linux 5.3.0-10-generic x86_64 ApportVersion: 2.20.11-0ubuntu7 Architecture: amd64 CurrentDesktop: ubuntu:GNOME Date: Fri Sep 20 10:47:44 2019 InstallationDate: Installed on 2019-09-12 (7 days ago) InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416) SourcePackage: virtualbox UpgradeStatus: Upgraded to eoan on 2019-09-20 (0 days ago)
2019-10-29 09:33:50 Łukasz Zemczak nominated for series Ubuntu Disco
2019-10-29 09:33:50 Łukasz Zemczak bug task added virtualbox (Ubuntu Disco)
2019-10-29 09:33:50 Łukasz Zemczak bug task added ubuntu-release-upgrader (Ubuntu Disco)
2019-10-29 09:34:00 Łukasz Zemczak ubuntu-release-upgrader (Ubuntu Disco): status New Triaged
2019-10-29 09:34:02 Łukasz Zemczak ubuntu-release-upgrader (Ubuntu Disco): assignee Łukasz Zemczak (sil2100)
2019-10-29 09:34:04 Łukasz Zemczak ubuntu-release-upgrader (Ubuntu Disco): importance Undecided Medium
2019-10-30 05:49:34 Launchpad Janitor ubuntu-release-upgrader (Ubuntu Focal): status Triaged Fix Released
2019-10-30 13:11:20 Launchpad Janitor virtualbox (Ubuntu Disco): status New Confirmed
2019-10-30 17:27:50 Robie Basak ubuntu-release-upgrader (Ubuntu Disco): status Triaged Fix Committed
2019-10-30 17:27:53 Robie Basak bug added subscriber Ubuntu Stable Release Updates Team
2019-10-30 17:27:54 Robie Basak bug added subscriber SRU Verification
2019-10-30 17:27:58 Robie Basak tags amd64 apport-bug eoan id-5db1d1e0a5035a6075816b57 regression-release amd64 apport-bug eoan id-5db1d1e0a5035a6075816b57 regression-release verification-needed verification-needed-disco
2019-10-30 17:55:26 Adam Conrad ubuntu-release-upgrader (Ubuntu Eoan): status Triaged Fix Committed
2019-10-30 17:55:34 Adam Conrad tags amd64 apport-bug eoan id-5db1d1e0a5035a6075816b57 regression-release verification-needed verification-needed-disco amd64 apport-bug eoan id-5db1d1e0a5035a6075816b57 regression-release verification-needed verification-needed-disco verification-needed-eoan
2019-10-31 04:50:40 Mathew Hodson bug added subscriber Mathew Hodson
2019-11-02 02:04:29 Mathew Hodson bug task deleted virtualbox (Ubuntu)
2019-11-02 02:05:47 Mathew Hodson bug task deleted virtualbox (Ubuntu Disco)
2019-11-02 02:05:53 Mathew Hodson bug task deleted virtualbox (Ubuntu Eoan)
2019-11-02 02:05:59 Mathew Hodson bug task deleted virtualbox (Ubuntu Focal)
2019-11-02 02:06:08 Mathew Hodson removed subscriber Mathew Hodson
2019-11-02 02:11:40 Mathew Hodson tags amd64 apport-bug eoan id-5db1d1e0a5035a6075816b57 regression-release verification-needed verification-needed-disco verification-needed-eoan amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-needed verification-needed-disco verification-needed-eoan
2019-11-02 11:11:40 Danilo Piazzalunga tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-needed verification-needed-disco verification-needed-eoan amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-eoan verification-needed verification-needed-disco
2019-11-02 13:47:33 Danilo Piazzalunga tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-eoan verification-needed verification-needed-disco amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan verification-needed
2019-11-02 22:23:24 Mathew Hodson tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan verification-needed amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan
2019-11-05 05:56:13 Adam Conrad ubuntu-release-upgrader (Ubuntu Xenial): status New Fix Committed
2019-11-05 05:56:20 Adam Conrad tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan verification-needed verification-needed-xenial
2019-11-05 05:57:21 Adam Conrad ubuntu-release-upgrader (Ubuntu Bionic): status New Fix Committed
2019-11-05 05:57:28 Adam Conrad tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan verification-needed verification-needed-xenial amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan verification-needed verification-needed-bionic verification-needed-xenial
2019-11-05 20:23:43 Launchpad Janitor ubuntu-release-upgrader (Ubuntu Eoan): status Fix Committed Fix Released
2019-11-05 20:24:01 Adam Conrad removed subscriber Ubuntu Stable Release Updates Team
2019-11-07 14:25:03 Łukasz Zemczak ubuntu-release-upgrader (Ubuntu Disco): status Fix Committed In Progress
2019-11-07 14:25:08 Łukasz Zemczak ubuntu-release-upgrader (Ubuntu Eoan): status Fix Released In Progress
2019-11-07 14:25:12 Łukasz Zemczak ubuntu-release-upgrader (Ubuntu Bionic): status Fix Committed In Progress
2019-11-07 14:25:16 Łukasz Zemczak ubuntu-release-upgrader (Ubuntu Xenial): status Fix Committed In Progress
2019-11-08 18:23:23 Brian Murray ubuntu-release-upgrader (Ubuntu Eoan): status In Progress Fix Committed
2019-11-08 18:23:26 Brian Murray bug added subscriber Ubuntu Stable Release Updates Team
2019-11-08 18:23:33 Brian Murray tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan verification-needed verification-needed-bionic verification-needed-xenial amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-needed verification-needed-bionic verification-needed-eoan verification-needed-xenial
2019-11-08 18:25:45 Brian Murray ubuntu-release-upgrader (Ubuntu Disco): status In Progress Fix Committed
2019-11-08 18:25:55 Brian Murray tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-needed verification-needed-bionic verification-needed-eoan verification-needed-xenial amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan verification-needed-xenial
2019-11-08 18:28:36 Brian Murray ubuntu-release-upgrader (Ubuntu Bionic): status In Progress Fix Committed
2019-11-08 18:30:00 Brian Murray ubuntu-release-upgrader (Ubuntu Xenial): status In Progress Fix Committed
2019-11-09 20:36:30 Brian Murray tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan verification-needed-xenial amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-failed-xenial verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan verification-needed-xenial
2019-11-11 14:15:55 Łukasz Zemczak tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-failed-xenial verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan verification-needed-xenial amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan verification-needed-xenial
2019-11-11 15:43:09 Łukasz Zemczak tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan verification-needed-xenial amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-eoan verification-needed verification-needed-bionic verification-needed-disco verification-needed-xenial
2019-11-11 16:08:12 Łukasz Zemczak tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-eoan verification-needed verification-needed-bionic verification-needed-disco verification-needed-xenial amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan verification-needed verification-needed-bionic verification-needed-xenial
2019-11-11 16:23:08 Łukasz Zemczak tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-disco verification-done-eoan verification-needed verification-needed-bionic verification-needed-xenial amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-bionic verification-done-disco verification-done-eoan verification-needed verification-needed-xenial
2019-11-11 16:32:06 Łukasz Zemczak tags amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done-bionic verification-done-disco verification-done-eoan verification-needed verification-needed-xenial amd64 apport-bug dist-upgrade eoan id-5db1d1e0a5035a6075816b57 verification-done verification-done-bionic verification-done-disco verification-done-eoan verification-done-xenial
2019-11-20 19:19:20 Launchpad Janitor ubuntu-release-upgrader (Ubuntu Eoan): status Fix Committed Fix Released
2019-11-20 19:19:35 Launchpad Janitor ubuntu-release-upgrader (Ubuntu Disco): status Fix Committed Fix Released
2019-11-20 19:20:07 Launchpad Janitor ubuntu-release-upgrader (Ubuntu Bionic): status Fix Committed Fix Released
2019-11-20 19:20:41 Launchpad Janitor ubuntu-release-upgrader (Ubuntu Xenial): status Fix Committed Fix Released