do-release-upgrade crashed with AttributeError in tryMarkObsoleteForRemoval(): 'Package' object has no attribute 'section'

Bug #1841675 reported by Bart Thevis on 2019-08-27
120
This bug affects 18 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Łukasz Zemczak
Eoan
Medium
Łukasz Zemczak

Bug Description

After every startup. System is up-to-date

ProblemType: Crash
DistroRelease: Ubuntu 19.10
Package: ubuntu-release-upgrader-core 1:19.10.10
ProcVersionSignature: Ubuntu 5.2.0-13.14-generic 5.2.8
Uname: Linux 5.2.0-13-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
CrashDB: ubuntu
Date: Tue Aug 27 23:22:58 2019
ExecutablePath: /usr/bin/do-release-upgrade
InstallationDate: Installed on 2019-08-20 (7 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190819)
InterpreterPath: /usr/bin/python3.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 /usr/lib/ubuntu-release-upgrader/do-partial-upgrade --frontend=DistUpgradeViewGtk3
Python3Details: /usr/bin/python3.7, Python 3.7.4, python3-minimal, 3.7.3-1
PythonArgs: ['/usr/bin/do-release-upgrade', '--frontend=DistUpgradeViewGtk3']
PythonDetails: /usr/bin/python2.7, Python 2.7.16+, python-minimal, 2.7.16-1
SourcePackage: ubuntu-release-upgrader
Title: do-release-upgrade crashed with AttributeError in tryMarkObsoleteForRemoval(): 'Package' object has no attribute 'section'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

VarLogDistupgradeTermlog:

Related branches

Bart Thevis (bthevis) wrote :
tags: removed: need-duplicate-check
Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
tags: added: rls-ee-incoming
information type: Private → Public
dinamic (dinamic6661) wrote :

same here, just updated today (2019-08-29). yesterday's update was fine

Brian Murray (brian-murray) wrote :

This appears in one of the duplicate bugs:

Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) libedata-book-1.2-25:amd64 < 3.32.2-2 @ii mK Ib >
Broken libedata-book-1.2-25:amd64 Depends on libebackend-1.2-10:amd64 < 3.32.2-2 -> 3.33.4-1 @ii umU > (= 3.32.2-2)
  Considering libebackend-1.2-10:amd64 8 as a solution to libedata-book-1.2-25:amd64 1
  Removing libedata-book-1.2-25:amd64 rather than change libebackend-1.2-10:amd64
Investigating (0) libebook-1.2-19:amd64 < 3.32.2-2 @ii mK Ib >
Broken libebook-1.2-19:amd64 Depends on libedata-book-1.2-25:amd64 < 3.32.2-2 @ii mR > (= 3.32.2-2)
  Considering libedata-book-1.2-25:amd64 1 as a solution to libebook-1.2-19:amd64 0
  Removing libebook-1.2-19:amd64 rather than change libedata-book-1.2-25:amd64
Investigating (0) libedata-cal-1.2-29:amd64 < 3.32.2-2 @ii mK Ib >
Broken libedata-cal-1.2-29:amd64 Depends on libebackend-1.2-10:amd64 < 3.32.2-2 -> 3.33.4-1 @ii umU > (= 3.32.2-2)
  Considering libebackend-1.2-10:amd64 8 as a solution to libedata-cal-1.2-29:amd64 0
  Removing libedata-cal-1.2-29:amd64 rather than change libebackend-1.2-10:amd64
Done
ERROR:root:not handled exception:
Traceback (most recent call last):

  File "/usr/lib/ubuntu-release-upgrader/do-partial-upgrade", line 114, in <module>
    controller.doPartialUpgrade()

  File "/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeController.py", line 2095, in doPartialUpgrade
    if not self.askDistUpgrade():

  File "/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeController.py", line 1154, in askDistUpgrade
    changes = self.calcDistUpgrade()

  File "/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeController.py", line 1117, in calcDistUpgrade
    if not self.cache.distUpgrade(self._view, self.serverMode, self._partialUpgrade):

  File "/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeCache.py", line 241, in wrapper
    res = f(*args, **kwargs)

  File "/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeCache.py", line 609, in distUpgrade
    self.keep_installed_rule()

  File "/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeCache.py", line 463, in keep_installed_rule
    and pkg.marked_delete and pkg.section == section):

AttributeError: 'Package' object has no attribute 'section'

tags: removed: rls-ee-incoming

No problems anymore since this week (wednesday) updates.

Launchpad Bug Tracker schreef op di 27-08-2019 om 23:00 [+0000]:
> Status changed to 'Confirmed' because the bug affects multiple users.
>
> ** Changed in: ubuntu-release-upgrader (Ubuntu)
> Status: New => Confirmed
>

tags: added: id-5d67f902a91f1d4cce5576ab
dinamic (dinamic6661) wrote :

this bug is not fixed, happened to me again today

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: Confirmed → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Eoan):
assignee: nobody → Łukasz Zemczak (sil2100)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:19.10.14

---------------
ubuntu-release-upgrader (1:19.10.14) eoan; urgency=medium

  * DistUpgrade/DistUpgradeCache.py: New python3-apt bindings no longer provide
    Package.section, so switch to using Package.{candidate,installed}.section
    whenever applicable. This fixes broken partial upgrades. (LP: #1841675)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 10 Oct 2019 09:59:30 +0200

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: In Progress → Fix Released
Łukasz Zemczak (sil2100) wrote :

@dinamic6661 Hey! We released a fixed ubuntu-release-upgrader for this issue - could you check if you can reproduce the bug with version 1:19.10.14? Thanks!

Hello Bart, or anyone else affected,

Accepted ubuntu-release-upgrader into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:19.10.15.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: Fix Released → Fix Committed
tags: added: verification-needed verification-needed-eoan
Brian Murray (brian-murray) wrote :

The upload of ubuntu-release-upgrader 19.10.15.2 was about building the release upgrader tarball as that was broken. Given that the fix for this bug is not actually in code that runs in the release upgrader tarball I am setting this to verification-done.

tags: added: verification-done verification-done-eoan
removed: verification-needed verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:19.10.15.2

---------------
ubuntu-release-upgrader (1:19.10.15.2) eoan; urgency=medium

  * Fix binary and binary-indep targets to work as intended (LP: #1850851)

ubuntu-release-upgrader (1:19.10.15.1) eoan; urgency=medium

  * do-release-upgrade: also check for linux-image- in reboot-required.pkgs,
    refusing upgrading before a reboot is performed. (LP: #1844805)

ubuntu-release-upgrader (1:19.10.15) eoan; urgency=medium

  * Don't check for validity of /usr/bin/python symlink because this is no
    longer relevant to the upgrades (and the printed error message was
    inaccurate). LP: #1825655.
  * Clean up remaining references to /usr/bin/python (tests and utilities)
    in the source.

ubuntu-release-upgrader (1:19.10.14) eoan; urgency=medium

  * DistUpgrade/DistUpgradeCache.py: New python3-apt bindings no longer provide
    Package.section, so switch to using Package.{candidate,installed}.section
    whenever applicable. This fixes broken partial upgrades. (LP: #1841675)

ubuntu-release-upgrader (1:19.10.13) eoan; urgency=medium

  [ Brian Murray ]
  * DistUpgrade/DistUpgradeQuirks.py: do not include gnome-system-monitor in
    the deb to snap transition anymore. (LP: #1845485)
  * DistUpgrade/DistUpgradeQuirks.py: improve wording regarding not being able
    to upgrade from a system with an apt architecture of i386.

  [ Łukasz 'sil2100' Zemczak ]
  * DistUpgrade/DistUpgradeQuirks.py: slightly refactor code to fix related
    unit tests.

 -- Adam Conrad <email address hidden> Thu, 31 Oct 2019 13:38:35 -0600

Changed in ubuntu-release-upgrader (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers