python3-distupgrade missing a dep on python3-distro-info

Bug #1824866 reported by Brian Murray on 2019-04-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned
Bionic
Medium
Brian Murray

Bug Description

[Impact]
Release upgrades on a system w/o python3-distro-info will crash.

[Test Case]
On a bionic-amd64 chroot:

(bionic-amd64)root@impulse:/home/bdmurray/Documents# do-release-upgrade
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [819 B]
Get:2 Upgrade tool [1250 kB]
Fetched 1251 kB in 0s (0 B/s)
authenticate 'cosmic.tar.gz' against 'cosmic.tar.gz.gpg'
extracting 'cosmic.tar.gz'

A fatal error occurred

Please report this as a bug and include the files
/var/log/dist-upgrade/main.log and /var/log/dist-upgrade/apt.log in
your report. The upgrade has aborted.
Your original sources.list was saved in
/etc/apt/sources.list.distUpgrade.

Traceback (most recent call last):

File "/tmp/ubuntu-release-upgrader-wvzfz5ou/cosmic", line 8, in
<module>
sys.exit(main())

File
"/tmp/ubuntu-release-upgrader-wvzfz5ou/DistUpgrade/DistUpgradeMain.py",
line 224, in main
from .DistUpgradeController import DistUpgradeController

File
"/tmp/ubuntu-release-upgrader-wvzfz5ou/DistUpgrade/DistUpgradeController.py",
line 25, in <module>
import distro_info

ModuleNotFoundError: No module named 'distro_info'

With the version of the package from -proposed you'll receive no such traceback.

[Regression Potential]
We are just adding a new dependency so none.

Original Description
--------------------
This a result of the SRU of the fix for bug 1799310 while the new dependency was added to the cosmic version of u-r-u that doesn't help because the dist-upgrader tarball doesn't reflect that dependency.

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Medium
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
milestone: none → bionic-updates
description: updated
description: updated
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)

Hello Brian, or anyone else affected,

Accepted ubuntu-release-upgrader into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:18.04.33 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

I tested the new version of ubuntu-release-upgrader in bionic-proposed and confirm that the bug is now fixed.

(bionic-amd64)root@impulse:~# apt-cache policy ubuntu-release-upgrader-core
ubuntu-release-upgrader-core:
  Installed: 1:18.04.33
  Candidate: 1:18.04.33
  Version table:
 *** 1:18.04.33 500
        500 http://192.168.10.7/ubuntu bionic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1:18.04.32 500
        500 http://192.168.10.7/ubuntu bionic-updates/main amd64 Packages
     1:18.04.17 500
        500 http://192.168.10.7/ubuntu bionic/main amd64 Packages
(bionic-amd64)root@impulse:~# do-release-upgrade
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [819 B]
Get:2 Upgrade tool [1249 kB]
Fetched 1250 kB in 0s (0 B/s)
authenticate 'cosmic.tar.gz' against 'cosmic.tar.gz.gpg'
extracting 'cosmic.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
Hit http://192.168.10.7/ubuntu bionic InRelease
Hit http://192.168.10.7/ubuntu bionic-updates InRelease
Hit http://192.168.10.7/ubuntu bionic-proposed InRelease
Hit http://security.ubuntu.com/ubuntu bionic-security InRelease
Fetched 0 B in 0s (0 B/s)
Reading package lists... Done
Building dependency tree
Reading state information... Done

Updating repository information

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.04.33

---------------
ubuntu-release-upgrader (1:18.04.33) bionic; urgency=medium

  * DistUpgrade/DistUpgradeViewNonInteractive.py: when responding to a
    conffile prompt with "n" use bytes not a string. (LP: #1796193)
  * debian/control: add an explicit python3-distro-info dependency to
    python3-distupgrade as it is now required by DistUpgradeController.
    (LP: #1824866)
  * pre-build.sh: stop updating demotions for artful since it is no longer
    available at archive.ubuntu.com and if we do update then demotions becomes
    an empty file which is wrong.

 -- Brian Murray <email address hidden> Wed, 15 May 2019 10:37:15 -0700

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers