distribution upgrade bug - upgrading to 18.10

Bug #1799855 reported by B K on 2018-10-25
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

[Impact]

Without this, upgrades from Lubuntu 18.04 to 18.10 don't work properly and display an error as shown below.

[Test Case]

Using a Lubuntu 18.04 system, ensuring that "Prompt=normal" is set in /etc/update-manager/release-upgrades, run `do-release-upgrade -p`.

[Regression Potential]

Little to none. This could only regress if lubuntu-core was re-introduced into Cosmic, which is very unlikely at this point in time.

[Original Description]

Can't install 'lubuntu-core'

It was impossible to install a required package. Please report this as a bug using 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.27
ProcVersionSignature: Ubuntu 4.15.0-38.41-generic 4.15.18
Uname: Linux 4.15.0-38-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: LXDE
Date: Wed Oct 24 21:58:18 2018
InstallationDate: Installed on 2018-06-17 (129 days ago)
InstallationMedia: Lubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to bionic on 2018-10-25 (0 days ago)
VarLogDistupgradeTermlog:

mtime.conffile..etc.update-manager.release-upgrades: 2018-06-17T14:56:38.161228

B K (darklink259) wrote :
tags: added: bionic2cosmic
tags: added: third-party-packages
Brian Murray (brian-murray) wrote :

From VarLogDistupgradeMainlog.txt:

2018-10-24 21:53:36,473 DEBUG none of the '['ubuntu-desktop', 'kubuntu-desktop', 'xubuntu-core', 'xubuntu-desktop', 'ubuntustudio-desktop', 'mythbuntu-desktop', 'kubuntu-netbook', 'lubuntu-core', 'lubuntu-desktop', 'ubuntu-gnome-desktop', 'ubuntu-mate-core', 'ubuntu-mate-desktop', 'ubuntukylin-desktop', 'ubuntu-budgie-desktop']' meta-pkgs installed
2018-10-24 21:53:36,473 DEBUG guessing 'lubuntu-core' as missing meta-pkg
2018-10-24 21:53:36,473 ERROR failed to mark 'lubuntu-core' for install ("The cache has no package named 'lubuntu-core'")

The lubuntu-core package seems to have been removed from the archive for cosmic. Please try installing lubuntu-dekstop and then upgrading again.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
Brian Murray (brian-murray) wrote :

It'd probably be worth updating the following file to reflect the fact that lubuntu-core went away.

https://bazaar.launchpad.net/~ubuntu-core-dev/ubuntu-release-upgrader/trunk/view/head:/data/DistUpgrade.cfg

B K (darklink259) wrote :

installing lubuntu-desktop seemed to work, thanks!

Walter Lapchynski (wxl) wrote :

This is fixed in Dingo. We'll SRU for Cosmic. More info here:
https://phab.lubuntu.me/T137

Changed in ubuntu-release-upgrader (Ubuntu):
status: Incomplete → Triaged
status: Triaged → In Progress
Simon Quigley (tsimonq2) on 2019-02-02
description: updated

Hello B, or anyone else affected,

Accepted ubuntu-release-upgrader into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:18.10.11.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Brian Murray (brian-murray) wrote :
Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
Walter Lapchynski (wxl) on 2019-02-04
description: updated
Chris Guiver (guiverc) wrote :

I tried to `do-release-upgrade -p` a x86 box (18.04) and failed

"apt architecture is i386
Upgrades from 18.04 on the i386 architecture are not supported at this time."

this result is probably expected (& unrelated); but I'm noting here in-case it's an issue.

Chris Guiver (guiverc) wrote :

`do-release-upgrade -p` performed on a recently created/install 18.04.2 (qa-test install)
this was on a vm (virtual box, fedora 29 host)
note: i ran do-release-upgrade logged into gui in error (i usually use console)

lubuntu 18.10 booted, brief play with it & everything looked normal
No errors mentioning "lubuntu-core" (no error messages except warnings I've mentioned)
No error "impossible to install a required package, please report..."

--- notes of process follow
started with 18.04.2 on virtual machine

I added `vim`, pointed vm to my ISP mirror (ftp.iinet.net.au; which is on https://launchpad.net/ubuntu/+archivemirrors) as that bandwidth isn't counted in my monthly quota. (I manually replaced `%s/^deb/# deb/g` & added lines for my isp's mirror (bionic, -updates & -security, main universe multiverse restricted).

i then dist-upgraded (no kernel updates) so next `do-release-upgrade -p`

but had

"Updating repository information
No valid mirror found
While scanning your repository information no mirror entry for the
upgrade was found. This can happen...."

I'm not sure if this is an issue, but I continued..

..
6 installed packages are no longer supported by Canonical ...

-- (a few questions), eventually asked to reboot

lubuntu 18.10 booted, brief play with it & everything looked normal
No errors mentioning "lubuntu-core" (no error messages except warnings I've mentioned)
No error "impossible to install a required package, please report..."

Brian Murray (brian-murray) wrote :

@Chris - I'm not certain this is an adequate test of the upgrade process given that you manually modified /etc/apt/sources.list and then ran do-release-upgrade. If you want to confirm that this bug is fixed please skip modifying your sources.list file and just run 'do-release-upgrade -p'. Thanks!

Chris Guiver (guiverc) wrote :

I can only test this late in the month then (if bandwidth, but mostly easier to calculate how long I'll be suffering dial-up speeds...)

Chris Guiver (guiverc) wrote :
Download full text (4.0 KiB)

lubuntu 18.04.2 qa-test install: virtual machine on sony vaio ultrabook (i5-9400u, 4gb, intel haswell-ULT); host is lubuntu 19.04

I didn't use `vim` to change sources, but found I could achieve equivalent with synaptic [package manager] which was pre-installed on Lubuntu 18.04; settings->repositories and selecting using drop down australia->ftp.iinet.net.au. i made no other changes
(note: mine wasn't identical, I don't recall adding -backports & had 'main universe multiverse restricted' for bionic, -updates, -security)

i `sudo vi /etc/update-manager/release-upgrades` ("=normal"); `sudo apt update` (probably pointless but ..)

`do-release-upgrade -p`

..
6 installed packages are no longer supported by Canonical. You can ..
..
on questions I used default (eg. lightdm as it was highlighted, not sddm or what I assume most users would do), package-maintainers-version, (y) remove obselete packages (probabe some users are likely to choose no for this), reboot (y)

login (after reboot), brief explore & it's LXQt desktop, reboot(vm) & again login and [still] looks correct

            .-/+oossssoo+/-. guiverc@lubu-sru-test
        `:+ssssssssssssssssss+:` ---------------------
      -+ssssssssssssssssssyyssss+- OS: Ubuntu 18.10 x86_64
    .ossssssssssssssssssdMMMNysssso. Host: VirtualBox 1.2
   /ssssssssssshdmmNNmmyNMMMMhssssss/ Kernel: 4.18.0-15-generic
  +ssssssssshmydMMMMMMMNddddyssssssss+ Uptime: 2 mins
 /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/ Packages: 2188 (dpkg)
.ssssssssdMMMNhsssssssssshNMMMdssssssss. Shell: bash 4.4.19
+sssshhhyNMMNyssssssssssssyNMMMysssssss+ Resolution: 800x600
ossyNMMMNyMMhsssssssssssssshmmmhssssssso DE: LXQt
ossyNMMMNyMMhsssssssssssssshmmmhssssssso WM: Openbox
+sssshhhyNMMNyssssssssssssyNMMMysssssss+ Theme: Arc-Darker [GTK3]
.ssssssssdMMMNhsssssssssshNMMMdssssssss. Icons: Adwaita [GTK3]
 /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/ Terminal: qterminal ...

Read more...

Dan Simmons (kc2bez) wrote :

I installed a fresh Lubuntu 18.04 system in a virtual machine, I set "Prompt=normal" in /etc/update-manager/release-upgrades, then ran `do-release-upgrade -p`. I followed the normal upgrade prompts, selected SDDM. The upgrader prompted me to restart and after restart the SDDM login screen appeared. After I logged in the LXQt desktop environment started. I did not receive any errors throughout the process.

After the update here is the following for lsb_release and uname:

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.10
Release: 18.10
Codename: cosmic

uname -a
Linux dan-VBox-1804 4.18.0-15-generic #16-Ubuntu SMP Thu Feb 7 10:56:39 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Walter Lapchynski (wxl) wrote :

Since Dan had a normal upgrade with no quirks, I compared the logs between Chris and Dan and they looked basically equivalent, so I'm calling this good.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.10.11.5

---------------
ubuntu-release-upgrader (1:18.10.11.5) cosmic; urgency=medium

  * Remove lubuntu-core from the list of metapackages, fixing some upgrades
    from Lubuntu 18.04 to 18.10 (LP: #1799855).

 -- Simon Quigley <email address hidden> Fri, 01 Feb 2019 18:52:07 -0600

Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers