release upgrader has no icon in gnome-shell dock

Bug #1797384 reported by Iain Lane on 2018-10-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray
Bionic
High
Brian Murray
Cosmic
High
Brian Murray

Bug Description

[Impact]
You don't see an icon for the release upgrade in gnome-shell's dock.

[Test Case]
1) On cosmic run '/usr/lib/ubuntu-release-upgrader/check-new-release-gtk with the -d switch
2) Observe a dialog box regarding "Upgrade available" notice there is no icon in gnome-shell's dock
3) Click "yes" upgrade now
4) Observe the Release Notes dialog and notice there is no icon in gnome-shell's dock
5) Click upgrade
6) Now observe that there is an icon in gnome-shell's dock (this is because we've downloaded the next release's dist-upgrader tarball

Additionally, 'do-release-upgrade --frontend DistUpgradeViewGtk3' should be tested and an icon check for in gnome-shell's dock.

[Regression Potential]
None as we are just adding an icon for the release upgrade dialogs

Was running through the upgrade testcase

  http://iso.qa.ubuntu.com/qatracker/milestones/390/builds/181996/testcases/1310/results

between step 4 and 5, the release upgrader is spawned. It has the "icon not found" icon instead of a proper one. update-manager itself is fine.

Related branches

Iain Lane (laney) wrote :
Iain Lane (laney) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1797384

tags: added: iso-testing
Brian Murray (brian-murray) wrote :

Do you think reusing update-manager's icon would be okay?

Iain Lane (laney) wrote :

for the record:

11/10 19:10:14 <bdmurray> Laney: Did you see my comment on bug 1797384?
11/10 19:10:14 <ubottu> bug 1797384 in ubuntu-release-upgrader (Ubuntu) "release upgrader has no icon in gnome-shell dock" [Undecided,New] https://launchpad.net/bugs/1797384
11/10 20:02:05 <Laney> bdmurray: no, but yes that'd probably be fine :-)

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
importance: Medium → High
tags: added: rls-dd-incoming
Changed in ubuntu-release-upgrader (Ubuntu):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
Brian Murray (brian-murray) wrote :

ubuntu-release-upgrader actually uses multiple dialogs and some of them are in the dist-upgrader and some of them are from the ubuntu-release-upgrader install on the system, so to fix this everywhere will require u-r-u updates in cosmic and disco. The SRU should also be done in Ubuntu 18.04 since it is an LTS.

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
assignee: nobody → Brian Murray (brian-murray)
Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
assignee: nobody → Brian Murray (brian-murray)
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
importance: Undecided → High
Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:19.04.4

---------------
ubuntu-release-upgrader (1:19.04.4) disco; urgency=medium

  * Set icon_name in the dialogs so that there will be an icon in gnome-shell.
    (LP: #1797384)

 -- Brian Murray <email address hidden> Wed, 07 Nov 2018 15:55:25 -0800

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
description: updated
description: updated
Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
status: New → In Progress
Brian Murray (brian-murray) wrote :

Verifying this on bionic is dependent on using the -p switch with do-release-upgrade / check-new-release-gtk or waiting until the cosmic SRU is in -updates.

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: New → In Progress

Hello Iain, or anyone else affected,

Accepted ubuntu-release-upgrader into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:18.10.11.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
status: In Progress → Fix Committed
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Adam Conrad (adconrad) wrote :

This was accepted to bionic too, but the tool ran into a locking issue and didn't comment. Go forth and verify both.

tags: added: verification-needed-bionic
Brian Murray (brian-murray) wrote :

I tested the release upgrade process from Cosmic to Disco and confirm that there are no icons throughout all stages of the upgrade process screenshots attached.

Brian Murray (brian-murray) wrote :

Release notes screen for disco.

Brian Murray (brian-murray) wrote :

Screenshot from when the dist-upgrader tarball was being run.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Brian Murray (brian-murray) wrote :

I tested the upgrade process from Bionic to Cosmic and confirm that there are icons through all stages of the upgrade process, screenshots attached.

And in comment #11 I meant that there "are now icons".

Brian Murray (brian-murray) wrote :

Release notes.

I had to run /usr/lib/ubuntu-release-upgrader/check-new-release-gtk with -d to be able able to see the icons when running the cosmic dist-upgrader tarball. This was expected though.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.10.11.2

---------------
ubuntu-release-upgrader (1:18.10.11.2) cosmic; urgency=medium

  * Set icon_name in the dialogs so that there will be an icon in gnome-shell.
    (LP: #1797384)

 -- Brian Murray <email address hidden> Mon, 12 Nov 2018 13:04:53 -0800

Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.04.29

---------------
ubuntu-release-upgrader (1:18.04.29) bionic; urgency=medium

  * Set icon_name in the dialogs so that there will be an icon in gnome-shell.
    (LP: #1797384)

 -- Brian Murray <email address hidden> Mon, 12 Nov 2018 13:09:05 -0800

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers