ubuntu-release-upgrader-core missing a dependency

Bug #1796940 reported by Brian Murray on 2018-10-09
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Medium
Brian Murray
Xenial
High
Brian Murray
Bionic
High
Unassigned

Bug Description

Test Case
---------
1) Install ubuntu-release-upgrader-core on an 18.04 chroot
2) Edit /etc/update-manager/release-upgrades set Prompt=normal
3) Run 'do-release-upgrade -d'
4) Observe the following

(bionic-amd64)root@impulse:~# do-release-upgrade -d
Checking for a new Ubuntu release
Failed to connect to https://changelogs.ubuntu.com/meta-release-development. Check your Internet connection or proxy settings
Upgrades to the development release are only
available from the latest supported release.

Installing ca-certificates resolves the issue, this was likely caused by the fix for bug 1744318.

Related branches

tags: added: bionic cosmic
description: updated
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.10.11

---------------
ubuntu-release-upgrader (1:18.10.11) cosmic; urgency=medium

  * do-release-upgrade: do not run the release upgrade if either not all
    updates are installed or a reboot is required due to a libc6 upgrade.
    (LP: #1797209)
  * debian/control: change ubuntu-release-upgrader-core to depend on
    ca-certificates (LP: #1796940)
  * Update of demotions and mirrors data.

 -- Brian Murray <email address hidden> Wed, 10 Oct 2018 14:10:29 -0700

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released

Hello Brian, or anyone else affected,

Accepted ubuntu-release-upgrader into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:18.04.27 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

I tested this with ubuntu-release-upgrader-core version 1:18.04.27 from bionic-proposed. When installing the updated version of the package both ca-certificates and openssl were installed.

(bionic-amd64)root@impulse:~# apt install ubuntu-release-upgrader-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  ca-certificates openssl python3-distupgrade
The following NEW packages will be installed:
  ca-certificates openssl
The following packages will be upgraded:
  python3-distupgrade ubuntu-release-upgrader-core

After which I no longer received the error message when trying to upgrade.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.04.27

---------------
ubuntu-release-upgrader (1:18.04.27) bionic; urgency=medium

  * do-release-upgrade: do not run the release upgrade if either not all
    updates are installed or a reboot is required due to a libc6 upgrade.
    (LP: #1797209)
  * debian/control: change ubuntu-release-upgrader-core to depend on
    ca-certificates (LP: #1796940)
  * Update mirrors data.

 -- Brian Murray <email address hidden> Fri, 12 Oct 2018 11:27:19 -0700

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Steve Langasek (vorlon) wrote :

This bug also affects upgrades from xenial to bionic.

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
tags: added: id-5eac9778b1aacf294e46e296

Hello Brian, or anyone else affected,

Accepted ubuntu-release-upgrader into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:16.04.30 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done
Brian Murray (brian-murray) wrote :

I've verified this fix on Ubuntu 16.04 LTS.

(xenial-amd64)root@impulse:/home/bdmurray# apt-cache policy ubuntu-release-upgrader-core
ubuntu-release-upgrader-core:
  Installed: 1:16.04.30
  Candidate: 1:16.04.30
  Version table:
 *** 1:16.04.30 500
        500 http://ubuntu.osuosl.org/ubuntu xenial-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1:16.04.29 500
        500 http://ubuntu.osuosl.org/ubuntu xenial-updates/main amd64 Packages
     1:16.04.25 500
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     1:16.04.12 500
        500 http://ubuntu.osuosl.org/ubuntu xenial/main amd64 Packages

(xenial-amd64)root@impulse:/home/bdmurray# do-release-upgrade
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [819 B]
Get:2 Upgrade tool [1242 kB]
Fetched 1243 kB in 0s (0 B/s)
authenticate 'bionic.tar.gz' against 'bionic.tar.gz.gpg'
extracting 'bionic.tar.gz'

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Mathew Hodson (mhodson) on 2020-05-07
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
importance: Undecided → High
tags: added: unmetdeps
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:16.04.30

---------------
ubuntu-release-upgrader (1:16.04.30) xenial; urgency=medium

  * debian/control: change ubuntu-release-upgrader-core to depend on
    ca-certificates (LP: #1796940)
  * Update mirrors data.

 -- Brian Murray <email address hidden> Fri, 01 May 2020 16:06:05 -0700

Changed in ubuntu-release-upgrader (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers