Cant update Kubuntu 16.04 to 18.04 updater crashes displaying "could not calculate the update"

Bug #1787579 reported by Rex Manuel on 2018-08-17

This bug report will be marked for expiration in 24 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Undecided
Unassigned

Bug Description

Updater crashes with screen as I reported earlier "https://bugs.launchpad.net/ubuntu/+source/ubuntu-release-upgrader/+bug/1787383". Removed the kubuntu-backports PPA as recommended by Brian, still the same problem.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.25
ProcVersionSignature: Ubuntu 4.4.0-78.99-generic 4.4.62
Uname: Linux 4.4.0-78-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: KDE
Date: Fri Aug 17 12:52:59 2018
InstallationDate: Installed on 2015-03-05 (1261 days ago)
InstallationMedia: Ubuntu 12.04.5 LTS "Precise Pangolin" - Release amd64 (20140807)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: ubuntu-release-upgrader
UpgradeStatus: Upgraded to xenial on 2018-08-17 (0 days ago)
VarLogDistupgradeTermlog:

Rex Manuel (rexmanuelin) wrote :
tags: added: xenial2bionic
tags: added: third-party-packages
Brian Murray (brian-murray) wrote :

Now there is a failure due to the xorg PPA you are using.

deb http://ppa.launchpad.net/oibaf/graphics-drivers/ubuntu xenial main

Please also remove that PPA using ppa-purge and try the upgrade again. Thanks!

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
Rex Manuel (rexmanuelin) wrote :

Thanks a lot Brian it worked. removed kubuntu-backports and oibaf/graphics-drivers ppa using the ppa-purge then update issue was fixed and now upgraded to 18.04. Thanks again for your valuable time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers