_checkStoreConnectivity uses translatable strings for error checking

Bug #1783738 reported by Jean-Baptiste Lallement on 2018-07-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
High
Brian Murray
Bionic
Medium
Brian Murray

Bug Description

[Impact]
There currently are not any translation files for snappy that I could find for Ubuntu 16.04, the release from which an upgrade would be happening, however those might be SRU'ed so its still worth fixing.

[Test Case]
Given that there are no translations of snappy in Ubuntu 16.04 yet we should just test that there are no regressions. This can be done by ensuring that you are running an old version of snapd which doesn't support the 'debug connectivity' command.

[Regression Potential]
Already addressed in the test case above.

In DistUpgradeQuirks.py in _checkStoreConnectivity there is this code:

451 elif 'error: unknown command' in connected[1]:
[...]
461 elif 'error: access denied' in connected[1]:

These tests will fail in a non-english language. For example in French:

u@vm:~$ snap debug xxx
erreur : unknown command "debug", see 'snap help'
u@vm:~$ snap debug connectivity
erreur : access denied (essayez avec sudo)

Related branches

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
tags: added: id-5b5b80eb89d784de8e6deacd
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.10.6

---------------
ubuntu-release-upgrader (1:18.10.6) cosmic; urgency=medium

  * DistUpgradeQuirks.py:
    - make sure that snapd is installed before trying to use it.
      (LP: #1783589)
    - update the view with information regarding the progress of snaps being
      installed. (LP: #1783593)
    - when checking for connectivity to the snap store use C.UTF-8 for the
      language so error message matching works. (LP: #1783738)
  * DistUpgradeController.py:
    - Remove debs from apt's "Dir::Cache::archives" folder after the upgrade
      has completed successfully.
    - Add a telemetry marker to report the time to process migration from deb
      to snaps.
  * DistUpgrade/DistUpgradeViewGtk3.py: call vte's terminal.feed_child() with
    the correct parameters thereby fixing a crash. (LP: #1780501)

 -- Brian Murray <email address hidden> Wed, 01 Aug 2018 15:06:53 -0700

Changed in ubuntu-release-upgrader (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Brian Murray (brian-murray)
Changed in ubuntu-release-upgrader (Ubuntu Bionic):
importance: High → Medium
description: updated

Hello Jean-Baptiste, or anyone else affected,

Accepted ubuntu-release-upgrader into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-release-upgrader/1:18.04.22 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

Here are the test results from an Ubuntu 16.04 with an old version of snapd and using the version of the dist-upgrader from bionic-proposed.

bdmurray@clean-xenial-amd64:~/u-r-u$ tail -n 20 /var/log/dist-upgrade/screenlog.0

Outdated snapd package

Your system does not have the latest version of snapd. Please update
the version of snapd on your system to improve the upgrade
experience.
Do you still want to continue with the upgrade?

Continue [yN] -- 0:bionic -- time-stamp -- Aug/06/18 11:09:39 --
-- 0:bionic -- time-stamp -- Aug/06/18 11:13:02 --
N

Restoring original system state

Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done

=== Command detached from window (Mon Aug 6 11:13:04 2018) ===bdmurray@clean-xenial-amd64:~/u-r-u$ head -n20 /var/log/dist-upgrade/main.log
2018-08-06 11:07:09,619 INFO Using config files '['./DistUpgrade.cfg.xenial']'
2018-08-06 11:07:09,619 INFO uname information: 'Linux clean-xenial-amd64 4.4.0-121-generic #145-Ubuntu SMP Fri Apr 13 13:47:23 UTC 2018 x86_64'
2018-08-06 11:07:09,923 INFO apt version: '1.2.26'
2018-08-06 11:07:09,924 INFO python version: '3.5.2 (default, Nov 23 2017, 16:37:01)
[GCC 5.4.0 20160609]'
2018-08-06 11:07:09,926 INFO release-upgrader version '18.04.22' started

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-release-upgrader - 1:18.04.22

---------------
ubuntu-release-upgrader (1:18.04.22) bionic; urgency=medium

  * DistUpgradeQuirks.py:
    - make sure that snapd is installed before trying to use it.
      (LP: #1783589)
    - update the view with information regarding the progress of snaps being
      installed. (LP: #1783593)
    - when checking for connectivity to the snap store use C.UTF-8 for the
      language so error message matching works. (LP: #1783738)
  * DistUpgradeController.py:
    - Remove debs from apt's "Dir::Cache::archives" folder after the upgrade
      has completed successfully. (LP: #1785096)
    - Add a telemetry marker to report the time to process the migration from
      deb to snaps.

 -- Brian Murray <email address hidden> Thu, 02 Aug 2018 11:20:06 -0700

Changed in ubuntu-release-upgrader (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-release-upgrader has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers