Failed to upgrade 16.04.4 to 18.04. Process aborted

Bug #1775883 reported by DanglingPointer
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-release-upgrader (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

Tried doing an upgrade from 16.04.4 to 18.04 by using the command

"sudo do-release-upgrade -d -m -desktop"

It failed giving the following errors:

(appstreamcli:16680): GLib-CRITICAL **: g_strchug: assertion 'string != NULL' failed

(appstreamcli:16680): GLib-CRITICAL **: g_strchomp: assertion 'string != NULL' failed

(appstreamcli:16680): GLib-CRITICAL **: g_strchug: assertion 'string != NULL' failed

(appstreamcli:16680): GLib-CRITICAL **: g_strchomp: assertion 'string != NULL' failed
AppStream cache update completed, but some metadata was ignored due to errors.

Checking package manager
Reading package lists... Done
Building dependency tree
Reading state information... Done

Calculating the changes

Calculating the changes

Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal.

Restoring original system state

Aborting
Reading package lists... Done
Building dependency tree
Reading state information... Done

========================================
$ lsb_release -rd
Description: Ubuntu 16.04.4 LTS
Release: 16.04

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: ubuntu-release-upgrader-core 1:16.04.25
ProcVersionSignature: Ubuntu 4.13.0-45.50~16.04.1-generic 4.13.16
Uname: Linux 4.13.0-45-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
CrashDB: ubuntu
CurrentDesktop: Unity
Date: Sat Jun 9 02:19:03 2018
InstallationDate: Installed on 2016-05-01 (768 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: Upgraded to xenial on 2018-06-08 (0 days ago)

Revision history for this message
DanglingPointer (ferncasado) wrote :
tags: added: xenial2bionic
Revision history for this message
Brian Murray (brian-murray) wrote :

You have installed packages from the ubuntu-toolchain test PPA and that is preventing the upgrader from calculating the upgrade as there are packages installed greater than the version in 18.04. Please use ppa-purge to remove that PPA and then try the upgrade again.

Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Invalid
Revision history for this message
DanglingPointer (ferncasado) wrote :

Will try and reply back here.
Thanks for the time looking it up.

Revision history for this message
Karun (karun-gahlawat) wrote :

i removed webupdjava8 that is all i saw. still the same error.

Revision history for this message
DanglingPointer (ferncasado) wrote :

Brian's suggestion solved my problem.

This bug can be closed. Apologies for the delay in replying. It was sorted back in June.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers